From: sundar.palaniappan@verizon.com
Date: Wed Aug 17 2005 - 22:24:29 GMT-3
Stefan,
I don't know if you have figured this out by now.
You are correct in that the only protocol that doesn't redistribute
connected networks is ISIS. You would have to explicitly redistribute
connected networks in addition to redistributing ISIS. All other IGPs
redistribute connected networks when the protocol they are running is
redistributed.
You should be seeing the loopback of R1 on R2's routing table as ISIS L2
route. You may want to check whether you have set the metric for rip or
using a default metric under ISIS process.
R1:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
ip router isis
!
router isis
redistribute rip metric 10
net 47.0001.0001.0002.00
!
router rip
version 2
network 1.0.0.0
no auto-summary
R2:
interface Ethernet0
ip address 10.1.1.2 255.255.255.0
ip router isis
!
router isis
net 47.0001.0001.0001.00
R2#show isis top
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
R2 --
R1 10 R1 Et0
00e0.b05b.1f4d
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
R2 --
R1 10 R1 Et0
00e0.b05b.1f4d
R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/32 is subnetted, 1 subnets
i L2 1.1.1.1 [115/20] via 10.1.1.1, Ethernet0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Ethernet0
R2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
HTH,
Sundar Palaniappan
CCIE #14532
"Quetta Walla"
<quetta_1@lycos.c To: ccielab@groupstudy.com
om> cc:
Sent by: Subject: RE: rip to isis redistribution!!
nobody@groupstudy
.com
08/16/2005 01:34
AM
Please respond to
"Quetta Walla"
And OSPF also behaves the same way. Try advertising a loop0 address in ospf
and then redistribute ospf in some other protocol. That loop0 is not going
to get redistributed. You can user a route-map for it if required to do so.
----- Original Message -----
From: "Chris Lewis (chrlewis)" <chrlewis@cisco.com>
To: "Stefan Grey" <examplebrain@hotmail.com>, ccielab@groupstudy.com
Subject: RE: rip to isis redistribution!!
Date: Mon, 15 Aug 2005 23:25:28 -0400
>
> You may have enabled RIP on the loopback, but nothing is more believable
> than a directly connected network. Look in your routing table, Loop 0
> will be a connected route. Remember redistribution starts off by looking
> at what routes from the redistrbuted protocol are in the routing table.
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Stefan Grey
> Sent: Monday, August 15, 2005 11:21 AM
> To: ccielab@groupstudy.com
> Subject: rip to isis redistribution!!
>
> lo0-R1- isis-R2
>
> Between R1 and R2 is a layer 2 isis connection. on lo0 is rip enabled.
>
> Then rip is redistributed on R1 to R2 using router isis redistribute rip
>
> command.
>
> The R2 doesn't get the Route to lo0. I don't understand why. It should
> be there shouldn't it. I heared that isis doesn't redistribute its
> directly connected networks to other protocols. Buts is it so for RIP.
>
> VEry suspicious.
> Thanks
>
> _________________________________________________________________
> Accurate weather reports for this week & the weekend!
> http://www.msn.ie/weather
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
--
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:01:19 GMT-3