EIGRP Timer

From: Ali.Huang (zero5291@gmail.com)
Date: Mon Aug 15 2005 - 02:19:49 GMT-3


Hi,
During I do EIGRP LAB,I found the hold time which have effect on routing stable.
Topo,
R4
|
R2(only S0)
| \
R5 R6
The following is routers' configuration:
R2#sh run
Building configuration...

Current configuration : 1527 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
logging rate-limit console 10 except errors
enable password cisco
!
ip subnet-zero
no ip finger
!
no ip dhcp-client network-discovery
!
!
!
!
interface Loopback0
 ip address 200.0.0.2 255.255.255.255
!
interface Ethernet0
 ip address 150.50.17.2 255.255.255.0
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 no arp frame-relay
 no frame-relay inverse-arp
!
interface Serial0.24 point-to-point
 ip address 150.50.24.2 255.255.255.0
 ip hello-interval eigrp 2 20
 ip hold-time eigrp 2 60
 frame-relay interface-dlci 401
!
interface Serial0.256 multipoint
 ip address 150.50.100.2 255.255.255.248
 ip hello-interval eigrp 1 20
 frame-relay map ip 150.50.100.2 402
 frame-relay map ip 150.50.100.5 402 broadcast
 frame-relay map ip 150.50.100.6 403 broadcast
 frame-relay interface-dlci 402
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 1
 redistribute eigrp 2
 network 150.50.17.0 0.0.0.255
 network 150.50.100.2 0.0.0.0
 network 200.0.0.2 0.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router eigrp 2
 redistribute eigrp 1
 network 150.50.24.2 0.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 privilege level 15
 no login
!
end
R4#sh run
Building configuration...
interface Ethernet0
 ip address 10.1.1.4 255.255.255.0
!
interface Serial0
 ip address 150.50.24.4 255.255.255.0
 ip hello-interval eigrp 2 20
 ip hold-time eigrp 2 60
 encapsulation frame-relay
 no arp frame-relay
 frame-relay map ip 150.50.24.2 104 broadcast
 frame-relay map ip 150.50.24.4 104
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 2
 network 10.1.1.4 0.0.0.0
 network 150.50.24.4 0.0.0.0
 no auto-summary
 no eigrp log-neighbor-changes
...

Symptoms:
First,I didn't issue ip hold-time eigrp 2 60 command on R2'S0.24 and R4 S0,
I issued ping 10.1.1.4 command and set repeat count to 1000 from
R2,then found some packets were lost about ten point every two
lines.And I can ping 150.50.24.4,that's OK.I issued show ip eigrp
neighbor,the hole time is under 180s,but the uptime is very shorter
than other neighbors,and always be reseted.Last I configured
hold-time,then OK.
Q1:As I knew,the hold time was sent with hello packets,and was used to
check whether its neighbors do exist or not,I set hello-interval to 20
seconds,the hold time is 180s(default).I think the links is stable,and
the routers can receive hello packets before out of hole-time.why was
some packets lost?
Q2:I didn't manually modify the hold time of R2'S0.256,but it works
well.I think the symptoms were occurs again,but it did't ,why?The
following statement is R2's neighbors.
R2#sh ip ei nei
IP-EIGRP neighbors for process 1
H Address Interface Hold Uptime SRTT RTO Q Seq Type
                                        (sec) (ms) Cnt Num
0 150.50.17.1 Et0 11 02:36:57 11 200 0 382
1 150.50.100.5 Se0.256 169 03:47:00 50 300 0 1262
2 150.50.100.6 Se0.256 169 03:49:00 46 276 0 1263
IP-EIGRP neighbors for process 2
H Address Interface Hold Uptime SRTT RTO Q Seq Type
                                        (sec) (ms) Cnt Num
0 150.50.24.4 Se0.24 51 00:56:13 160 960 0 553

I hope your help.
THX.
Ali.huang



This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:01:19 GMT-3