From: Gustavo Novais (gustavo.novais@novabase.pt)
Date: Sat Jul 30 2005 - 12:04:06 GMT-3
Hi, thanks for reply
I've set ip ospf priority on interfaces since my first email, and it worked.
When specifying neighbor command on a spoke router, with priority 0 on
interface, it just ignores me.
R2
interface Serial0/0
ip address 150.50.100.2 255.255.255.0
encapsulation frame-relay
ip ospf priority 100 < ---------------- with ip ospf
priority at the interface level it works
clockrate 256000
no arp frame-relay
frame-relay map ip 150.50.100.2 204
frame-relay map ip 150.50.100.4 204 tcp header-compression
frame-relay map ip 150.50.100.5 205
frame-relay map ip 150.50.100.6 206
no frame-relay inverse-arp
!
router ospf 1
log-adjacency-changes
area 1 nssa default-information-originate
area 1 nssa translate type7 suppress-fa
network 150.50.2.2 0.0.0.0 area 0
network 150.50.10.0 0.0.0.255 area 1
network 150.50.100.0 0.0.0.255 area 0
network 150.50.101.4 0.0.0.3 area 0
neighbor 150.50.100.4
neighbor 150.50.100.5
neighbor 150.50.100.6
!
But on the spoke
interface Serial0/0
ip address 150.50.100.5 255.255.255.0
encapsulation frame-relay
ip ospf priority 0 <--------------------------------------------again
at interface level it works
clockrate 256000
no arp frame-relay
frame-relay map ip 150.50.100.2 502
frame-relay map ip 150.50.100.4 502
frame-relay map ip 150.50.100.5 502
frame-relay map ip 150.50.100.6 502
no frame-relay inverse-arp
end
R5#sh run | b r o
router ospf 1
log-adjacency-changes
redistribute isis level-1 subnets
network 150.50.5.5 0.0.0.0 area 0
network 150.50.100.0 0.0.0.255 area 0
network 150.50.101.4 0.0.0.3 area 0
distance ospf external 140
R5#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R5(config)#router ospf 1
R5(config-router)#neighbor 150.50.100.2 priority 100
R5(config-router)#exit
R5(config)#^Z
R5#sh run | b r o
*Mar 1 01:34:56.866: %SYS-5-CONFIG_I: Configured from console by console
router ospf 1
log-adjacency-changes
redistribute isis level-1 subnets
network 150.50.5.5 0.0.0.0 area 0
network 150.50.100.0 0.0.0.255 area 0
network 150.50.101.4 0.0.0.3 area 0
distance ospf external 140
!
Apparently the intelligence of routers has increased. When I increased ip ospf
priority on interface to 30 (for example) it didn't ignore my neighbor
statement, meaning it would participate on election
On versions earlier than 10 this configuration wouldn't need (or wouldn't
have) ip ospf priority command, accordingly to Doyle.
Thanks for reminding ip ospf priority...
Gustavo
________________________________
From: Thomwin Chen [mailto:thomwin_chen@yahoo.com]
Sent: sabado, 30 de Julho de 2005 15:53
To: Gustavo Novais; ccielab@groupstudy.com
Subject: Re: Strange behaviour on OSPF network NON-broadcast
Hi Gustavo,
neighbor x.x.x.x priority y
y value is taken from ip ospf priority set on the neighbor
rgds,
Thomwin
Gustavo Novais <gustavo.novais@novabase.pt> wrote:
Hello,
I was trying to review the basics and attempted to do a hub and spoke
topology involving router R2 as hub and R4,R5 and R6 as spokes on a NBMA
environment, with neighbor defined and such.
My config on the hub was
interface Serial0/0
ip address 150.50.100.2 255.255.255.0
encapsulation frame-relay
clockrate 256000
no arp frame-relay
frame-relay map ip 150.50.100.2 204
frame-relay map ip 150.50.100.4 204 tcp header-compression
frame-relay map ip 150.50.100.5 205
frame-relay map ip 150.50.100.6 206
no frame-relay inverse-arp
end
I set router ospf with spokes with priority 0 making R2 DR
R2(config-router)#neighbor 150.50.100.4 priority 0
R2(config-router)#neighbor 150.50.100.5 priority 0
R2(config-router)#neighbor 150.50.100.6 priority 0
R2(config-router)#
R2(config-router)#
R2(config-router)#
R2(config-router)#^Z
R2#
R2#
R2#
R2#
R2#
R2#
R2#
R2#
*Mar 1 00:51:05.483: %SYS-5-CONFIG_I: Configured from console by
consolesh run | b r o
router ospf 1
log-adjacency-changes
area 1 nssa default-information-originate
area 1 nssa translate type7 suppress-fa
network 150.50.2.2 0.0.0.0 area 0
network 150.50.10.0 0.0.0.255 area 1
network 150.50.100.0 0.0.0.255 area 0
network 150.50.101.4 0.0.0.3 area 0
neighbor 150.50.100.4
neighbor 150.50.100.5
neighbor 150.50.100.6
On the spokes, I did
interface Serial0/0
ip address 150.50.100.4 255.255.255.0
encapsulation frame-relay
clockrate 256000
no arp frame-relay
frame-relay map ip 150.50.100.2 402 tcp header-compression
frame-relay map ip 150.50.100.4 402
frame-relay map ip 150.50.100.5 402
frame-relay map ip 150.50.100.6 402
no frame-relay inverse-arp
!
R4#sh run | b r o
router ospf 1
log-adjacency-changes
area 4 stub
network 150.50.4.4 0.0.0.0 area 0
network 150.50.40.0 0.0.0.255 area 4
network 150.50.100.0 0.0.0.255 area 0
neighbor 150.50.100.2 priority 100
!
The strange thing to me, is that after election R6 (highest RID) was
elected, and configurations on running were updated automatically!
after election we have on spoke:
router ospf 1
log-adjacency-changes
area 4 stub
network 150.50.4.4 0.0.0.0 area 0
network 150.50.40.0 0.0.0.255 area 4
network 150.50.100.0 0.0.0.255 area 0
neighbor 150.50.100.2 priority 1
<-------------------------------------------WAS 100
!
and on hub
router ospf 1
log-adjacency-changes
area 1 nssa default-information-originate
area 1 nssa translate type7 suppress-fa
network 150.50.2.2 0.0.0.0 area 0
network 150.50.10.0 0.0.0.255 area 1
network 150.50.100.0 0.0.0.255 area 0
network 150.50.101.4 0.0.0.3 area 0
neighbor 150.50.100.4 priority 1
<---------------------------------------- I set it to 0 earlier
neighbor 150.50.100.5 priority 1
<---------------------------------------- I set it to 0 earlier
neighbor 150.50.100.6 priority 1
<---------------------------------------- I set it to 0 earlier
!
R2#sh ip ospf interface ser0/0
Serial0/0 is up, line protocol is up
Internet Address 150.50.100.2/24, Area 0
Process ID 1, Router ID 150.50.2.2, Network Type NON_BROADCAST, Cost:
64
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 150.50.6.6, Interface address 150.50.100.6
Backup Designated router (ID) 150.50.2.2, Interface address
150.50.100.2
Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
oob-resync timeout 120
Hello due in 00:00:25
Index 2/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 0, maximum is 4
Last flood scan time is 0 msec, maximum is 4 msec
Neighbor Count is 3, Adjacent neighbor count is 3
Adjacent with neighbor 150.50.4.4
Adjacent with neighbor 150.50.5.5
Adjacent with neighbor 150.50.6.6 (Designated Router)
Suppress hello for 0 neighbor(s)
R2#
I'm running version IOS (tm) C2600 Software (C2600-JK9O3S-M), Version
12.2(15)T16, RELEASE SOFTWARE (fc2)
c2600-jk9o3s-mz.122-15.T16.bin
Has anybody ever faced this behaviour? Is it usual? Am I missing
something here? Usually we go for point-to-point or broadcast or
something else than NBMA but in deed I'd like to try it. I'm getting
confused.
_______________________________________________________________________
Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:32 GMT-3