From: Brian Dennis (bdennis@internetworkexpert.com)
Date: Wed Jul 27 2005 - 15:48:12 GMT-3
Rohan,
You are missing the map-class that should be bound to the dialer
string on the server side.
RB#sho run int dialer 1
Building configuration...
Current configuration : 311 bytes
!
interface Dialer1
ip address 11.0.0.2 255.255.255.0
encapsulation ppp
ip ospf cost 999
dialer pool 1
dialer remote-name RA
dialer idle-timeout 100
dialer enable-timeout 20
dialer string 22222 class PPPCALLBACK
dialer callback-secure
dialer-group 1
ppp callback accept
ppp authentication chap
end
RB#sho run | in (map-class|dialer callback-ser)
map-class dialer PPPCALLBACK
dialer callback-server username
RB#
HTH,
Brian Dennis, CCIE 2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Rohan Grover (rohang)
Sent: Wednesday, July 27, 2005 10:14 AM
To: Group Study
Subject: ppp callback with dialer ints
Hi,
i'm trying to configure PPP callback with dialer interfaces but it does
not seem to be working. It is working fine with legacy DDR config.
Configs
Client
====
RA#sh run int dialer1
Building configuration...
Current configuration : 244 bytes
!
interface Dialer1
ip address 11.0.0.1 255.255.255.0
encapsulation ppp
ip ospf cost 999
dialer pool 1
dialer remote-name RB
dialer idle-timeout 100
dialer string 11111
dialer-group 1
ppp callback request
ppp authentication chap
end
RA#
Server
=====
RB#sh run int dialer1
Building configuration...
Current configuration : 293 bytes
!
interface Dialer1
ip address 11.0.0.2 255.255.255.0
encapsulation ppp
ip ospf cost 999
dialer pool 1
dialer remote-name RA
dialer idle-timeout 100
dialer enable-timeout 20
dialer string 22222
dialer callback-secure
dialer-group 1
ppp callback accept
ppp authentication chap
end
RB#
=========
debug dialer on the server side shows that 'no callback configured for
RA'. I know that in legacy DDR a dialer class is required with
callback-server username, but how do I do the same with dialer int? How
do I apply a class to a dialer int?
Thanks
Rohan
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:31 GMT-3