Re: Minimum Number of Routers required for Practice Labs

From: Arun Arumuganainar (aarumuga@hotmail.com)
Date: Wed Jul 27 2005 - 06:08:00 GMT-3


Mailing this for broader interest of the group . The techique can be used if
you run short of routers in your lab . With this technique you can create 2
or More routers with in a single physical routers . Using this technique you
can very effectively simulate all the back bone or stub routers in your
setup with a single physical router with multiple interfaces .

Creation Multiple routers using a single router ( For CCIE Practice LAB
Purpose only ) :

General recommendation : Use this For Back bone or STUB routers in your
Topology .
             e1/0 e1/0
Router1=============Router2
               e0/0 e0/0

Here Our topology will look like 2 routers connected back to back via two
link .

Our Objective is two split the router1 in to two routers namely routera and
routerb . When we are done, the topology will look like these .

      e0/0 e0/0 e1/0 e1/0
routera------router2-------routerb

Pls. note : Router A and Router B are actually logical routers created with
in router1.

You can run same or different protocol on router A and Router B . In our
case I have used RIP between router A and Router 2 & OSPF between Router 2
and Router B

How to do it ?

Step 1: Define a VRF and Apply it on interface :

Note : IP Cef is pre-requisite . In case it is not enabled by default enable
them using " ip cef " command in the global prompt .

Sample Config :

For Router A

!
ip vrf routera
 rd 100:100
 route-target export 100:100
 route-target import 100:100
!
interface Loopback0
 ip vrf forwarding routera
 ip address 10.10.10.1 255.255.255.255
!
interface Ethernet0/0
 ip vrf forwarding routera
 ip address 192.168.1.1 255.255.255.0
!

Note : While configuring VRF first apply vrf and then configure the IP
address and not the other way around

for Router B

ip vrf routerb
 rd 200:300
 route-target export 200:300
 route-target import 200:300
!
!
interface Loopback1
 ip vrf forwarding routerb
 ip address 30.30.30.1 255.255.255.255
!
interface Ethernet1/0
 ip vrf forwarding routerb
 ip address 192.168.2.1 255.255.255.0

Config Note :

1) RD is the identifier for Router A and Router B . Pls. give a unique
identifier .
2) Ensure that import and export targets are not identical . This will lead
to route leaking which we want to avoid

Best Practce : Give a unique ID for RD on each VRF and set the import and
export targets to RD .

STEP 2 : Configure Routing protcols .

Here I configured OSPF on RouterA---Router2 and RIP on ROUTER2---RouterB
link . I have also did mutual re-distribution between RIP and OSPF at R2

Sample Configs
COnfigs on Router 1

!OSPF COnfigs for Router A
!
router ospf 100 vrf routera
 log-adjacency-changes
 network 0.0.0.0 255.255.255.255 area 100
!
!RIP config for Router B
!
router rip
 !
 address-family ipv4 vrf routerb
 network 30.0.0.0
 network 192.168.2.0
 no auto-summary
 exit-address-family
!

Configuration on Router 2

Note : Mutual redistribution is enabled

router ospf 100
 log-adjacency-changes
 redistribute rip metric 100 metric-type 1 subnets
 network 20.20.20.0 0.0.0.255 area 100
 network 192.168.1.0 0.0.0.255 area 100
!
router rip
 redistribute ospf 100 metric 8
 network 192.168.2.0
!

Verification .

Routing Table for Routera ( you have to virew this on Route1 )

Router#sh ip route vrf routera
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/32 is subnetted, 1 subnets
O 20.20.20.1 [110/11] via 192.168.1.2, 00:02:21, Ethernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
C 10.10.10.1 is directly connected, Loopback0
C 192.168.1.0/24 is directly connected, Ethernet0/0
O E1 192.168.2.0/24 [110/110] via 192.168.1.2, 00:02:21, Ethernet0/0
O E1 30.0.0.0/8 [110/110] via 192.168.1.2, 00:02:21, Ethernet0/0

Routing Table for Routera ( you have to virew this on Route1 )

Router#sh ip route vrf routerb
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

R 20.0.0.0/8 [120/8] via 192.168.2.2, 00:00:01, Ethernet1/0
R 10.0.0.0/8 [120/8] via 192.168.2.2, 00:00:01, Ethernet1/0
R 192.168.1.0/24 [120/8] via 192.168.2.2, 00:00:01, Ethernet1/0
C 192.168.2.0/24 is directly connected, Ethernet1/0
     30.0.0.0/32 is subnetted, 1 subnets
C 30.30.30.1 is directly connected, Loopback1

Ping Test : Ping from routera to routerb

Router#

Router#ping vrf routera 30.30.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.30.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/60/100 ms

Trace Route from Router A to Router B ( goes via router2)

Router#trace vrf routera
Protocol [ip]:
Target IP address: 30.30.30.1
Source address:
Numeric display [n]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Type escape sequence to abort.
Tracing the route to 30.30.30.1

  1 192.168.1.2 40 msec 40 msec 40 msec
  2 192.168.2.1 60 msec 40 msec *

----- Original Message -----
From: "Arun Arumuganainar" <aarumuga@hotmail.com>
To: "Shanky" <shankyz@gmail.com>; "Group Study" <ccielab@groupstudy.com>
Sent: Saturday, July 23, 2005 9:06 PM
Subject: Re: Minimum Number of Routers required for Practice Labs

> Hi Shanky ,
>
> This is really tricky . Let me suggest few things that you may find useful

>
> 1) FR switch can be used as a router too . You can use it as core router
or
> in the Back bone ...No harm ..FR Switching does not interfere with ip
> routing .
>
> 2) You can use Cat Switch as a router too ( may be a back bone router ) .
>
> 3) Still if your running out of routers . Try doing this . Enable VRF on
> interfaces and Runn routing protocol instances . For ex : If a router has
> for interfaces and your requirement is 2 routers having 2 interfaces .
>
> Then you can logically split the router in to two routers by configuring
VRF
> ( popularly used in MPLS VPN ) . You run different instances of protocol
on
> each VRF . Believe me ... You can combine all the back bone routers( for
ex:
> IP EXPERT Topology uses 3 Back bone routers ) in to one and runn 3
> different routing protocols ..as though u have 3 routers .!!!
>
> Thanks and Regards
> Arun
>
> ----- Original Message -----
> From: "Shanky" <shankyz@gmail.com>
> To: "Group Study" <ccielab@groupstudy.com>
> Sent: Saturday, July 23, 2005 5:17 PM
> Subject: Minimum Number of Routers required for Practice Labs
>
>
> > Hello everyone,
> > Can you guys let me know ..the absolute minimum routers needed for
> > practice....
> > I believe most of the technologies can be practiced with 4-5 routers so
> why
> > do all the vendors like IE,IP and NMC use so many routers in their
> > topologies ?
> > I think most of the workbooks are designed with topology containing 10+
> > routers .. does one really need such large number of routers ?
> > Can we not use the FR Switch (Cisco Router ) as backbone and and whats
> the
> > minimum number of routers one should go for ?
> > At the moment , I have started practice with my own ..designed small
> > topologies of 3-4 routers but I want to know if anyone is using any
> standard
> > topology over which most of the IGPs & BGP can be practiced without
making
> > Physical changes.
> > TIA
> > Shanky
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:31 GMT-3