From: Alexander Arsenyev (GU/ETL) (alexander.arsenyev@ericsson.com)
Date: Mon Jul 18 2005 - 19:24:30 GMT-3
<quote>
interface fastethernet0/0
ip address 120.1.1.1 255.255.255.0
!
interface fastethernet0/1
ip address 10.1.1.1 255.255.255.0
!
ip route 50.0.0.0 255.0.0.0 120.1.1.1
!
router bgp 120
network 120.1.1.0
network 10.1.1.0
network 50.0.0.0
network 60.0.0.0
network 70.0.0.0
!
end
You see that, BGP will not advertise networks 60.0.0.0 & 70.0.0.0, because
according to the limited configuration above, there is no reference to them
in the router's routing table, but if you disable syncronization, BGP will
accept these networks and advertise them, despite the fact that none of your
routers know how to reach those networks.
</quote>
This is not entirely true, at least on my 7507 with 12.0(21)ST7:
Router#sh run | b r bgp
router bgp 10
bgp log-neighbor-changes
!
<irrelevant config parts snipped>
!
address-family ipv4
redistribute connected metric 50
redistribute static metric 40
neighbor 172.16.0.2 activate
neighbor 172.16.0.11 activate
neighbor 172.16.0.21 activate
neighbor 172.16.0.65 activate
neighbor 172.16.0.66 activate
no auto-summary
no synchronization
network 1.1.1.1 mask 255.255.255.255
network 1.1.2.2 mask 255.255.255.255
network 1.1.3.3 mask 255.255.255.255
network 1.1.4.4 mask 255.255.255.255
exit-address-family
Router#sh ip proto | b bgp
Routing Protocol is "bgp 10"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
IGP synchronization is disabled <==============================Sync if OFF
Automatic route summarization is disabled
Redistributing: connected, static
Neighbor(s):
Address FiltIn FiltOut DistIn DistOut Weight RouteMap
172.16.0.2
172.16.0.11
172.16.0.21
172.16.0.65
172.16.0.66
Routing for Networks:
Routing Information Sources:
Gateway Distance Last Update
172.16.0.11 200 4d10h
172.16.0.2 200 4d08h
Distance: external 20 internal 200 local 200
Router#sh ip bgp 1.1.1.1
% Network not in table
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#int lo19
Router(config-if)#ip add 1.1.1.1 255.255.255.255
Router(config-if)#^Z
Router#sh ip bgp 1.1.1.1
BGP routing table entry for 1.1.1.1/32, version 229
Paths: (1 available, best #1, table Default-IP-Routing-Table)
Advertised to non peer-group peers:
172.16.0.2 172.16.0.11 172.16.0.21 172.16.0.65 172.16.0.66
Local
0.0.0.0 from 0.0.0.0 (172.16.0.1)
Origin IGP, metric 50, localpref 100, weight 32768, valid, sourced, local, best,
mpls labels in/out unknown/exp-null
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#no int lo19
Router(config)#^Z
Router#sh ip bgp 1.1.1.1
BGP routing table entry for 1.1.1.1/32, version 230
Paths: (0 available, no best path)
Flag: 0x208
Not advertised to any peer
I don't think there is a way to advertise unknown networks except using Conditional Advertisement but I might be wrong on that. Would someone be able to demonstrate how unknown networks could be advertised (without Conditional Advertisement)?
HTH,
Alex
#13405
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:30 GMT-3