From: Andy (trung@vnsystem.net)
Date: Fri Jul 15 2005 - 00:48:25 GMT-3
I have tested this scenario with dialer profile but there's no difference.
interface dialer up when primary link (s0) down -> default route is in
routing table but here is the output from debug ip packet:
Router6#p 10.0.0.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.0.0.8, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
Router6#
00:55:12: IP: s=10.0.0.6 (local), d=10.0.0.8 (Dialer0), len 100, sending
00:55:12: IP: s=10.0.0.6 (local), d=10.0.0.8 (Dialer0), len 100,
encapsulation failed
00:55:14: IP: s=10.0.0.6 (local), d=10.0.0.8 (Dialer0), len 100, sending
00:55:14: IP: s=10.0.0.6 (local), d=10.0.0.8 (Dialer0), len 100,
encapsulation failed
00:55:16: IP: s=10.0.0.6 (local), d=10.0.0.8 (Dialer0), len 100, sending
Have you guys tested this successfully ?
here is my config:
Router6:
interface Serial0
backup delay 5 5
backup interface Dialer0
ip address 100.0.0.6 255.255.255.0
encapsulation frame-relay
frame-relay map ip 100.0.0.8 608 broadcast
no frame-relay inverse-arp
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 66612345
isdn spid2 66654321
isdn x25 static-tei 0
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
!
interface Dialer0
ip address 10.0.0.6 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 666111
!
ip route 0.0.0.0 0.0.0.0 10.0.0.8
----------------------------
Router8:
interface Serial0
ip address 100.0.0.8 255.255.255.0
encapsulation frame-relay
frame-relay map ip 100.0.0.6 806 broadcast
no frame-relay inverse-arp
!
interface BRI0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 88812345
isdn spid2 88854321
cdapi buffers regular 0
cdapi buffers raw 0
cdapi buffers large 0
!
interface Dialer0
ip address 10.0.0.8 255.255.255.0
encapsulation ppp
dialer pool 1
dialer string 666111
Andy
----- Original Message -----
From: <gladston@br.ibm.com>
To: "DaveW" <kapsi1911@hotmail.com>
Cc: <ccielab@groupstudy.com>
Sent: Tuesday, June 28, 2005 6:31 AM
Subject: Re: ISDN - default route
> Thanks Dave,
>
> I tried it. Does not work for legacy. The first part works (while main
> serial is up, bri0/0 is down and default ip route is not on RIB. But when
> main serial goes down, I got an encapsulation failure for most of the
> destination, because on the remote bri address is solved by dialer map.
>
> I tested it for dialer profile, but I remember I made a mistake. I did not
> change backup interface bri0/0 to backup interface dialer 200. I will try
> this tomorrow morning.
> I think this will work, as dialer 200 will be down, so ip route will be
> removed from RIB. And, as dialer is point-to-point, there will be no map
> problem.
>
>
> Cordially,
> ------------------------------------------------------------------
> Gladston
>
>
>
>
> "DaveW" <kapsi1911@hotmail.com>
> 27/06/2005 18:33
>
> To
> Alaerte Gladston Vidali/Brazil/IBM@IBMBR, <ccielab@groupstudy.com>
> cc
>
> Subject
> Re: ISDN - default route
>
>
>
>
>
>
> Gladston,
>
> Try this. Create a default static route that points to Bri0/0. Then put a
> "backup interface bri0/0" configuration on serial/0. Since this will put
> bri0/0 standby/down state, I would think the default route would be
> suppressed until ser0/0 goes down and the bri0/0 interface is returned to
> an
> up/up state. I haven't tested it, but I don't see why it wouldn't work.
>
> DAve
> ----- Original Message -----
> From: <gladston@br.ibm.com>
> To: <ccielab@groupstudy.com>
> Sent: Monday, June 27, 2005 3:31 PM
> Subject: ISDN - default route
>
>
>> How would you configure a default route pointing to ISDN so it is on the
> RIB only when the main interface is down?
>>
>> I tried pointing to physical BRI (ip route ...bri0/0), but I get an
> encapsulation failed for the addresses not mapped under bri (dialer map
> ip...)
>>
>> I tried pointing to Dialer (ip route...dialer 200), but the default
> route
> is always on the RIB in this case.
>>
>> I tried pointing to the remote IP of the ISDN (ip route 172.16.45.5),
> but
> the default route is always on the RIB in this case either.
>>
>> Tested using legacy with this config:
>>
>> interface BRI0/0
>> description testar dialer load-trheshold only on R5
>> ip address 172.16.45.6 255.255.255.252
>> encapsulation ppp
>> dialer map ip 172.16.45.5 name Rack2R4 broadcast 4441111111
>> dialer-group 1
>> isdn switch-type basic-ni
>> isdn spid1 555111111100
>> isdn spid2 555222222200
>> no cdp enable
>> ppp authentication chap
>> ppp multilink
>>
>>
>> Testing using dialer profile with this config:
>>
>> interface BRI0/0
>> no ip address
>> encapsulation ppp
>> dialer pool-member 200
>> isdn switch-type basic-ni
>> isdn spid1 555111111100
>> isdn spid2 555222222200
>> ppp authentication chap
>> ppp multilink
>>
>>
>> interface Dialer200
>> description testar dialer load-trheshold only on R5
>> ip address 172.16.45.6 255.255.255.252
>> encapsulation ppp
>> dialer pool 200
>> dialer remote-name Rack2R4
>> dialer string 4441111111
>> dialer-group 1
>> no cdp enable
>> ppp authentication chap
>> ppp multilink
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:30 GMT-3