From: Dillon Yang (dillony@gmail.com)
Date: Wed Jul 13 2005 - 11:57:22 GMT-3
Hi, group:
I am finding a way to distinguish ISIS internal or external route, but I found something strange:
[Question01]
<quote from Doyle's book>
Whereas L2 routes may be either internal or external, L1 routes are always internal.
</quote>
You see, under L1-only routing, the router is generating the "IP-External" routes, and the routes was in the routing table.
How can you explain this problem, if you were Mr. Doyle?
[config01]
!
interface Loopback11
ip address 11.6.6.1 255.255.255.0
!
interface Loopback12
ip address 11.6.7.1 255.255.255.0
!
interface Loopback13
ip address 11.6.8.1 255.255.255.0
!
interface Loopback14
ip address 11.6.9.1 255.255.255.0
!
interface Loopback211
ip address 211.211.211.1 255.255.255.0
ip router isis fr
!
interface Ethernet0
ip address 150.100.2.254 255.255.255.0
ip router isis fr
no ip route-cache
no ip mroute-cache
clns router isis fr
!
!
router isis fr
net 49.0001.9999.9999.9999.00
redistribute connected metric-type external level-1
is-type level-1
!
end
R6#s isis dat det
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
R4.00-00 0x00000015 0xFF15 626 1/0/0
Area Address: 49.0001
NLPID: 0x81 0xCC
Hostname: R4
IP Address: 150.100.2.3
Metric: 10 IP 150.100.2.0 255.255.255.0
Metric: 10 IS R6.02
Metric: 0 ES R4
R6.00-00 * 0x00000015 0xFA76 642 0/0/0
Area Address: 49.0001
NLPID: 0x81 0xCC
Hostname: R6
IP Address: 211.211.211.1
Metric: 10 IP 150.100.2.0 255.255.255.0
Metric: 10 IP 211.211.211.0 255.255.255.0
Metric: 10 IS R6.02
Metric: 0 ES R6
Metric: 64 IP-External 11.6.9.0 255.255.255.0
Metric: 64 IP-External 11.6.8.0 255.255.255.0
Metric: 64 IP-External 11.6.7.0 255.255.255.0
Metric: 64 IP-External 11.6.6.0 255.255.255.0
R6.02-00 * 0x00000012 0xC7B1 677 0/0/0
Metric: 0 IS R6.00
Metric: 0 IS R4.00
R6#
[Question02]
The more strange thing followed, when I added the command "metric-style wide", the router did not generate the "IP-External" routes and these routes did not appear in the routing table.
How can it works?
[config02]
R6#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R6(config)#router isis fr
R6(config-router)#metric
R6(config-router)#metric-style wi level-1
R6(config-router)#end
R6.00-00 * 0x00000007 0x951B 1187 1/0/0
Area Address: 01
NLPID: 0xCC
Hostname: R6
IP Address: 211.211.211.1
Metric: 10 IP 211.211.211.0/24
Metric: 10 IP 3.3.16.0/24
Metric: 10 IS-Extended R1.00
Metric: 0 IP 11.6.9.0/24
Metric: 0 IP 11.6.8.0/24
Metric: 0 IP 11.6.7.0/24
Metric: 0 IP 11.6.6.0/24
routing table:
<omitted>
C 211.211.211.0/24 is directly connected, Loopback211
3.0.0.0/24 is subnetted, 16 subnets
i L1 3.3.10.0 [115/74] via 3.3.16.1, Serial0.601, fr
i L1 3.3.13.0 [115/30] via 3.3.16.1, Serial0.601, fr
i L1 3.3.14.0 [115/30] via 3.3.16.1, Serial0.601, fr
<omitted>
TIA
dillon
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:29 GMT-3