From: Arun Arumuganainar (aarumuga@hotmail.com)
Date: Tue Jul 12 2005 - 09:08:17 GMT-3
Hi Amit ,
This is the OSPF behavior from the good old times !!!! You should look at how
inverse mask works to understand this better . Let me explain .
Inverse mask contains series of zeroes followed by series of 1s ( Just
opposite to subnetmask ) . When match is to made it will just check zero
portion of it and 1s portion are called don't cares.
i.e "11.0.0.0 0.0.0.255" will try to match for 11.0.0 and last octet could
be any thing .
how ever "11.0.0.0 0.255.255.255" will match for 11 alone and rest of bits
are dontcares
If all the inverse mask bits are 1 ( 255.255.255.255) then it will equivalent
to Match any address . In such a case OSPF will be enabled of all the
interfaces which has an IP address configured on the router .
Router Traces to illustrate the behavior
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Router#sh runn | b ospf
router ospf 100
log-adjacency-changes
! >>> Configured OSPF with wild card mask( All 1s inverse mask )
network 0.0.0.0 255.255.255.255 area 0
!>>>Further traces are omitted
Router#sh ip ospf int brie
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Se1/0 100 0 10.1.1.2/24 64 P2P 0/0
Et0/0 100 0 11.0.0.1/8 10 DR 0/0
Note : all the interfaces in the above example are assigned to area 0
Again in case there is more specific match is available then that network
statement will over-ride all the other network statement in the ospf
configuration .
Router#sh runn | b ospf
router ospf 100
log-adjacency-changes
! >>> Note : Area 4 is the most specific Match
network 11.0.0.0 0.0.0.255 area 4
network 11.0.0.0 0.0.255.255 area 3
network 11.0.0.0 0.255.255.255 area 2
network 0.0.0.0 255.255.255.255 area 0
!
Note : E0/0 has been assigned the area with most specific match
Router#sh ip ospf int brie
Interface PID Area IP Address/Mask Cost State Nbrs F/C
Se1/0 100 0 10.1.1.1/24 64 P2P 0/0
Et0/0 100 4 11.0.0.1/8 10 WAIT 0/0
Hope this helps .
Thanks and Regards
Arun
----- Original Message -----
From: "Amit Jain" <netsteps@rediffmail.com>
To: "ccie2be" <ccie2be@nyc.rr.com>; "'Chris Aguillo'" <ccaguillo1@hotpop.com>;
"'Godswill Oletu'" <oletu@inbox.lv>; "'ccie_06'" <ccie_06@att.net>;
<ccielab@groupstudy.com>
Sent: Tuesday, July 12, 2005 2:42 PM
Subject: Re: OSPF Network Statement
> I guess you are r right Tim. IOS has gotten smarter. I am sure that I read
> it somewhere that new IOS will not consider the sequence now.
> Though I also have not tested also but new IOS works that way.
>
> Amit
> ----- Original Message -----
> From: "ccie2be" <ccie2be@nyc.rr.com>
> To: "'Chris Aguillo'" <ccaguillo1@hotpop.com>; "'Godswill Oletu'"
> <oletu@inbox.lv>; "'ccie_06'" <ccie_06@att.net>; <ccielab@groupstudy.com>
> Sent: Tuesday, July 12, 2005 11:28 AM
> Subject: RE: OSPF Network Statement
>
>
> > Chris,
> >
> > Has IOS gotten smarter?
> >
> > It used to be that if the first network statement included 0.0.0.0
> > 255.255.255.255, that was it. No other statements mattered. I haven't
> > tested this myself but it used to be that the sequence of net statements
> > mattered.
> >
> > Tim
> >
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> > Chris Aguillo
> > Sent: Tuesday, July 12, 2005 12:55 AM
> > To: Godswill Oletu; ccie_06; ccielab@groupstudy.com
> > Subject: OSPF Network Statement
> >
> > Hi ccie_06,
> >
> > upon you start the OSPF process, the algorithm will check which
> > interface is part of an OSPF area or not.
> >
> > Each NETWORK command is treated sequentially as it is written under the
> > ROUTER OSPF command.
> >
> > Also in each every NETWORK ip_address inverse_mask command, you will
> > treat it as it is an ACL.
> >
> > taking out from your original script:
> >
> > network 0.0.0.0 255.255.255.255 area 0
> > >>> 0.0.0.0 255.255.255.255 means all IP-Address will match
> > >>> any interface that have a valid IP address and will be placed in
> Area0
> >
> > network 1.2.3.0 0.0.0.0 area 1
> > >>> The IP address 1.2.3.0 is a host address as per inverse_mask
> > >>> The Interface that have the IP address of 1.2.3.0 is pulled out
> > from area 0 and placed into area 1.
> >
> >
> > network 1.2.3.4 0.0.0.0 area 2
> > >>> The IP address 1.2.3.4 is a host address as per inverse_mask
> > >>> The Interface that have the IP address of 1.2.3.4 is pulled out
> > from area 0 and placed into area 2
> >
> > As a result, all router interfaces are in Area 0 except 1.2.3.0 and
> > 1.2.3.4 which are in Area 1 and Area 2 respectively.
> >
> > Moreover, reversing the Network statement and placing as the last
> > statement the command
> >
> > NETWORK 0.0.0.0 255.255.255.255 AREA 0
> > >>> this will remove all interfaces assigned in other Areas (earlier
> > NETWORK command) and will bring other interfaces not yet assigned for
> > any Area and all be brought into AREA 0.
> >
> > >>> This is in effect because the Network command is treated
> sequencially.
> >
> > I do not see why network 1.2.3.0 0.0.0.0 will not match any interface
> > and no interface as a result will be in AREA 1 as per Godswill below?
> > >>> as long as there is a valid IP_address configured in the router as
> > 1.2.3.0, that only interface will be placed in AREA 1.
> >
> > I do not agree with the explanation of Godswill for:
> > +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> > network 0.0.0.0 255.255.255.255 area 0 -> Will match ALL remaining
> > interfaces not previously matched and place them into area 0.
> > +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
> >
> > The network command is placed as the first item in the series of Network
> > command, thus it will make all interface in the area 0 (whether or not
> > matched in other network command, take note this network is the first
> > one). The way I analyzed the words <<<all remaining>>> and <<<not
> > previously mathed>>> is probably he thinks that Network Command is not
> > trated sequentially.
> >
> > HTH....chris
> >
> >
> > Godswill Oletu wrote:
> > > The interfaces will be assigned like this:
> > > network 1.2.3.0 0.0.0.0 area 1 -> Will not match any interface, no
> > > interface will be in area 1
> > >
> > > network 1.2.3.4 0.0.0.0 area 2 -> Will match only interface 1.2.3.4
and
> > > put it into area 2
> > >
> > > network 0.0.0.0 255.255.255.255 area 0 -> Will match ALL remaining
> > > interfaces not previously matched and place them into area 0.
> > >
> > > Thanks.
> > > Godswill Oletu
> > >
> > > ----- Original Message ----- From: "ccie_06" <ccie_06@att.net>
> > > To: <ccielab@groupstudy.com>
> > > Sent: Sunday, July 10, 2005 12:29 PM
> > > Subject: Ospf Network statement
> > >
> > >
> > >> Can any one explain following statement under ospf process ( I mean
> > >> which interface will participate in which area.?)
> > >>
> > >> router ospf 1
> > >> network 0.0.0.0 255.255.255.255 area 0
> > >> network 1.2.3.0 0.0.0.0 area 1
> > >> network 1.2.3.4 0.0.0.0 area 2
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Sep 04 2005 - 17:00:29 GMT-3