Frame Relay traffic shaping VS GTS traffic shaping on a PVC

From: George Cassels \(gcassels\) (gcassels@cisco.com)
Date: Fri Jun 17 2005 - 10:50:34 GMT-3


All,

     Based on the conversation yesterday on the GTS with MQC verses
shaping with map-class I decided to lab this up and see the results. It
seems it has to do with whether or not you shape under the map-class
frame-relay or under the MQC. If you shape under the MQC it considers
it GTS and you can not apply the frame-relay traffic shaping command on
the physical interface. If you shape under the map-class and only do
bandwidth under the MQC you can enable frame-relay traffic shaping. The
bad thing about the second option is that it enables shaping for ALL PVC
with default values regardless of whether or not you put a class under
that interface. Also I found that the bandwidth statements have to be
less then the mincir for the shaping. If the total is more then the
mincir the class with not apply. I hope this helps everyone...

R1-------------------R2
|
|
|
|
R3

R2 also has a p2p PVC to R3

Map-class Frame-relay shaping config:

R1#sh run
Building configuration...

Current configuration : 1470 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone PST -8
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
class-map match-all telnet
  match access-group 100
class-map match-all icmp
  match access-group 102
class-map match-all www
  match access-group 101
!
!
policy-map frame-map
  class telnet
   bandwidth 64
  class www
   bandwidth 32
  class icmp
   bandwidth 16
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 no fair-queue
 no arp frame-relay
 frame-relay traffic-shaping
 no frame-relay inverse-arp
!
interface Serial1/0.12 point-to-point
 ip address 172.16.12.1 255.255.255.0
 frame-relay interface-dlci 102
  class nmc
!
interface Serial1/0.13 point-to-point
 ip address 172.16.13.1 255.255.255.0
 frame-relay interface-dlci 103
!
interface Serial2/0
 no ip address
 shutdown
!
interface Serial3/0
 no ip address
 shutdown
!
ip classless
no ip http server
!
!
!
map-class frame-relay nmc
 frame-relay cir 128000
 frame-relay mincir 128000
 frame-relay adaptive-shaping becn
 service-policy output frame-map
access-list 100 permit tcp any any eq telnet
access-list 101 permit tcp any any eq www
access-list 102 permit icmp any any
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Notice that regardless whether you actually put a map-class under the
other interfaces or not a default shaping value is enabled because of
the frame relay traffic shaping command on the physical interface:

R1#sh traffic-shape

Interface Se1/0
       Access Target Byte Sustain Excess Interval Increment
Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes)
Active
104 56000 875 7000 0 125 875 -

Interface Se1/0.12
       Access Target Byte Sustain Excess Interval Increment
Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes)
Active
102 128000 2000 128000 0 125 2000
BECN

Interface Se1/0.13
       Access Target Byte Sustain Excess Interval Increment
Adapt
VC List Rate Limit bits/int bits/int (ms) (bytes)
Active
103 56000 875 7000 0 125 875 -

MQC nested policy config:

R2#sh run
Building configuration...

Current configuration : 1446 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
clock timezone PST -8
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
class-map match-all telnet
  match access-group 100
class-map match-all icmp
  match access-group 102
class-map match-all www
  match access-group 101
!
!
policy-map child
  class telnet
   bandwidth 64
  class www
   bandwidth 32
  class icmp
   bandwidth 16
policy-map parent
  class class-default
   shape average 128000
   shape adaptive 128000
   service-policy child
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 no arp frame-relay
 no frame-relay inverse-arp
!
interface Serial1/0.12 point-to-point
 ip address 172.16.12.2 255.255.255.0
 frame-relay interface-dlci 201
  class nmc
!
interface Serial1/0.13 point-to-point
 ip address 172.16.23.2 255.255.255.0
 frame-relay interface-dlci 203
!
interface Serial2/0
 no ip address
 shutdown
!
interface Serial3/0
 no ip address
 shutdown
!
ip classless
no ip http server
!
!
!
map-class frame-relay nmc
 service-policy output parent
access-list 100 permit tcp any any eq telnet
access-list 101 permit tcp any any eq www
access-list 102 permit icmp any any
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
line vty 0 4
 login
!
!
end

Note you can not put frame-relay traffic-shaping on the interface with
nest MQC.

R2(config-if)#frame-relay traffic-shaping
Generic traffic shaping commands must be removed before enabling
frame-relay
traffic shaping.

Also note that there is no traffic shaping on R2 with nested MQC policy
and no traffic shaping frame relay on the physical port:

R2#sh traffic-shape

R2#

you see no traffic shaping under show frame PVC:

R2#sh frame pvc

PVC Statistics for interface Serial1/0 (Frame Relay DTE)

              Active Inactive Deleted Static
  Local 2 0 0 0
  Switched 0 0 0 0
  Unused 0 1 0 0

DLCI = 201, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
Serial1/0.12

  input pkts 31 output pkts 31 in bytes 10714
  out bytes 10651 dropped pkts 0 in pkts dropped 0

  out pkts dropped 0 out bytes dropped 0
  in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

  out BECN pkts 0 in DE pkts 0 out DE pkts 0

  out bcast pkts 31 out bcast bytes 10651
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:30:49, last time pvc status changed 00:30:49

DLCI = 203, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
Serial1/0.13

  input pkts 0 output pkts 5 in bytes 0
  out bytes 1760 dropped pkts 0 in pkts dropped 0

  out pkts dropped 0 out bytes dropped 0
  in FECN pkts 0 in BECN pkts 0 out FECN pkts 0

  out BECN pkts 0 in DE pkts 0 out DE pkts 0

  out bcast pkts 5 out bcast bytes 1760
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 00:30:51, last time pvc status changed 00:08:30

Only way to see the policy results at all is show policy interface s
1/0.12

R2#sh policy-map in s 1/0.12
 Serial1/0.12: DLCI 201 -

  Service-policy output: parent

    Class-map: class-default (match-any)
      61 packets, 14216 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
      Traffic Shaping
           Target/Average Byte Sustain Excess Interval
Increment
             Rate Limit bits/int bits/int (ms) (bytes)

           128000/128000 1984 7936 7936 62 992

        Adapt Queue Packets Bytes Packets Bytes Shaping
        Active Depth Delayed Delayed Active
        BECN 0 61 14216 0 0 no

      Service-policy : child

        Class-map: telnet (match-all)
          11 packets, 514 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 100
          Queueing
            Output Queue: Conversation 25
            Bandwidth 64 (kbps) Max Threshold 64 (packets)
            (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

        Class-map: www (match-all)
          12 packets, 542 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          Queueing
            Output Queue: Conversation 26
            Bandwidth 32 (kbps) Max Threshold 64 (packets)
            (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

        Class-map: icmp (match-all)
          0 packets, 0 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 102
          Queueing
            Output Queue: Conversation 27
            Bandwidth 16 (kbps) Max Threshold 64 (packets)
            (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

        Class-map: class-default (match-any)
          38 packets, 13160 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any

R2#

Regards,
George



This archive was generated by hypermail 2.1.4 : Wed Jul 06 2005 - 14:43:41 GMT-3