Re: NET-RED message

From: Pat Chui (cui666@gmail.com)
Date: Tue Jun 14 2005 - 13:07:34 GMT-3


Though this particular debug command is mostly used when practising
routing redistribution, everytime the router re-install routes into
routing table, you will see the message. In another word, you don't
really need routing redistribution to see it. Notice that you can even
see the message for a connected route being re-installed in routing
table:.

 

====
RTD#clear ip route *
RTD#
*Mar 15 16:43:10.158: is_up: 1 state: 4 sub state: 1 line: 1 has_route: True
*Mar 15 16:43:10.158: RT: add 172.16.1.0/24 via 0.0.0.0, connected metric [0/0]
*Mar 15 16:43:10.158: RT: NET-RED 172.16.1.0/24
*Mar 15 16:43:10.162: RT: NET-RED queued, Queue size 1
*Mar 15 16:43:10.162: RT: interface Ethernet0/0 added to routing table
*Mar 15 16:43:10.162: is_up: 1 state: 4 sub state: 1 line: 1 has_route: True
*Mar 15 16:43:10.162: RT: add 172.16.4.0/24 via 0.0.0.0, connected metric [0/0]
*Mar 15 16:43:10.162: RT: NET-RED 172.16.4.0/24
*Mar 15 16:43:10.166: RT: NET-RED queued, Queue size 2
*Mar 15 16:43:10.166: RT: interface Ethernet0/1 added to routing table
RTD#
*Mar 15 16:43:10.214: RT: add 5.5.5.0/24 via 172.16.4.2, rip metric [120/1]
*Mar 15 16:43:10.214: RT: NET-RED 5.5.5.0/24
*Mar 15 16:43:10.214: RT: NET-RED queued, Queue size 1
*Mar 15 16:43:10.218: RT: add 172.16.3.0/24 via 172.16.4.2, rip metric [120/1]
*Mar 15 16:43:10.218: RT: NET-RED 172.16.3.0/24
*Mar 15 16:43:10.218: RT: NET-RED queued, Queue size 2

On 6/14/05, gladston@br.ibm.com <gladston@br.ibm.com> wrote:
> Hi,
> Thanks. Yes, there is redistribution. Here is the config:
>
> version 12.2
> service timestamps debug datetime localtime
> service timestamps log datetime localtime
> no service password-encryption
> !
> hostname Rack2R4
> !
> logging queue-limit 100
> logging buffered 4096 debugging
> !
> username Rack2R5 password 0 cisco
> memory-size iomem 15
> ip subnet-zero
> !
> !
> no ip domain lookup
> !
> ip multicast-routing
> ip cef
> ipv6 unicast-routing
> mpls ldp logging neighbor-changes
> isdn switch-type basic-ni
> !
> !
> !
> !
> !
> !
> !
> !
> !
> no voice hpi capture buffer
> no voice hpi capture destination
> !
> !
> mta receive maximum-recipients 0
> !
> !
> class-map match-all Gold
> match protocol telnet
> class-map match-all Normal
> match protocol tftp
> class-map match-all http-imp
> match protocol http url "*important*"
> !
> !
> policy-map Qos
> class Normal
> bandwidth 5000
> class Gold
> bandwidth 4000
> policy-map Parent
> class class-default
> shape average 10000000
> service-policy Qos
> policy-map http-important
> class http-imp
> set dscp af21
> police cir 64000 bc 8000 pir 128000 be 16000
> conform-action transmit
> exceed-action set-dscp-transmit default
> violate-action drop
> !
> !
> !
> !
> interface Loopback0
> ip address 142.20.4.1 255.255.255.0
> ip pim sparse-dense-mode
> !
> interface Loopback20
> ip address 55.55.55.1 255.255.255.0
> !
> interface Loopback30
> ip address 142.44.4.1 255.255.255.0
> !
> interface Loopback31
> ip address 142.44.8.1 255.255.255.0
> !
> interface Loopback44
> ip address 44.44.44.1 255.255.255.0
> !
> interface Ethernet0/0
> no ip address
> half-duplex
> no sh
> !
> interface Ethernet0/0.4
> encapsulation dot1Q 4 native
> ip address 142.20.44.4 255.255.255.0
> ip access-group 150 in
> ip helper-address 142.20.1.1
> ip directed-broadcast
> ip nat outside
> ip multicast helper-map broadcast 229.1.1.1 110
> service-policy output Parent
> rate-limit input access-group 121 512000 64000 96000 conform-action
> continue exceed-action drop
> rate-limit input access-group 122 64000 8000 12000 conform-action transmit
> exceed-action drop
> rate-limit input access-group 123 32000 4000 6000 conform-action transmit
> exceed-action drop
> no ip mroute-cache
> ntp multicast 229.2.2.2
> ipv6 address 2001:1:1:4::4/64
> ipv6 address FEC0:2E3D:5B7C:4::4/64
> ipv6 nd suppress-ra
> !
> interface Serial0/0
> bandwidth 64
> no sh
> ip address 142.20.14.4 255.255.255.0
> ip access-group 120 in
> ip nat inside
> ip pim sparse-dense-mode
> encapsulation frame-relay
> no ip route-cache
> ip ospf message-digest-key 5 md5 OLD
> ip ospf network point-to-multipoint
> ip ospf priority 0
> no ip mroute-cache
> ipv6 address FEC0:2E3D:5B7C:14::4/64
> cdp enable
> frame-relay class Pvc-priority
> frame-relay map ip 142.20.14.1 401 broadcast
> no frame-relay inverse-arp
> frame-relay interface-queue priority
> !
> interface BRI0/0
> ip address 142.20.45.4 255.255.255.0
> encapsulation ppp
> ip ospf message-digest-key 10 md5 cisco
> ip ospf cost 9999
> dialer map ip 142.20.45.5 name Rack2R5 broadcast 5551111111
> dialer load-threshold 1 outbound
> dialer-group 1
> isdn switch-type basic-ni
> isdn spid1 444111111100
> isdn spid2 444222222200
> no cdp enable
> ppp authentication chap
> ppp multilink
> no sh
> !
> interface Ethernet0/1
> description Connected w/ SW1
> ip address 142.20.47.4 255.255.255.0
> service-policy input http-important
> half-duplex
> ntp multicast
> ipv6 address 2001:1:1:47::4/64
> ipv6 address FEC0:2E3D:5B7C:47::4/64
> ipv6 nd prefix 2001:47::/64 259200 259200
> no sh
> !
> interface Serial0/1
> no ip address
> shutdown
> !
> router ospf 1
> router-id 142.20.4.1
> log-adjacency-changes
> area 0 authentication
> area 4 nssa no-summary
> area 112 authentication message-digest
> area 112 virtual-link 142.20.1.1 authentication-key cisco
> area 113 authentication message-digest
> area 113 virtual-link 142.20.5.1 authentication message-digest
> area 113 virtual-link 142.20.5.1 message-digest-key 5 md5 cisco5
> redistribute connected subnets route-map connected->ospf
> redistribute rip subnets
> network 142.20.4.0 0.0.0.255 area 112
> network 142.20.14.0 0.0.0.255 area 112
> network 142.20.44.0 0.0.0.255 area 4
> network 142.20.45.4 0.0.0.0 area 113
> network 142.44.0.0 0.0.255.255 area 112
> distance 111 142.20.5.1 0.0.0.0 90
> !
> router rip
> version 2
> redistribute ospf 1 metric 10
> passive-interface default
> network 142.20.0.0
> neighbor 142.20.47.7
> !
> router bgp 44
> no synchronization
> bgp log-neighbor-changes
> network 44.44.44.0 mask 255.255.255.0
> neighbor 142.20.1.1 remote-as 20
> no auto-summary
> !
> ip nat pool net171 171.68.16.10 171.68.16.254 netmask 255.255.255.0
> ip nat outside source list 1 pool net171 add-route
> ip http server
> ip classless
> ip forward-protocol udp 5000
> ip forward-protocol udp bootpc
> ip route 171.68.16.0 255.255.255.0 Null0
> ip route 171.68.16.10 255.255.255.255 142.20.44.7
> ip route 172.16.88.0 255.255.255.0 142.20.44.7
> !
> ip policy-list as permit
> !
> ip mroute 0.0.0.0 0.0.0.0 BRI0/0
> ip mroute 142.20.5.1 255.255.255.255 142.20.14.1
> !
> !
> !
> map-class frame-relay Pvc-priority
> access-list 1 permit 172.16.88.0 0.0.0.255
> access-list 90 permit 142.20.5.1
> access-list 110 permit udp any any eq 5000
> access-list 110 permit udp any any eq domain
> access-list 120 permit tcp any any eq bgp
> access-list 120 permit tcp any eq bgp any
> access-list 120 permit tcp any eq 2065 any
> access-list 120 permit tcp any any eq 2065
> access-list 120 permit ospf any any
> access-list 120 permit pim any any
> access-list 120 permit igmp any any
> access-list 120 permit icmp any any
> access-list 120 permit udp any any eq pim-auto-rp log-input
> access-list 120 permit udp any eq ntp any eq ntp
> access-list 120 permit udp any eq bootps any eq bootps
> access-list 120 deny ip any any log-input
> access-list 121 permit ip any any
> access-list 122 permit tcp any any eq telnet
> access-list 123 permit icmp any any
>
> access-list 150 permit icmp any any
> access-list 150 permit osp a a
> access-list 150 per pim a a
> access-list 150 per ig a a
> access-list 150 per udp an an eq pim
> access-list 150 per udp an eq 68 a eq 67
> access-list 150 per udp an eq 123 an eq 123
> access-list 150 per tcp an an eq 2065
> access-list 150 per tcp an eq 2065 an
> access-list 150 deny ip any any log-inp
>
> access-list 165 permit ip 142.20.47.0 0.0.0.255 142.20.0.0 0.0.255.255
> access-list 165 permit ip 142.20.44.0 0.0.0.255 142.20.0.0 0.0.255.255
> access-list 165 permit ip 142.20.4.0 0.0.0.255 142.20.0.0 0.0.255.255
> access-list 165 deny udp host 142.20.4.1 eq ntp any eq ntp
> access-list 165 permit ospf any any
> access-list 181 permit tcp any any eq telnet
> dialer-list 1 protocol ip list 165
> !
> route-map connected->ospf permit 10
> match interface Ethernet0/0 Ethernet0/1 Loopback20
> !
> !
> call rsvp-sync
> !
> voice-port 1/0/0
> !
> voice-port 1/0/1
> !
> !
> mgcp profile default
> !
> dial-peer cor custom
> !
> !
> !
> rtr responder
> no alias exec p
> alias exec evel 15
> alias exec c conf t
> alias exec s show run
> alias exec sib show ip interface brief
> alias exec sl sh logg
> alias exec cl clear logg
> alias exec sb show ip bgp
> alias exec sibs show ip bgp su
> alias exec cb clear ip bgp * soft
> alias exec sir show ip route
> alias exec so show ip os ne
> alias exec sip show ip protocols
> alias exec cir clear ip route *
> alias exec u no debug all
> alias exec b sh run | begin
> !
> line con 0
> exec-timeout 0 0
> privilege level 15
> logging synchronous
> line aux 0
> line vty 0 4
> password cisco
> login
> !
> ntp clock-period 17208146
> ntp source Loopback0
> ntp server 142.20.6.1
> !
> end
>
>
>
>
> Cordialmente,
> ------------------------------------------------------------------
> Alaerte Gladston Vidali
> IBM Global Services - SO
> Tel.55+11+2121-2879 Fax:55+11+2121-2449
>
>
>
>
> "Amit Jain" <netsteps@rediffmail.com>
> 14/06/2005 10:46
> Please respond to
> "Amit Jain" <netsteps@rediffmail.com>
>
>
> To
> Alaerte Gladston Vidali/Brazil/IBM@IBMBR, <ccielab@groupstudy.com>
> cc
>
> Subject
> Re: NET-RED message
>
>
>
>
>
>
> Do you have redistribution on router ?? Net-Red might be hint to network
> redistribution message.
> Can you paste your configs.
>
> Amit
> ----- Original Message -----
> From: <gladston@br.ibm.com>
> To: <ccielab@groupstudy.com>
> Sent: Tuesday, June 14, 2005 6:04 PM
> Subject: NET-RED message
>
>
> > Hi,
> >
> > Do you know what does this message mean?
> >
> >
> > Rack2R4#deb ip routing
> >
> > Jun 14 12:24:02: RT: NET-RED 0.0.0.0/0
> > Jun 14 12:24:02: RT: NET-RED queued, Queue size 1
> >
> > Route 0.0.0.0 is on the RIB for a long time:
> >
> > Rack2R4#sir
> >
> > Gateway of last resort is 142.20.14.1 to network 0.0.0.0
> >
> > 171.68.0.0/16 is variably subnetted, 4 subnets, 2 masks
> > O 171.68.1.1/32 [110/1563] via 142.20.14.1, 00:23:56, Serial0/0
> > S 171.68.16.10/32 [1/0] via 142.20.44.7
> > O 171.68.20.1/32 [110/1563] via 142.20.14.1, 00:23:56, Serial0/0
> > S 171.68.16.0/24 is directly connected, Null0
> > 55.0.0.0/24 is subnetted, 1 subnets
> > C 55.55.55.0 is directly connected, Loopback20
> > O IA 142.200.0.0/16 [110/1563] via 142.20.14.1, 00:22:03, Serial0/0
> > 142.44.0.0/16 is variably subnetted, 3 subnets, 2 masks
> > O IA 142.44.0.0/16 [110/1762] via 142.20.14.1, 00:22:05, Serial0/0
> > C 142.44.4.0/24 is directly connected, Loopback30
> > C 142.44.8.0/24 is directly connected, Loopback31
> > 172.16.0.0/24 is subnetted, 1 subnets
> > S 172.16.88.0 [1/0] via 142.20.44.7
> > 142.16.0.0/24 is subnetted, 1 subnets
> > O E2 142.16.55.0 [110/20] via 142.20.14.1, 00:21:55, Serial0/0
> > 142.20.0.0/16 is variably subnetted, 19 subnets, 3 masks
> > O 142.20.155.1/32 [110/3125] via 142.20.14.1, 00:22:05, Serial0/0
> > O IA 142.20.28.0/24 [110/3134] via 142.20.14.1, 00:16:42, Serial0/0
> > O E2 142.20.23.0/24 [110/20] via 142.20.14.1, 00:21:55, Serial0/0
> > O IA 142.20.8.1/32 [110/3135] via 142.20.14.1, 00:16:38, Serial0/0
> > C 142.20.14.0/24 is directly connected, Serial0/0
> > O 142.20.14.1/32 [110/1562] via 142.20.14.1, 00:23:58, Serial0/0
> > O E2 142.20.3.0/24 [110/20] via 142.20.14.1, 00:21:55, Serial0/0
> > O 142.20.2.1/32 [110/3125] via 142.20.14.1, 00:22:05, Serial0/0
> > O 142.20.1.1/32 [110/1563] via 142.20.14.1, 00:22:05, Serial0/0
> > O E2 142.20.6.0/24 [110/20] via 142.20.14.1, 00:21:55, Serial0/0
> > R 142.20.7.0/24 [120/1] via 142.20.47.7, 00:00:06, Ethernet0/1
> > O 142.20.5.1/32 [111/3125] via 142.20.14.1, 00:22:06, Serial0/0
> > C 142.20.4.0/24 is directly connected, Loopback0
> > O E2 142.20.56.0/24 [110/20] via 142.20.14.1, 00:21:56, Serial0/0
> > C 142.20.47.0/24 is directly connected, Ethernet0/1
> > C 142.20.44.0/24 is directly connected, Ethernet0/0.4
> > C 142.20.45.0/24 is directly connected, BRI0/0
> > O E2 142.20.65.0/24 [110/20] via 142.20.14.1, 00:21:56, Serial0/0
> > O 142.20.125.0/27 [110/3124] via 142.20.14.1, 00:22:06, Serial0/0
> > 11.0.0.0/32 is subnetted, 1 subnets
> > O IA 11.11.11.1 [110/3125] via 142.20.14.1, 00:22:06, Serial0/0
> > 44.0.0.0/24 is subnetted, 1 subnets
> > C 44.44.44.0 is directly connected, Loopback44
> > 150.100.0.0/16 is variably subnetted, 2 subnets, 2 masks
> > O E2 150.100.10.9/32 [110/20] via 142.20.14.1, 00:21:16, Serial0/0
> > O E2 150.100.10.0/24 [110/20] via 142.20.14.1, 00:21:16, Serial0/0
> > O*E2 0.0.0.0/0 [110/1] via 142.20.14.1, 00:21:56, Serial0/0
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Wed Jul 06 2005 - 14:43:41 GMT-3