From: Mark Lasarko (mlasarko@co.ba.md.us)
Date: Wed Jun 01 2005 - 15:42:30 GMT-3
Indeed, a fun way to have a port up/up and not send any traffic at all :)
The vlan manager port mode change notification debug shows similar to a
'shut'
(in the example below vlan 254 is configured, vlan 2 is not)
<./begin_example1>
SW2#u all
All possible debugging has been turned off
SW2#sh interfaces fa0/24 switchport | i Access
Access Mode VLAN: 254 (VLAN0254)
SW2#sh cdp nei
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
Device ID Local Intrfce Holdtme Capability Platform Port ID
BB2 Fas 0/24 159 R 2500 Eth 0
SW2#debug sw-vlan not mode
vlan manager port mode change notification debugging is on
SW2#config t
Enter configuration commands, one per line. End with CNTL/Z.
SW2(config)#int fa0/24
SW2(config-if)#switchport access vlan 2
SW2(config-if)#
01:48:06: ++sw-vlan MODECHANGE: PORT Fa0/24, cookie 0x10B4878 mode change to
none
01:48:06: ++sw-vlan MODECHANGE: PORT Fa0/24, cookie 0x10B4878 mode change to
access
SW2(config-if)#end
SW2#sh interfaces fa0/24 switchport | i Access
Access Mode VLAN: 2 (Inactive)
(now our neighbor times out - even though the debugs indicate cdp continues to
send packets)
<./begin_example1>
So for me this yields two more questions. When the vlan is not available on
the switch in client mode we still have CDP sending packets, but the interface
counters do not reflect this?
<./begin_example2>
SW2#
02:21:00: CDP-PA: version 2 packet sent out on FastEthernet0/24
02:21:05: CDP-PA: version 2 packet sent out on FastEthernet0/24
02:21:10: CDP-PA: version 2 packet sent out on FastEthernet0/24
SW2#sh int fa0/24 | i output
input flow-control is off, output flow-control is unsupported
Last input 00:25:48, output 00:25:29, output hang never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
<./end_example2>
Question 1: Why (ASIC?, VTP??, duh???)
Next,
on BB2 running IOS (tm) 2500 Software (C2500-IK8OS-L), Version 12.2(23)
there are a few unknown TLV's being seen from the 3550
Both devices are running recent code with cdp v2:
<./begin_example3>
Jun 1 14:30:25.347 EST: CDP-EV: Unrecognized type (12) seen in TLV
Jun 1 14:30:25.351 EST: CDP-EV: Unrecognized type (13) seen in TLV
Jun 1 14:30:25.351 EST: CDP-EV: Unrecognized type (16) seen in TLV
<./end_example3>
Question 2: Does anyone have a reference for this?
(I looked for info on these for a few minutes and did not find what I was
looking for)
TIA,
~M
>>> <gladston@br.ibm.com> 06/01/05 11:52 AM >>>
CAT2 is vtp client.
BB2 is connected to CAT2
If configuring this:
interface FastEthernet0/12
switchport access vlan 300
switchport mode access
no ip address
spanning-tree portfast
Considering the Vlan was not created first, CDP will not be announced.
This was new for me. I though CDP was always advertised, but the following
test confirms that if the Vlan does not exist, it is not advertised.
First, CAT2, fa0/12 is configured with and existing Vlan (received from CAT1
via vtp announce).
Then, I change the vlan using 'switchport access vlan 300'. As CAT2 is client,
the vlan is not created.
This cause BB2 to loose CDP information.
I can see a problem like this taking our time (during the lab) looking for
other configuration problems between CAT2---BB2.
bb2#sh cdp ne
Device ID Local Intrfce Holdtme Capability Platform Port ID
cat2 Eth 0 162 R S I WS-C3550-2Fas 0/12
TERMSERV1>res cat2
[Resuming connection 6 to cat2 ... ]
cat2#sh run int fa 0/12
interface FastEthernet0/12
switchport access vlan 125
switchport mode access
no ip address
spanning-tree portfast
end
cat2#c
cat2(config)#int fa 0/12
cat2(config-if)#sw ac vl 300
cat2#sh vlan
VLAN Name Status Ports
---- -------------------------------- ---------
-------------------------------
1 default active Fa0/3, Fa0/4, Fa0/10, Fa0/13
Fa0/14, Fa0/15, Fa0/16,
Fa0/17
Fa0/18, Fa0/19, Fa0/20,
Fa0/21
Gi0/1, Gi0/2
18 VLAN0018 active Fa0/1
19 VLAN0019 active
26 VLAN0026 active Fa0/6
48 VLAN0048 active
57 VLAN0057 active Fa0/7, Fa0/8
116 VLAN0116 active
125 VLAN0125 active Fa0/5
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
TERMSERV1>resu bb2
bb2#sh cdp ne det
-------------------------
Device ID: cat2
Entry address(es):
IP address: 172.16.29.9
Platform: cisco WS-C3550-24, Capabilities: Router Switch IGMP
Interface: Ethernet0, Port ID (outgoing port): FastEthernet0/12
Holdtime : 116 sec
Version :
Cisco Internetwork Operating System Software
IOS (tm) C3550 Software (C3550-I5K2L2Q3-M), Version 12.1(19)EA1c, RELEASE
SOFTWARE (fc2
)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 03-Feb-04 10:39 by yenanh
advertisement version: 2
Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=27,
value=00000000FFFFFF
FF010221FF000000000000000BFDCB1380FF0000
VTP Management Domain: 'ccie'
Native VLAN: 125
Duplex: half
bb2#sh cdp ne det
-------------------------
Device ID: cat2
Entry address(es):
IP address: 172.16.29.9
Platform: cisco WS-C3550-24, Capabilities: Router Switch IGMP
Interface: Ethernet0, Port ID (outgoing port): FastEthernet0/12
Holdtime : 102 sec
Version :
Cisco Internetwork Operating System Software
IOS (tm) C3550 Software (C3550-I5K2L2Q3-M), Version 12.1(19)EA1c, RELEASE
SOFTWARE (fc2
)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 03-Feb-04 10:39 by yenanh
advertisement version: 2
Protocol Hello: OUI=0x00000C, Protocol ID=0x0112; payload len=27,
value=00000000FFFFFF
FF010221FF000000000000000BFDCB1380FF0000
VTP Management Domain: 'ccie'
Native VLAN: 125
Duplex: half
bb2#
bb2#clear cdp ta
bb2#sh cdp ne det
bb2#sh cdp ne
Device ID Local Intrfce Holdtme Capability Platform Port ID
bb2#sh cdp ne
Device ID Local Intrfce Holdtme Capability Platform Port ID
bb2#deb cdp pa
CDP packet info debugging is on
bb2#deb cdp ev
CDP events debugging is on
03:37:35: CDP-PA: version 2 packet sent out on Ethernet0
bb2#sh run int e0
Building configuration...
Current configuration : 67 bytes
!
interface Ethernet0
ip address 150.100.2.254 255.255.255.0
end
bb2#
This archive was generated by hypermail 2.1.4 : Wed Jul 06 2005 - 14:43:40 GMT-3