Priority Queue under Sub-interface

From: gladston@br.ibm.com
Date: Fri May 06 2005 - 17:52:41 GMT-3


Is it possible to configure Priority Queue under subinteface if not using 'frame-relay traffic-shaping'?

It does accept the commands, does not complain (12.2T, 2600), but could not find a show command to monitor it.

(I have configured CBWQF under that condition - without traffic-shaping).

With traffic shaping, that is ok:

Rack2R3#sh fram pvc 200

PVC Statistics for interface Serial1/3 (Frame Relay DCE)

DLCI = 200, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/3.23

  input pkts 1610 output pkts 5520 in bytes 1945588
  out bytes 5952944 dropped pkts 0 in pkts dropped 0
  out pkts dropped 0 out bytes dropped 0
  in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
  out BECN pkts 0 in DE pkts 0 out DE pkts 0
  out bcast pkts 5164 out bcast bytes 5933104
  5 minute input rate 1000 bits/sec, 0 packets/sec
  5 minute output rate 5000 bits/sec, 1 packets/sec
  pvc create time 03:06:41, last time pvc status changed 03:06:30
  cir 56000 bc 7000 be 0 byte limit 875 interval 125
  mincir 28000 byte increment 875 Adaptive Shaping none
  pkts 532 bytes 537291 pkts delayed 6 bytes delayed 510
  shaping inactive
  traffic shaping drops 0
  Queueing strategy: priority-list 1

List Queue Args
1 high protocol ip list 160
  Output queue: high 0/20/0, medium 0/40/0, normal 0/60/0, low 0/80/0
Rack2R3#
Rack2R3#sh run int ser 1/3
Building configuration...

Current configuration : 158 bytes
!
interface Serial1/3
 no ip address
 encapsulation frame-relay
 clockrate 128000
 no fair-queue
 frame-relay traffic-shaping
 frame-relay intf-type dce
end

Without traffic shaping, no monitor commands to check:

Rack2R3#c
Enter configuration commands, one per line. End with CNTL/Z.
Rack2R3(config)#int ser 1/3
Rack2R3(config-if)#no frame-relay traffic-shaping
Rack2R3(config-if)#do sh run int ser 1/3.23
Building configuration...

Current configuration : 346 bytes
!
interface Serial1/3.23 multipoint
 ip address 142.20.23.3 255.255.255.0
 ip router isis
 isis circuit-type level-2-only
 isis authentication mode md5 level-2
 isis authentication key-chain Isis-authen
 frame-relay map clns 200 broadcast
 frame-relay map ip 142.20.23.2 200 broadcast
 frame-relay interface-dlci 200
  class Frame-Priority
end

Rack2R3#sh fram pvc 200

PVC Statistics for interface Serial1/3 (Frame Relay DCE)

DLCI = 200, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial1/3.23

  input pkts 1619 output pkts 5552 in bytes 1956230
  out bytes 5986954 dropped pkts 0 in pkts dropped 0
  out pkts dropped 0 out bytes dropped 0
  in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
  out BECN pkts 0 in DE pkts 0 out DE pkts 0
  out bcast pkts 5193 out bcast bytes 5966963
  5 minute input rate 2000 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
  pvc create time 03:07:46, last time pvc status changed 03:07:35
Rack2R3#
Rack2R3#sh run
Building configuration...

Current configuration : 3144 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Rack2R3
!
logging queue-limit 100
!
memory-size iomem 10
ip subnet-zero
!
!
no ip domain lookup
!
ip cef
mpls ldp logging neighbor-changes
frame-relay switching
!
!
key chain Isis-authen
 key 1
  key-string cisco
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
 class-map match-all rtp
  match protocol rtp audio
!
!
 policy-map rtp
  class rtp
   priority 32
 policy-map shape-all
  class class-default
   shape average 96000 9600
   service-policy rtp
!
!
!
!
interface Loopback0
 ip address 142.20.3.1 255.255.255.0
 ip router isis
!
interface Ethernet0/0
 ip address 150.100.20.3 255.255.255.0
 ip access-group Fragments in
 half-duplex
!
interface Serial1/0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1/1
 no ip address
 shutdown
!
interface Serial1/2
 no ip address
 shutdown
!
interface Serial1/3
 no ip address
 encapsulation frame-relay
 clockrate 128000
 no fair-queue
 frame-relay intf-type dce
!
interface Serial1/3.23 multipoint
 ip address 142.20.23.3 255.255.255.0
 ip router isis
 isis circuit-type level-2-only
 isis authentication mode md5 level-2
 isis authentication key-chain Isis-authen
 frame-relay map clns 200 broadcast
 frame-relay map ip 142.20.23.2 200 broadcast
 frame-relay interface-dlci 200
  class Frame-Priority
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
router isis
 net 49.0023.3333.3333.3333.00
 authentication mode md5 level-2
 authentication key-chain Isis-authen
!
router bgp 65203
 no synchronization
 bgp router-id 142.20.3.1
 bgp log-neighbor-changes
 bgp confederation identifier 20
 bgp confederation peers 65202
 neighbor 142.20.23.2 remote-as 65202
 neighbor 142.20.23.2 next-hop-self
 neighbor 150.100.20.254 remote-as 254
 neighbor 150.100.20.254 filter-list 60 out
 no auto-summary
!
ip http server
ip classless
!
ip as-path access-list 50 permit ^$
ip as-path access-list 50 permit ^65202$
ip as-path access-list 60 permit ^$
!
!
ip access-list extended Fragments
 deny tcp any any fragments
 deny udp any any fragments
 deny icmp any any fragments
 permit ip any any
!
!
map-class frame-relay Frame-Priority
 frame-relay priority-group 1



This archive was generated by hypermail 2.1.4 : Fri Jun 03 2005 - 10:11:56 GMT-3