RE: IP CEF - Load Balancing

From: Dennis J. Hartmann (dhartma5@optonline.net)
Date: Fri May 06 2005 - 17:27:30 GMT-3


        CEF does per source/destination load-balancing by default (for
transiting traffic). All process switched traffic is always per-packet
load-balanced. If it's the same source and destiantion, it shoud be using
the same interface.

-Dennis Hartmann

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
gladston@br.ibm.com
Sent: Friday, May 06, 2005 4:18 PM
To: ccielab@groupstudy.com
Subject: IP CEF - Load Balancing

Although it shows it is using two interfaces, it uses just e1/0

Any idea what happens on the algorithm?

Rack2R5#sh ip cef

142.20.6.0/24 142.20.56.6 Ethernet0/0
                    142.20.65.6 Ethernet1/0

Rack2R5#sir 142.20.6.0
Routing entry for 142.20.6.0/24
  Known via "eigrp 10", distance 90, metric 409600, type internal
  Redistributing via eigrp 10, ospf 1
  Advertised by ospf 1 subnets
  Last update from 142.20.65.6 on Ethernet1/0, 01:11:10 ago
  Routing Descriptor Blocks:
  * 142.20.56.6, from 142.20.56.6, 01:11:10 ago, via Ethernet0/0
      Route metric is 409600, traffic share count is 1
      Total delay is 6000 microseconds, minimum bandwidth is 10000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1
    142.20.65.6, from 142.20.65.6, 01:11:10 ago, via Ethernet1/0
      Route metric is 409600, traffic share count is 1
      Total delay is 6000 microseconds, minimum bandwidth is 10000 Kbit
      Reliability 255/255, minimum MTU 1500 bytes
      Loading 1/255, Hops 1

Rack2R5#sh policy-map interface e0/0
 Ethernet0/0

  Service-policy output: Premium-gold-normal

    Class-map: normal (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol tftp
      Queueing
        Output Queue: Conversation 265
        Bandwidth 1125 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
      QoS Set
        precedence 5
          Packets marked 0

    Class-map: gold (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol telnet
      Queueing
        Output Queue: Conversation 266
        Bandwidth 2250 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
      QoS Set
        precedence 4
          Packets marked 0

    Class-map: premium (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol rtp
      Queueing
        Output Queue: Conversation 267
        Bandwidth 3375 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)
      2145 packets, 169239 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
Rack2R5#
Rack2R5#sh policy-map interface e1/0
 Ethernet1/0

  Service-policy output: Premium-gold-normal

    Class-map: normal (match-all)
      36 packets, 1735 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol tftp
      Queueing
        Output Queue: Conversation 265
        Bandwidth 1125 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
      QoS Set
        precedence 5
          Packets marked 36

    Class-map: gold (match-all)
      317 packets, 17461 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol telnet
      Queueing
        Output Queue: Conversation 266
        Bandwidth 2250 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0
      QoS Set
        precedence 4
          Packets marked 317

    Class-map: premium (match-all)
      0 packets, 0 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: protocol rtp
      Queueing
        Output Queue: Conversation 267
        Bandwidth 3375 (kbps) Max Threshold 64 (packets)
        (pkts matched/bytes matched) 0/0
        (depth/total drops/no-buffer drops) 0/0/0

    Class-map: class-default (match-any)
      1680 packets, 140067 bytes
      5 minute offered rate 0 bps, drop rate 0 bps
      Match: any
Rack2R5#

sh run
ip cef
ipv6 unicast-routing
mpls ldp logging neighbor-changes
isdn switch-type basic-ni
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
 class-map match-all gold
  match protocol telnet
 class-map match-all normal
  match protocol tftp
 class-map match-all premium
  match protocol rtp
!
!
 policy-map Premium-gold-normal
  class normal
   bandwidth 1125
   set precedence 5
  class gold
   bandwidth 2250
   set precedence 4
  class premium
   bandwidth 3375
!
!
!
!
interface Loopback0
 ip address 142.20.5.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface Loopback10
 ip address 142.16.55.1 255.255.255.0
!
interface Loopback50
 ip address 190.100.2.1 255.255.255.255
!
interface Tunnel512
 ip unnumbered Loopback0
 ip pim sparse-dense-mode
 tunnel source Loopback0
 tunnel destination 150.100.10.9
!
interface Ethernet0/0
 ip address 142.20.56.5 255.255.255.0
 ip pim sparse-dense-mode
 service-policy output Premium-gold-normal half-duplex !
interface Serial0/0
 ip address 142.20.125.5 255.255.255.224 ip access-group ICMPTRACKER in ip
pim sparse-dense-mode encapsulation frame-relay ip ospf authentication-key
cisco
 ipv6 address 2001:125::5/64
 no fair-queue
 frame-relay traffic-shaping
 frame-relay map ipv6 2001:125::1 501 broadcast frame-relay map ipv6
2001:125::2 502 broadcast frame-relay map ip 142.20.125.1 501 broadcast
frame-relay map ip 142.20.125.2 502 broadcast frame-relay interface-dlci
501
  class Frame-qos-to-r1
 frame-relay interface-dlci 502
  class Frame-qos-to-r2
 no frame-relay inverse-arp
!
interface BRI0/0
 ip address 142.20.45.6 255.255.255.252
 encapsulation ppp
 ip ospf message-digest-key 1 md5 cisco
 dialer idle-timeout 30
 dialer map ip 142.20.45.5 name Rack2R4 broadcast 4441111111 dialer-group 1
isdn switch-type basic-ni isdn spid1 555111111100 5551111111 isdn spid2
555222222200 5552222222 ppp authentication chap !
interface Serial0/1
 no ip address
 shutdown
!
interface Ethernet1/0
 ip address 142.20.65.5 255.255.255.0
 service-policy output Premium-gold-normal half-duplex !
router eigrp 10
 variance 11
 redistribute connected metric 10000 1000 255 1 1500 route-map
connected->eigrp redistribute ospf 1 metric 10000 1000 255 1 1500 network
142.20.56.0 0.0.0.255 network 142.20.65.0 0.0.0.255 auto-summary



This archive was generated by hypermail 2.1.4 : Fri Jun 03 2005 - 10:11:56 GMT-3