From: Dennis J. Hartmann (dhartma5@optonline.net)
Date: Fri May 06 2005 - 14:07:15 GMT-3
My solution would be a little different (although both work).
Instead of memorizing transport layer types and port numbers for
this traffic, use NBAR's capabilities (unless the question forbades such
useage).
Citrix: Match protocol citrix
Lotus: Match protocol notes
Voice: Match protocol rtp audio
H.323: I think we'll have to memorize the fact that H.323 uses TCP port
1720 (as long as we're talking about H.323v2 Call Setup/Teardown
(H.225/H.245) using the Fast Connect functionality. If the scenario does
not mention Fast Connect or the H.323 version / Fast connect, you also have
to match on the TCP port range of 11000 through 11999 for H.245. If you use
auto qos voip on the interface it will generate the policy where you can get
the port numbers, then you can take auto qos off of the interface. No auto
qos voip.
What if the version of IOS I'm using doesn't have those NBAR match
protocol capabilities? Easy. Go onto one of the routers that does have the
NBAR capabilities and use the show ip nbar port-map command. This command
will show you all of the port numbers.
I'm going to try to leverage NBAR as much as possible because it's
so easy.
The NBAR documentation on /univercd will also help you get the port
numbers:
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122
t/122t8/dtnbarad.htm#xtocid8
Sincerely,
Dennis Hartmann
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of marc
fernandez
Sent: Tuesday, May 03, 2005 9:51 PM
To: alissitz@corvil.com; ccielab@groupstudy.com
Subject: RE: QoS config with VOICE, APP, Citrix, lotus sample ( any
comments)
Thanks for the rply Andrew,
Basically I've been asked to provide a default config for the company. Voice
and video will be in there but will not currently be implemented at the
present time.
They just want to have it in the config template and add it later. The
critical application will be added with the maximum bandwidth as it is
critical for the company at this time. I just needed to know if there was
anything wrong with the config itself.
Regards,
- marco
--- Andrew Lee Lissitz <alissitz@corvil.com> wrote:
> Hello Everyone,
>
> Marc, are you asking about the configs or the bandwidth allocation...
> or both?
>
> My comments are on the bandwidth allocation you gave. What speed
> links are you using these configs for, and how do you know what
> bandwidth amount to give for each class? Interactive and delay
> sensitive traffic has higher bandwidth needs.
>
> Citrix, voice, and lotus each have very differnet quality
> requirements.
> Citrix and voice have much tighter quality requirements than Lotus.
> Will the bandwidth you provided for Citrix and Voice be sufficient to
> provide the quality required by each?
>
> Lotus notes is probably fine with less bandwidth since no one cares if
> their email is a second or two late. But... everyone cares if Citrix
> or voice calls are delayed and do not get their appropriate quallity.
>
> My suggestion Marc would be to carefully examine your bandwidth
> allocation before using these configs.
>
> How much bandwidth you need, is totally determiend by the quality
> targets that each traffic class has. Quality targets refer to queuing
> / buffering delay, jitter through the network, serialization delay (if
> present), and loss percentages.
>
> Kindest Regards Marc and all,
>
> Andrew Lee Lissitz
> 908.303.4762
>
>
> -----Original Message-----
> From: nobody@groupstudy.com
> [mailto:nobody@groupstudy.com] On Behalf Of marc fernandez
> Sent: Saturday, April 30, 2005 11:39 PM
> To: ccielab@groupstudy.com
> Subject: QoS config with VOICE, APP, Citrix, lotus sample ( any
> comments)
>
> I need help. Will this work in a real live situation.
> Any comments will be appreciated. This is a point to point config with
> servers and clients behind each router.
> Attached are the configs. Currently only bandwidth has been assigned.
>
> | |
> |-r1-------------------r4-|
> | |
>
>
>
----------------------------r1-------------------------
> !
> class-map match-all CITRIX
> match access-group name CITRIX
> class-map match-all APPLICATION
> match access-group name APPLICATION
> class-map match-all LOTUS
> match access-group name LOTUS
> class-map match-all VOICE
> match ip rtp 16384 16383
> match access-group name VOICE
> !
> !
> policy-map QoS
> class APPLICATION
> bandwidth percent 70
> class CITRIX
> bandwidth percent 5
> class VOICE
> priority percent 5
> class LOTUS
> bandwidth percent 5
> !
> interface Ethernet0
> ip address 10.1.1.1 255.255.255.0
> ip bandwidth-percent eigrp 1 5
> max-reserved-bandwidth 100
> service-policy output QoS
> !
> router eigrp 1
> network 10.0.0.0
> no auto-summary
> !
> ip access-list extended CITRIX
> permit tcp any any eq 1494
> permit tcp any eq 1494 any
> ip access-list extended LOTUS
> permit tcp any any eq 1352
> permit udp any any eq 1352
> permit tcp any eq 1352 any
> permit udp any eq 1352 any
> ip access-list extended APPLICATION
> permit ip host 10.1.2.1 any
> permit ip any host 10.1.2.1
> ip access-list extended VOICE
> remark H.323/H.225
> permit tcp any any eq 1720
> permit tcp any eq 1720 any
> !
> --------------------------- r4
> ------------------------
>
> class-map match-all CITRIX
> match access-group name CITRIX
> class-map match-all APPLICATION
> match access-group name APPLICATION
> class-map match-all LOTUS
> match access-group name LOTUS
> class-map match-all VOICE
> match ip rtp 16384 16383
> match access-group name VOICE
> !
> !
> policy-map QoS
> class APPLICATION
> bandwidth percent 70
> class CITRIX
> bandwidth percent 5
> class VOICE
> priority percent 5
> class LOTUS
> bandwidth percent 5
> !
> interface Ethernet0
> ip address 10.1.1.4 255.255.255.0
> ip bandwidth-percent eigrp 1 5
> max-reserved-bandwidth 100
> service-policy output QoS
> !
> ip access-list extended CITRIX
> permit tcp any any eq 1494
> permit tcp any eq 1494 any
> ip access-list extended LOTUS
> permit tcp any any eq 1352
> permit udp any any eq 1352
> permit tcp any eq 1352 any
> permit udp any eq 1352 any
> ip access-list extended APPLICATION
> permit ip any host 10.1.2.1
> permit ip host 10.1.2.1 any
> ip access-list extended VOICE
> remark H.323/H.225
> permit tcp any any eq 1720
> permit tcp any eq 1720 any
> !
>
-------------------------------------------------------------------
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
>
This archive was generated by hypermail 2.1.4 : Fri Jun 03 2005 - 10:11:56 GMT-3