From: Ralph (Mandela@myrealbox.com)
Date: Wed Apr 06 2005 - 21:46:55 GMT-3
This solution is indeed pretty, but it also WORKS!!
Here is a sample config:
R7---------------------------R8
BEFORE SETTING METRIC:
r8#
r8#sh run
!
!
!
interface Loopback0
ip address 200.8.8.8 255.255.255.0
!
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
no fair-queue
!
router ospf 1
log-adjacency-changes
redistribute connected subnets route-map connect2ospf
network 10.1.1.0 0.0.0.255 area 0
!
!
access-list 1 permit 200.8.8.0 0.0.0.255
!
route-map connect2ospf permit 10
match ip address 1
!
!
!
!!
end
r7#sh run
!
!
!
interface Loopback0
ip address 200.7.7.7 255.255.255.0
no clns route-cache
!
ip address 10.1.1.1 255.255.255.0
clockrate 128000
no fair-queue
no clns route-cache
!
no clns route-cache
!
router ospf 1
log-adjacency-changes
network 10.1.1.0 0.0.0.255 area 0
!
r7#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 200.7.7.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
O E2 200.8.8.0/24 [110/20] via 10.1.1.2, 00:02:26, Serial0/0
AFTER SETTING METRIC:
r8#sh run
!
interface Loopback0
ip address 200.8.8.8 255.255.255.0
!
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
no fair-queue
!
!
router ospf 1
log-adjacency-changes
redistribute connected subnets route-map connect2ospf
network 10.1.1.0 0.0.0.255 area 0
access-list 1 permit 200.8.8.0 0.0.0.255
!
route-map connect2ospf permit 10
match ip address 1
set metric 5
!
!
r7#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 200.7.7.0/24 is directly connected, Loopback0
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0
O E2 200.8.8.0/24 [110/5] via 10.1.1.2, 00:01:55, Seri
-----Original Message-----
From: Ed Lui <edwlui@gmail.com>
To: OzgurG@garanti.com.tr
Date: Wed, 6 Apr 2005 16:33:25 -0700
Subject: Re: Changing the cost of a specific route on OSPF
I would not go with the pretty way which doesn't work. Thanks for the info.
On Apr 6, 2005 8:03 AM, OzgurG@garanti.com.tr <OzgurG@garanti.com.tr> wrote:
> One possible soln...
> create two ospf processes,
> 2nd one, not neighboring that router with a lower AD.
> Then change the metric of that specific route while redistributing from
> one process to the other.
> An ugly way to do it but that should work.
>
> "The most incomprehensible thing about the world is
> that it is comprehensible." A. Einstein
>
> Ozgur Guler
> CCIE #13237
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> mani poopal
> Sent: 06 April 2005 17:36
> To: ccie2be; gladston@br.ibm.com; ccielab@groupstudy.com
> Subject: RE: Changing the cost of a specific route on OSPF
>
> Hi Tim,
>
> Good information, I think your second option affect all routes and not
> specific routes. For the first option(neighbor x.x.x.x cost y), do we
> need the ospf network type to be either non-braodcast or
> point-to-multipoint non-braodcast.
>
> Mani
>
> ccie2be <ccie2be@nyc.rr.com> wrote:
> 2 options come to mind.
>
> 1) ospf has a neighbor x.x.x.x cost command.
>
> 2) ospf computes cost on the basis of bandwidth, so if you can change
> the bandwidth on the interface to R6 that would work as long as the
> interface to
> R6 is different than the interface to R1.
>
> HTH, Tim
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> gladston@br.ibm.com
> Sent: Wednesday, April 06, 2005 9:49 AM
> To: ccielab@groupstudy.com
> Subject: Changing the cost of a specific route on OSPF
>
> Can you think a way to change the metric of one (just one) route
> received from a OSPF neighbor?
>
> For example, R6 and R2 are both connected to R1.
> R1 receives the same five routes from R6 and R2.
> Is there a way to change the cost of just one of the routes received by
> R1 from R6?
>
> I could not find a way, using OSPF.
> I could influence the selection by using PBR, but is there other way?
>
> Something like "offset list" for OSPF.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> B.ENG,A+,CCNA,CCNP,CCNP-VOICE, CSS1,CNA,MCSE
> (416)431 9929
> MANI_CCIE@YAHOO.COM
> __________________________________________________
> Do You Yahoo!?
> Tired of spam? Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> This message and attachments are confidential and intended solely for the individual(s) stated in this
> message.If you received this message although you are not the addressee you are responsible to keep the
> message confidential .The sender has no responsibility for the accuracy or correctness of the
> information in the message and its attachments.Our company shall have no liability for any changes
> or late receiving,loss of integrity and confidentiality,viruses and any damages caused in
> anyway to your computer system.
>
> Bu mesaj ve ekleri mesajda gonderildigi belirtilen kisi/kisilere ozeldir ve gizlidir.Bu mesajin muhatabi
> olmamaniza ragmen tarafiniza ulasmis olmasi halinde mesaj iceriginin gizliligi ve bu gizlilik yukumlulugune
> uyulmasi zorunlulugu tarafiniz icin de soz konusudur.Mesaj ve eklerinde yer alan bilgilerin dogrulugu ve
> guncelligi konusunda gonderenin ya da sirketimizin herhangi bir sorumlulugu bulunmamaktadir.Sirketimiz
> mesajin ve bilgilerinin size degisiklige ugrayarak veya gec ulasmasindan, butunlugunun ve gizliliginin
> korunamamasindan, virus icermesinden ve bilgisayar sisteminize verebilecegi herhangi bir zarardan
> sorumlu tutulamaz.
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Tue May 03 2005 - 07:54:54 GMT-3