RE: DHCP - Quick Practice IP SERVICES Question for ya (2%) -

From: Keane, James (James.Keane@agriculture.gov.ie)
Date: Wed Apr 06 2005 - 11:23:58 GMT-3


 The plot thickens !

Here is the debug AFTER doing kevins suggestion (using client identifier instead - thanks!!!)

Apr 6 15:02:45.612: DHCPD: checking for expired leases.
Apr 6 15:03:15.372: DHCPD: DHCPDISCOVER received from client 0100.4096.5745.a8 on interface Ethernet0.
Apr 6 15:03:15.372: DHCPD: requested address 10.99.1.50 has already been assigned.
Apr 6 15:03:17.372: DHCPD: assigned IP address 10.99.1.82 to client 0100.4096.5745.a8.
Apr 6 15:03:17.372: DHCPD: Sending DHCPOFFER to client 0100.4096.5745.a8 (10.99.1.82).
Apr 6 15:03:17.372: DHCPD: creating ARP entry (10.99.1.82, 0040.9657.45a8).
Apr 6 15:03:17.372: DHCPD: unicasting BOOTREPLY to client 0040.9657.45a8 (10.99.1.82).
Apr 6 15:03:22.390: DHCPD: DHCPREQUEST received from client 0100.4096.5745.a8.
Apr 6 15:03:22.394: DHCPD: Sending DHCPACK to client 0100.4096.5745.a8 (10.99.1.82).
Apr 6 15:03:22.394: DHCPD: creating ARP entry (10.99.1.82, 0040.9657.45a8).
Apr 6 15:03:22.394: DHCPD: unicasting BOOTREPLY to client 0040.9657.45a8 (10.99.1.82).

Ok so the client is sending 0100.4096.5745.a8

0100.4096.5745.a8 - so I need to match that ... hang on ... thats not its mac address !!!

its mac is 0040.9657.45a8

I can only assume that its sending 01 as DHCP Ethernet media type (see WEBREF#1 below)

ok I'll try that

ip dhcp pool MyReservedAddress

   host 10.99.1.50 255.255.255.0
   client-identifier 0100.4096.5745.a8

Now with that I see the following Debug

Apr 6 15:18:45.627: DHCPD: checking for expired leases.
Apr 6 15:18:49.083: DHCPD: DHCPDISCOVER received from client 0100.4096.5745.a8 on interface Ethernet0.
Apr 6 15:18:49.083: DHCPD: Sending DHCPOFFER to client 0100.4096.5745.a8 (10.99.1.50).
Apr 6 15:18:49.083: DHCPD: creating ARP entry (10.99.1.50, 0040.9657.45a8).
Apr 6 15:18:49.083: DHCPD: unicasting BOOTREPLY to client 0040.9657.45a8 (10.99.1.50).
Apr 6 15:18:54.079: DHCPD: DHCPREQUEST received from client 0100.4096.5745.a8.
Apr 6 15:18:54.083: DHCPD: Sending DHCPACK to client 0100.4096.5745.a8 (10.99.1.50).
Apr 6 15:18:54.083: DHCPD: creating ARP entry (10.99.1.50, 0040.9657.45a8).
Apr 6 15:18:54.083: DHCPD: unicasting BOOTREPLY to client 0040.9657.45a8 (10.99.1.50).

wo wo wo - hang on - It works !! The power of the Debug !

so the mega got-cha's

Hardware-address doesnt work (well - not very well for me)
and when you are putting in a client-identifier you must put a 01 for ethernet before it
and reformat the mac address, looks disgusting but it works !

Thanks

WEBREF#1
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/ipcprt1/1cfdhcp.htm#wp1001108

-----Original Message-----
From: ccie [mailto:ccie@gannons.net]
Sent: 06 April 2005 14:55
To: Keane, James
Subject: Re: DHCP - Quick Practice IP SERVICES Question for ya (2%)

Client:
Switch#sh run int fas 0/1
Building configuration...

Current configuration : 91 bytes
!
interface FastEthernet0/1
 no switchport
 ip address dhcp client-id FastEthernet0/1
end

Switch#sh int fas 0/1
FastEthernet0/1 is up, line protocol is up (connected)
  Hardware is Fast Ethernet, address is 000a.8a6c.8b00 (bia 000a.8a6c.8b00)

Server:
-------------------------------
ip dhcp pool AP
   network 10.10.10.0 255.255.255.0
   domain-name TEST.com
!
ip dhcp pool SW1
   host 10.10.10.188 255.255.255.0
   client-identifier 0100.0a8a.6c8b.00
!

There is two things to note here if you lab this up and enable debugs on the
server. Without the client-id FastEthernet0/1 the client ID sent is huge and
not very managable this command uses the mac address off the switch for
the client identifier. However there is gotcha here which I will leave
you to
figure out for yourself but it relates to the client id and the mac address
being different slightly see the ulr below:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/ipcprt1/1cfdhcp.htm#wp1001108

In my case the DHCP request from the client sends the client ID even if
I dont ask it to. Clients may differ.

Regards,
Kevin

>Ok here is a fairly basic sinario
>
>I have a network 10.99.1.0/24
>I want the PCs 10.99.1.75 - 10.99.1.254
>I want an AP to be 10.99.1.50 (mac = 0040.9657.548a)
>
>So where is DHCP config below wrong ??
>
>service dhcp
>no ip dhcp conflict logging
>ip dhcp excluded-address 10.99.1.1 10.99.1.49
>ip dhcp excluded-address 10.99.1.51 10.99.1.74
>!
>ip dhcp pool ClientPOOL
> network 10.99.1.0 255.255.255.0
> dns-server 10.0.9.50
> domain-name MYBIGDOMAIN
> default-router 10.99.1.1
> lease 7
>!
>ip dhcp pool MyReservedAddress
> host 10.99.1.50 255.255.255.0
> hardware-address 0040.9657.548a ieee802
> client-name WirelessAP
> default-router 10.99.1.1
> domain-name MYBIGDOMAIN
> dns-server 10.0.9.50
>
>
>I keep getting the next index on the ClientPool for the AP ?!?!?!
>
>
>TESTLab-1#sho ip dhcp pool
>
>Pool ClientPool :
> Utilization mark (high/low) : 100 / 0
> Subnet size (first/next) : 0 / 0
> Total addresses : 254
> Leased addresses : 0
> Pending event : none
> 1 subnet is currently in the pool :
> Current index IP address range Leased addresses
> 10.99.1.82 10.99.1.1 - 10.99.1.254 0
>
>Pool MyReservedAddress :
> Utilization mark (high/low) : 100 / 0
> Subnet size (first/next) : 0 / 0
> Total addresses : 1
> Leased addresses : 1
> Pending event : none
> 1 subnet is currently in the pool :
> Current index IP address range Leased addresses
> 10.99.1.50 10.99.1.50 - 10.99.1.50 1
>
>
>**********************************************************************
>*********** Department of Agriculture and Food ***************
>
>The information contained in this email and in any
>attachments is confidential and is designated solely
>for the attention and use of the intended recipient(s).
>This information may be subject to legal and professional
>privilege. If you are not an intended recipient of
>this email, you must not use, disclose, copy,
>distribute or retain this message or any part of it.
>If you have received this email in error, please
>notify the sender immediately and delete all copies of
>this email from your computer system(s).
>**********************************************************************
>
>_______________________________________________________________________
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
>
>

**********************************************************************
*********** Department of Agriculture and Food ***************

The information contained in this email and in any
attachments is confidential and is designated solely
for the attention and use of the intended recipient(s).
This information may be subject to legal and professional
privilege. If you are not an intended recipient of
this email, you must not use, disclose, copy,
distribute or retain this message or any part of it.
If you have received this email in error, please
notify the sender immediately and delete all copies of
this email from your computer system(s).
**********************************************************************



This archive was generated by hypermail 2.1.4 : Tue May 03 2005 - 07:54:54 GMT-3