Re: Inter-AS MP-BGP

From: Rodrigo Paes (rpaes@pobox.com)
Date: Sun Mar 27 2005 - 12:47:23 GMT-3


here you go.....

        I cleaned it up a little, the configs are pretty big :-)

R6 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
!
ip vrf bluenet
 rd 2048:62
 route-target export 2048:201
 route-target import 2048:202
 route-target import 2048:201
!
ip cef
!
!
interface Loopback0
 ip address 150.50.6.6 255.255.255.0
!
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0/0/0.1 point-to-point
 pvc 2/200
  encapsulation aal5snap
  protocol ppp dialer
  dialer pool-member 1
 !
!
interface ATM0/0/0.200 tag-switching
 ip address 142.30.76.6 255.255.255.0
 ip router isis
 tag-switching atm control-vc 1 200
 tag-switching atm vpi 0 vci-range 33-63
 tag-switching ip
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart_delay 0
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1/0.26 point-to-point
 ip vrf forwarding bluenet
 ip address 142.30.26.6 255.255.255.0
 frame-relay interface-dlci 602
!
interface Serial1/0.991 point-to-point
 ip address 51.0.6.2 255.255.255.252
 frame-relay interface-dlci 601
!
interface Serial1/0.992 point-to-point
 ip address 52.0.6.2 255.255.255.252
 frame-relay interface-dlci 608
!
interface Dialer1
 ip address 142.30.67.6 255.255.255.0
 ip router isis
 encapsulation ppp
 dialer pool 1
 tag-switching ip
 ppp authentication chap
 isis metric 30
!
router isis
 net 00.0006.0006.0006.00
 is-type level-1
 metric-style wide
 passive-interface Loopback0
!
router bgp 2048
 no synchronization
 bgp router-id 150.50.6.6
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor 51.0.6.1 remote-as 1024
 neighbor 52.0.6.1 remote-as 1025
 neighbor 150.50.7.7 remote-as 2048
 neighbor 150.50.7.7 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor 51.0.6.1 activate
 neighbor 51.0.6.1 send-community both
 neighbor 52.0.6.1 activate
 neighbor 52.0.6.1 send-community both
 neighbor 150.50.7.7 activate
 neighbor 150.50.7.7 next-hop-self
 neighbor 150.50.7.7 send-community both
 no auto-summary
 exit-address-family
 !
 address-family ipv4 vrf bluenet
 neighbor 142.30.26.2 remote-as 65001
 neighbor 142.30.26.2 activate
 neighbor 142.30.26.2 as-override
 neighbor 142.30.26.2 route-map BLUE_IN in
 no auto-summary
 no synchronization
 exit-address-family
!
!
ip prefix-list bluenet_25_lan seq 5 permit 142.30.25.0/24
!
!
route-map BLUE_IN permit 10
 match ip address prefix-list bluenet_25_lan
 set local-preference 400
 set extcommunity soo 2048:20025
!
route-map BLUE_IN permit 20
!

R7<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

!
ip vrf bluenet
 rd 2048:72
 route-target export 2048:201
 route-target import 2048:202
 route-target import 2048:201
!
!
interface Loopback0
 ip address 150.50.7.7 255.255.255.0
!
interface Multilink47
 ip address 142.30.74.7 255.255.255.0
 ip router isis
 tag-switching ip
 ppp multilink
 multilink-group 47
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0/0.1 point-to-point
 pvc 2/200
  encapsulation aal5snap
  protocol ppp dialer
  dialer pool-member 1
 !
!
interface ATM0/0.200 tag-switching
 ip address 142.30.76.7 255.255.255.0
 ip router isis
 tag-switching atm control-vc 1 200
 tag-switching atm vpi 0 vci-range 33-63
 tag-switching ip
!
interface Serial1/0
 no ip address
 encapsulation frame-relay
 serial restart_delay 0
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
!
interface Serial1/0.47 point-to-point
 frame-relay interface-dlci 704 ppp Virtual-Template47
!
interface Serial1/0.57 point-to-point
 ip vrf forwarding bluenet
 ip address 142.30.57.7 255.255.255.0
 frame-relay interface-dlci 705
!
interface Serial1/0.74 point-to-point
 frame-relay interface-dlci 724 ppp Virtual-Template47
!
interface Serial1/0.993 point-to-point
 ip address 53.0.7.2 255.255.255.252
 frame-relay interface-dlci 709
!
interface Virtual-Template47
 no ip address
 ppp authentication chap
 ppp multilink
 multilink-group 47
!
interface Dialer1
 ip address 142.30.67.7 255.255.255.0
 ip router isis
 encapsulation ppp
 dialer pool 1
 tag-switching ip
 ppp authentication chap
 isis metric 30
!
router isis
 net 00.0007.0007.0007.00
 is-type level-1
 metric-style wide
 passive-interface Loopback0
!
router bgp 2048
 no synchronization
 bgp router-id 150.50.7.7
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor PEs peer-group
 neighbor PEs remote-as 2048
 neighbor PEs update-source Loopback0
 neighbor 53.0.7.1 remote-as 1025
 neighbor 150.50.4.4 peer-group PEs
 neighbor 150.50.6.6 peer-group PEs
 no auto-summary
 !
 address-family vpnv4
 neighbor PEs activate
 neighbor PEs route-reflector-client
 neighbor PEs next-hop-self
 neighbor PEs send-community both
 neighbor 53.0.7.1 activate
 neighbor 53.0.7.1 send-community both
 neighbor 150.50.4.4 peer-group PEs
 neighbor 150.50.6.6 peer-group PEs
 no auto-summary
 exit-address-family
 !
 address-family ipv4 vrf bluenet
 neighbor 142.30.57.5 remote-as 65001
 neighbor 142.30.57.5 activate
 neighbor 142.30.57.5 as-override
 neighbor 142.30.57.5 route-map BLUE_IN in
 no auto-summary
 no synchronization
 exit-address-family
!
!
ip prefix-list bluenet_25_lan seq 5 permit 142.30.25.0/24
!
!
route-map BLUE_IN permit 10
 match ip address prefix-list bluenet_25_lan
 set local-preference 200
 set extcommunity soo 2048:20025
!
route-map BLUE_IN permit 20
!
!

BB2<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

!
ip vrf as2_vrf1
 rd 1025:10
 route-target export 1025:10
 route-target export 1025:2010
 route-target import 1025:10
 route-target import 1025:1010
!
ip vrf as2_vrf2
 rd 1025:20
 route-target export 1025:20
 route-target export 1025:2020
 route-target import 1025:20
 route-target import 1025:1020
!
ip vrf as2_vrf3
 rd 1025:30
 route-target export 1025:30
 route-target export 1025:2030
 route-target import 1025:30
 route-target import 1025:1030
!
ip vrf as2_vrf4
 rd 1025:40
 route-target export 1025:40
 route-target export 1025:2040
 route-target import 1025:40
 route-target import 1025:1040
!
ip vrf as2_vrf5
 rd 1025:50
 route-target export 1025:50
 route-target export 1025:2050
 route-target import 1025:50
 route-target import 1025:1050
!
!
interface Loopback0
 ip address 52.1.1.1 255.255.255.255
!
interface Loopback11
!
! THERE ARE A LOT OF LOOPBACKS ;-)
!
interface Loopback53
 ip vrf forwarding as2_vrf5
 ip address 28.50.3.3 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
 no shut
!
interface Serial0/0.2 point-to-point
 ip address 52.0.2.1 255.255.255.252
 frame-relay interface-dlci 802
!
interface Serial0/0.3 point-to-point
 ip address 52.0.3.1 255.255.255.252
 frame-relay interface-dlci 803
!
interface Serial0/0.4 point-to-point
 ip address 52.0.4.1 255.255.255.252
 frame-relay interface-dlci 804
!
interface Serial0/0.5 point-to-point
 ip address 52.0.5.1 255.255.255.252
 frame-relay interface-dlci 805
!
interface Serial0/0.6 point-to-point
 ip address 52.0.6.1 255.255.255.252
 frame-relay interface-dlci 806
!
interface Serial0/0.7 point-to-point
 ip address 52.0.7.1 255.255.255.252
 frame-relay interface-dlci 807
!
interface Serial0/0.9 point-to-point
 ip address 50.0.98.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 809
!
!
router isis
 net 00.1111.1111.1111.00
 is-type level-2-only
 metric-style wide
 passive-interface Loopback0
!
router bgp 1025
 no synchronization
 bgp router-id 52.1.1.1
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor PEERs peer-group
 neighbor PEERs remote-as 2048
 neighbor PEERs route-map EXPORT_MAP out
 neighbor 52.0.2.2 peer-group PEERs
 neighbor 52.0.3.2 peer-group PEERs
 neighbor 52.0.4.2 peer-group PEERs
 neighbor 52.0.5.2 peer-group PEERs
 neighbor 52.0.6.2 peer-group PEERs
 neighbor 52.0.7.2 peer-group PEERs
 neighbor 53.1.1.1 remote-as 1025
 neighbor 53.1.1.1 update-source Loopback0
 no auto-summary
 !
 address-family vpnv4
 neighbor PEERs activate
 neighbor PEERs send-community both
 neighbor PEERs route-map EXPORT_MAP out
 neighbor 52.0.2.2 peer-group PEERs
 neighbor 52.0.3.2 peer-group PEERs
 neighbor 52.0.4.2 peer-group PEERs
 neighbor 52.0.5.2 peer-group PEERs
 neighbor 52.0.6.2 peer-group PEERs
 neighbor 52.0.7.2 peer-group PEERs
 neighbor 53.1.1.1 activate
 neighbor 53.1.1.1 send-community both
 neighbor 53.1.1.1 next-hop-self
 no auto-summary
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf5
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf4
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf3
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf2
 redistribute connected route-map CONNECTED_VRF2
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf1
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
no ip http server
ip classless
!
ip bgp-community new-format
!
!
ip prefix-list ANY seq 5 permit 0.0.0.0/0 le 32
!
ip prefix-list lo11-13 seq 5 permit 28.10.1.0/24
ip prefix-list lo11-13 seq 10 permit 28.10.2.0/24
ip prefix-list lo11-13 seq 15 permit 28.10.3.0/24
!
ip prefix-list lo14-15 seq 5 permit 28.10.4.0/24
ip prefix-list lo14-15 seq 10 permit 28.10.5.0/24
!
ip prefix-list lo21-23 seq 5 permit 28.20.1.0/24
ip prefix-list lo21-23 seq 10 permit 28.20.2.0/24
ip prefix-list lo21-23 seq 15 permit 28.20.3.0/24
!
ip prefix-list lo24-25 seq 5 permit 28.20.4.0/24
ip prefix-list lo24-25 seq 10 permit 28.20.5.0/24
!
ip prefix-list lo31-33 seq 5 permit 28.30.1.0/24
ip prefix-list lo31-33 seq 10 permit 28.30.2.0/24
ip prefix-list lo31-33 seq 15 permit 28.30.3.0/24
!
ip prefix-list lo34-35 seq 5 permit 28.30.4.0/24
ip prefix-list lo34-35 seq 10 permit 28.30.5.0/24
!
ip prefix-list lo41-43 seq 5 permit 28.40.1.0/24
ip prefix-list lo41-43 seq 10 permit 28.40.2.0/24
ip prefix-list lo41-43 seq 15 permit 28.40.3.0/24
!
ip prefix-list lo44-45 seq 5 permit 28.40.4.0/24
ip prefix-list lo44-45 seq 10 permit 28.40.5.0/24
!
ip prefix-list lo51-43 seq 5 permit 28.50.1.0/24
ip prefix-list lo51-43 seq 10 permit 28.50.2.0/24
ip prefix-list lo51-43 seq 15 permit 28.50.3.0/24
!
ip prefix-list lo54-55 seq 5 permit 28.50.4.0/24
ip prefix-list lo54-55 seq 10 permit 28.50.5.0/24
!
!
route-map EXPORT_MAP permit 10
 match ip address prefix-list lo11-13
 set metric 150
 set as-path prepend 1021 1021 1021
 set community 1025:10
!
route-map EXPORT_MAP permit 20
 match ip address prefix-list lo14-15
 set metric 1200
 set as-path prepend 65000 65000 1021 1021
!
route-map EXPORT_MAP permit 30
 match ip address prefix-list lo21-23
 set metric 500
 set as-path prepend 65001 1022 1022
 set community 1025:22
!
route-map EXPORT_MAP permit 40
 match ip address prefix-list lo24-25
 set metric 200
 set as-path prepend 65001 1021 1022
 set community 1025:21
!
route-map EXPORT_MAP permit 50
 match ip address prefix-list lo31-33
 set as-path prepend 65000 65002
 set community 1025:30
!
route-map EXPORT_MAP permit 60
 match ip address prefix-list lo34-35
 set as-path prepend 65000 65000 1020
!
route-map EXPORT_MAP permit 70
 match ip address prefix-list lo54-55
 set metric 10
!
route-map CONNECTED_VRF2 permit 10
 set extcommunity soo 1025:245
!
!

BB3 <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<,

!
!
ip vrf as2_vrf1
 rd 1025:11
 route-target export 1025:10
 route-target export 1025:2010
 route-target import 1025:10
 route-target import 1025:1010
!
ip vrf as2_vrf2
 rd 1025:21
 route-target export 1025:20
 route-target export 1025:2020
 route-target import 1025:20
 route-target import 1025:1020
!
ip vrf as2_vrf3
 rd 1025:31
 route-target export 1025:30
 route-target export 1025:2030
 route-target import 1025:30
 route-target import 1025:1030
!
ip vrf as2_vrf4
 rd 1025:41
 route-target export 1025:40
 route-target export 1025:2040
 route-target import 1025:40
 route-target import 1025:1040
!
ip vrf as2_vrf5
 rd 1025:51
 route-target export 1025:50
 route-target export 1025:2050
 route-target import 1025:50
 route-target import 1025:1050
!
ip cef
!
!
interface Loopback0
 ip address 53.1.1.1 255.255.255.255
!
interface Loopback14
 ip vrf forwarding as2_vrf1
 ip address 28.10.4.4 255.255.255.0
!
! ALSO A LOT OF LOOPBACKS
!
interface Loopback55
 ip vrf forwarding as2_vrf5
 ip address 28.50.5.5 255.255.255.0
!
interface Serial0/0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
 no shut
!
interface Serial0/0.2 point-to-point
 ip address 53.0.2.1 255.255.255.252
 frame-relay interface-dlci 902
!
interface Serial0/0.3 point-to-point
 ip address 53.0.3.1 255.255.255.252
 frame-relay interface-dlci 903
!
interface Serial0/0.4 point-to-point
 ip address 53.0.4.1 255.255.255.252
 frame-relay interface-dlci 904
!
interface Serial0/0.5 point-to-point
 ip address 53.0.5.1 255.255.255.252
 frame-relay interface-dlci 905
!
interface Serial0/0.6 point-to-point
 ip address 53.0.6.1 255.255.255.252
 frame-relay interface-dlci 906
!
interface Serial0/0.7 point-to-point
 ip address 53.0.7.1 255.255.255.252
 frame-relay interface-dlci 907
!
interface Serial0/0.9 point-to-point
 ip address 50.0.98.2 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 908
!
router isis
 net 00.2222.2222.2222.00
 is-type level-2-only
 metric-style wide
 passive-interface Loopback0
!
router bgp 1025
 no synchronization
 bgp router-id 53.1.1.1
 no bgp default route-target filter
 bgp log-neighbor-changes
 neighbor PEERs peer-group
 neighbor PEERs remote-as 2048
 neighbor PEERs route-map EXPORT_MAP out
 neighbor 52.1.1.1 remote-as 1025
 neighbor 52.1.1.1 update-source Loopback0
 neighbor 53.0.2.2 peer-group PEERs
 neighbor 53.0.3.2 peer-group PEERs
 neighbor 53.0.4.2 peer-group PEERs
 neighbor 53.0.5.2 peer-group PEERs
 neighbor 53.0.6.2 peer-group PEERs
 neighbor 53.0.7.2 peer-group PEERs
 no auto-summary
 !
 address-family vpnv4
 neighbor PEERs activate
 neighbor PEERs send-community both
 neighbor PEERs route-map EXPORT_MAP out
 neighbor 52.1.1.1 activate
 neighbor 52.1.1.1 send-community both
 neighbor 52.1.1.1 next-hop-self
 neighbor 53.0.2.2 peer-group PEERs
 neighbor 53.0.3.2 peer-group PEERs
 neighbor 53.0.4.2 peer-group PEERs
 neighbor 53.0.5.2 peer-group PEERs
 neighbor 53.0.6.2 peer-group PEERs
 neighbor 53.0.7.2 peer-group PEERs
 no auto-summary
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf5
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf4
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf3
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf2
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf as2_vrf1
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
no ip http server
ip classless
!
ip bgp-community new-format
!
!
ip prefix-list ANY seq 5 permit 0.0.0.0/0 le 32
!
ip prefix-list lo11-13 seq 5 permit 28.10.1.0/24
ip prefix-list lo11-13 seq 10 permit 28.10.2.0/24
ip prefix-list lo11-13 seq 15 permit 28.10.3.0/24
!
ip prefix-list lo14-15 seq 5 permit 28.10.4.0/24
ip prefix-list lo14-15 seq 10 permit 28.10.5.0/24
!
ip prefix-list lo21-23 seq 5 permit 28.20.1.0/24
ip prefix-list lo21-23 seq 10 permit 28.20.2.0/24
ip prefix-list lo21-23 seq 15 permit 28.20.3.0/24
!
ip prefix-list lo24-25 seq 5 permit 28.20.4.0/24
ip prefix-list lo24-25 seq 10 permit 28.20.5.0/24
!
ip prefix-list lo31-33 seq 5 permit 28.30.1.0/24
ip prefix-list lo31-33 seq 10 permit 28.30.2.0/24
ip prefix-list lo31-33 seq 15 permit 28.30.3.0/24
!
ip prefix-list lo34-35 seq 5 permit 28.30.4.0/24
ip prefix-list lo34-35 seq 10 permit 28.30.5.0/24
!
ip prefix-list lo41-43 seq 5 permit 28.40.1.0/24
ip prefix-list lo41-43 seq 10 permit 28.40.2.0/24
ip prefix-list lo41-43 seq 15 permit 28.40.3.0/24
!
ip prefix-list lo44-45 seq 5 permit 28.40.4.0/24
ip prefix-list lo44-45 seq 10 permit 28.40.5.0/24
!
ip prefix-list lo51-43 seq 5 permit 28.50.1.0/24
ip prefix-list lo51-43 seq 10 permit 28.50.2.0/24
ip prefix-list lo51-43 seq 15 permit 28.50.3.0/24
!
ip prefix-list lo54-55 seq 5 permit 28.50.4.0/24
ip prefix-list lo54-55 seq 10 permit 28.50.5.0/24
!
!
route-map EXPORT_MAP permit 10
 match ip address prefix-list lo11-13
 set metric 200
 set as-path prepend 1021
 set community 1025:11
!
route-map EXPORT_MAP permit 20
 match ip address prefix-list lo14-15
 set metric 1200
 set as-path prepend 65000 1021 1021
!
route-map EXPORT_MAP permit 30
 match ip address prefix-list lo21-23
 set metric 200
 set as-path prepend 65001 1022 1022
 set community 1025:22
!
route-map EXPORT_MAP permit 40
 match ip address prefix-list lo24-25
 set as-path prepend 65001 1021 1022
 set metric 500
 set community 1025:21
!
route-map EXPORT_MAP permit 50
 match ip address prefix-list lo31-33
 set as-path prepend 65002 65002
 set community 1025:30
!
route-map EXPORT_MAP permit 60
 match ip address prefix-list lo34-35
 set metric 100
 set as-path prepend 65000 65000 1020
!
route-map EXPORT_MAP permit 70
 match ip address prefix-list lo54-55
 set metric 2000
!
!
route-map CONNECTED_VRF2 permit 10
 set extcommunity soo 1025:245
!

[]'s
Rodrigo



This archive was generated by hypermail 2.1.4 : Sun Apr 03 2005 - 17:56:52 GMT-3