Re: OSPF NETWORK TYPE

From: Sean C (Upp_and_Upp@hotmail.com)
Date: Tue Mar 22 2005 - 18:42:34 GMT-3


Learn something new everyday. Not that it's not acceptable to place a
'priority 0' and 'neighbor' command on the same router (already understand
that), but that the router won't accept the neighbor command when 'priority
0' is already configured. Learn something new....

Also, just to see if I got this, the router will allow both a 'priority' and
a 'neighbor' command if the priority is greater than 0, looks like the
router just won't accept the neighbor command if the command is strictly
'priority 0'.
R4#sh run <amended>
interface FastEthernet0/0
 ip address 14.14.14.4 255.255.255.0
 ip ospf network non-broadcast
 ip ospf priority 100
!
router ospf 1
  network 14.14.14.0 0.0.0.255 area 0
  neighbor 14.14.14.1

R4#conf t
R4(config)#int f0/0
R4(config-if)#ip osp pri
R4(config-if)#ip osp priority 0
R4(config-if)#end
R4#sh run <amended>
interface FastEthernet0/0
 ip address 14.14.14.4 255.255.255.0
 ip ospf network non-broadcast
 ip ospf priority 0
!
router ospf 1
 network 14.14.14.0 0.0.0.255 area 0
!
ip classless

R4#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R4(config)#int f0/0
R4(config-if)#ip osp prio 55
R4(config-if)#end
R4#sh run <amended>
interface FastEthernet0/0
 ip address 14.14.14.4 255.255.255.0
 ip ospf network non-broadcast
 ip ospf priority 55
 !
router ospf 1
 network 14.14.14.0 0.0.0.255 area 0
 neighbor 14.14.14.1

Thanks, Sean
----- Original Message -----
From: "Brian Dennis" <bdennis@internetworkexpert.com>
To: "Matt White" <mwhite23@gmail.com>
Cc: <ccielab@groupstudy.com>
Sent: Tuesday, March 22, 2005 4:07 PM
Subject: RE: OSPF NETWORK TYPE

> The IOS will not allow you to put both commands in.
>
> Router#wr t
> <snip>
> !
> interface Serial0/0
> ip address 1.1.1.1 255.255.255.0
> encapsulation frame-relay
> ip ospf priority 0
> !
> router ospf 1
> router-id 1.1.1.1
> log-adjacency-changes
> network 0.0.0.0 255.255.255.255 area 0
> !
> <snip>
> Router#conf t
> Enter configuration commands, one per line. End with CNTL/Z.
> Router(config)#router ospf 1
> Router(config-router)#neighbor 1.1.1.2
> Router(config-router)#do term len 5
> Router(config-router)#do sho run | be router ospf
> router ospf 1
> router-id 1.1.1.1
> log-adjacency-changes
> network 0.0.0.0 255.255.255.255 area 0
> !
> Router(config-router)#int s0/0
> Router(config-if)#no ip os pri 0
> Router(config)#router ospf 1
> Router(config-router)#neighbor 1.1.1.2
> Router(config-router)#do sho run | be router ospf
> router ospf 1
> router-id 1.1.1.1
> log-adjacency-changes
> network 0.0.0.0 255.255.255.255 area 0
> neighbor 1.1.1.2
>
>
> Let me ask you this, in what situation would you need both commands
> applied?
>
> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> bdennis@internetworkexpert.com
>
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987
> Direct: 775-745-6404 (Outside the US and Canada)
>
> -----Original Message-----
> From: Matt White [mailto:mwhite23@gmail.com]
> Sent: Tuesday, March 22, 2005 12:54 PM
> To: Brian Dennis
> Cc: Kunle Ayodele; ccielab@groupstudy.com; generalccie@yahoo.com
> Subject: Re: OSPF NETWORK TYPE
>
> Brian, in regard to the following, why not?
>
> "you can not put the OSPF 'neighbor'
> command on the spokes if they also have the "ip ospf priority" command
> applied to the interface."
>
>
>
> On Tue, 22 Mar 2005 01:55:42 -0500, Brian Dennis
> <bdennis@internetworkexpert.com> wrote:
>> You do not need the OSPF "neighbor" command on the spokes. It is only
>> need on the hub. As a side note, you can not put the OSPF "neighbor"
>> command on the spokes if they also have the "ip ospf priority" command
>> applied to the interface.
>>
>> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
>> bdennis@internetworkexpert.com
>>
>> Internetwork Expert, Inc.
>> http://www.InternetworkExpert.com
>> Toll Free: 877-224-8987
>> Direct: 775-745-6404 (Outside the US and Canada)
>>
>> -----Original Message-----
>> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of
>> Kunle Ayodele
>> Sent: Monday, March 21, 2005 10:35 PM
>> To: ccielab@groupstudy.com
>> Cc: generalccie@yahoo.com
>> Subject: OSPF NETWORK TYPE
>>
>> Hi Micheal,
>> Looking thru ur configs,for a NON-BROADCAST OSPF
>> network type, who would also need a neigbour command
>> on the spoke..U could also remove the ip
>> split-horizon(though not needed cos ospf is a link
>> protocol- but it sure keeps ur config clean and easy
>> to troobleshoot..
>> Regards
>> Kunle
>> --- Michael Wong <generalccie@yahoo.com> wrote:
>> > Hi,
>> >
>> > I have a hub-spoke frame relay cloud, the hub (R6)
>> > is multipoint subinterface, spokes (R7, R8) are
>> > physical interface. The OSPF network type is
>> > Non-broadcast. I have put neigh statements on hub
>> > router R6, and put ip ospf priority 0 on each spoke
>> > router frame interface. But R6 still can not form
>> > neighbor relationship with R8. Am I missing some
>> > config here?
>> >
>> > R6#wr t
>> > interface Serial0
>> > no ip address
>> > encapsulation frame-relay
>> >
>> > interface Serial0.3 multipoint
>> > ip address 167.78.86.1 255.255.255.248
>> > frame-relay map ip 167.78.86.2 608 broadcast
>> > frame-relay map ip 167.78.86.3 607 broadcast
>> >
>> > router ospf 1
>> > router-id 6.6.6.6
>> > log-adjacency-changes
>> > network 142.52.0.0 0.0.0.255 area 1
>> > network 167.78.86.0 0.0.0.7 area 0
>> > neighbor 167.78.86.3
>> > neighbor 167.78.86.2
>> >
>> > R6#sho ip ospf ne
>> > Neighbor ID Pri State Dead Time
>> > Address Interface
>> > 7.7.7.7 0 FULL/DROTHER 00:01:41
>> > 167.78.86.3 Serial0.3
>> > N/A 0 ATTEMPT/DROTHER -
>> > 167.78.86.2 Serial0.3
>> >
>> > R8#wr t
>> > interface Serial0/0
>> > ip address 167.78.86.2 255.255.255.248
>> > encapsulation frame-relay
>> > ip split-horizon
>> > ip ospf priority 0
>> > frame-relay map ip 167.78.86.1 806 broadcast
>> > frame-relay map ip 167.78.86.3 806 broadcast
>> >
>> > router ospf 1
>> > router-id 8.8.8.8
>> > log-adjacency-changes
>> > network 167.78.86.0 0.0.0.7 area 0
>> >
>> > R8#sho ip ospf ne
>> > Neighbor ID Pri State Dead Time
>> > Address Interface
>> > 6.6.6.6 1 INIT/DROTHER 00:01:04
>> > 167.78.86.1 Serial0/0
>> >
>> > R7#wr t
>> > interface Serial0/0
>> > ip address 167.78.86.3 255.255.255.248
>> > encapsulation frame-relay
>> > ip split-horizon
>> > ip ospf priority 0
>> > frame-relay map ip 167.78.86.1 706 broadcast
>> > frame-relay map ip 167.78.86.2 706 broadcast
>> > !
>> > router ospf 1
>> > router-id 7.7.7.7
>> > log-adjacency-changes
>> > network 167.78.86.0 0.0.0.7 area 0
>> >
>> > R7#sho ip osp ne
>> > Neighbor ID Pri State Dead Time
>> > Address Interface
>> > 6.6.6.6 1 FULL/DR 00:01:34
>> > 167.78.86.1 Serial0/0
>> >
>> >
>> >
>> > ---------------------------------
>> > Do you Yahoo!?
>> > Yahoo! Small Business - Try our new resources site!
>> >
>> >
>> >
>>
> _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>> >
>>
>> __________________________________
>> Do you Yahoo!?
>> Yahoo! Small Business - Try our new resources site!
>> http://smallbusiness.yahoo.com/resources/
>>
>>
> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>>
>>
> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sun Apr 03 2005 - 17:56:50 GMT-3