From: Bob Sinclair (bsinclair@netmasterclass.net)
Date: Mon Mar 21 2005 - 19:01:18 GMT-3
Hi Ananth,
Be glad to help if I can. First, though, let me point you to a link you might
find helpful:
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t
/122t13/frqosmqc.htm
To apply policies to individual DLCIs you must use a map-class frame-relay.
In that map-class frame-relay, you can apply a policy-map with the
service-policy command. That policy-map can shape the class-default, or it
can do set or police actions. If you want to do queueing on an individual PVC
(bandwidth or priority commands) then you must apply the queueing policy
hierarchically within a shaping policy. That may not sound simple! Here are
a few examples:
If you want to do MQC-based shaping on individual DLCIs, you can first create
a shaping policy that shapes the class-default.
policy-map SHAPE
class class-default
shape average 64000
You then create a map-class frame-relay that includes the policy-map:
map-class frame-relay MAPCLASS
service-policy output SHAPE
Then, apply the map-class frame-relay to the DLCI:
int s0/0
frame-relay interface-dlci 102
class MAPCLASS
This will shape all the traffic on that DLCI, but does not affect other PVCs
on the interface. In this case you do not issue the command "frame-relay
traffic-shaping" anywhere.
To verify, issue the command: show policy-map interface.
If you just want to do a set or police action, then change the policy-map
SHAPE, above. It is applied to the DLCI the same way, using the map-class
frame-relay MAPCLASS. If you shape on a PVC, you must shape class-default.
However if you want to set or police, you can apply the commands to any class.
PVCs do not have queues unless you create one through shaping. So if you want
to do queueing on a PVC with the MQC commands, you must first create a shaping
queue for class-default, and then apply the queueing to the shaped class.
Using the example above, we could define a class GOLD and a class SILVER, and
reserve bandwidth for each:
Policy-map QUEUE
class GOLD
priority percent 20
class SILVER
bandwidth percent 20
We then apply this policy-map within the SHAPE policy-map created above:
policy-map SHAPE
class class-default
shape average 64000
service policy QUEUE
Just as above, policy-map SHAPE, is applied within map-class frame-relay
MAPCLASS
Note that the bandwidth percent in the QUEUE policy relates to the SHAPE
bandwidth, 64000.
HTH,
Bob Sinclair
CCIE #10427, CCSI 30427, CISSP
www.netmasterclass.net
----- Original Message -----
From: anantha S
To: Bob Sinclair
Sent: Monday, March 21, 2005 3:55 PM
Subject: Re: Service Police under DLCI
Bob,
If possible, can you provide any basic examples on Shapping & Queueing
on FR links with MQC as well. or pointers
Thanks
Ananth
On Mon, 21 Mar 2005 14:19:31 -0500, Bob Sinclair
<bsinclair@netmasterclass.net> wrote:
> Gladston,
>
> Your result appears to be a limitation of the platform/IOS version. Your
> config works for me on a 3620, as shown below. You can do SET and POLICE
> commands in a policy-map applied to a PVC via a map-class frame-relay. If
you
> want to do MQC-based shaping on a PVC, you must shape class class-default.
If
> you want to do queueing on a PVC using the MQC, then the queueing
parameters
> must be in a CHILD policy to a Shaped PARENT policy.
>
> R1(config)#class-map match-all Class-de
> R1(config-cmap)# match any
> R1(config-cmap)#!
> R1(config-cmap)# policy-map Set-de
> R1(config-pmap)# class Class-de
> R1(config-pmap-c)# police cir 8000 bc 1000 be 1000
> R1(config-pmap-c-police)# conform-action set-frde-transmit
> R1(config-pmap-c-police)# exceed-action set-frde-transmit
> R1(config-pmap-c-police)# violate-action set-frde-transmit
> R1(config-pmap-c-police)#exit
> R1(config-pmap-c)#
> R1(config)#map-class frame-relay Setde
> R1(config-map-class)#service-policy output Set-de
> R1(config-map-class)#int s1/0.1
> R1(config-subif)#frame interface-dlci 212
> R1(config-fr-dlci)#class Setde
> R1(config-fr-dlci)#end
> R1#
> R1#sh policy-map int
> Serial1/0.1: DLCI 212 -
>
> Service-policy output: Set-de
>
> Class-map: Class-de (match-all)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
> police:
> cir 8000 bps, bc 1000 bytes, be 1000 bytes
> conformed 0 packets, 0 bytes; actions:
> set-frde-transmit
> exceeded 0 packets, 0 bytes; actions:
> set-frde-transmit
> violated 0 packets, 0 bytes; actions:
> set-frde-transmit
> conformed 0 bps, exceed 0 bps, violate 0 bps
>
> Class-map: class-default (match-any)
> 0 packets, 0 bytes
> 5 minute offered rate 0 bps, drop rate 0 bps
> Match: any
> R1#
>
> HTH,
>
> Bob Sinclair
> CCIE #10427, CCSI 30427, CISSP
> www.netmasterclass.net
>
> ----- Original Message -----
> From: gladston@br.ibm.com
> To: ccielab@groupstudy.com
> Sent: Monday, March 21, 2005 7:58 AM
> Subject: Service Police under DLCI
>
> Suppose there is a requirement to configure a service police under a
DLCI
> (the action is secondary, could be for example set DE bit of all packets.
> Would it be necessary to use "frame-relay traffic-shaping" under the
main
> interface".
> I am asking because I tried it without "frame-relay traffic-shaping" but
the
> 2500 (IOS 12.2T) does not take the command 'service policy' under the
class.
> It does not complain but show run shows the command is not there:
>
> r3(config-map-class)#service-policy output Set-de
> r3(config-map-class)#
>
> r3# sh run
>
> class-map match-all Class-de
> match any
> !
> !
> policy-map Set-de
> class Class-de
> police cir 8000 bc 1000 be 1000
> conform-action set-frde-transmit
> exceed-action set-frde-transmit
> violate-action set-frde-transmit
> !
> interface Serial0
> no ip address
> encapsulation frame-relay
> !
> interface Serial0.123 multipoint
> ip address 172.16.123.3 255.255.255.0
> frame-relay map ip 172.16.123.1 301 broadcast
> frame-relay map ip 172.16.123.2 302 broadcast
> frame-relay interface-dlci 301
> class Setde
> !
> map-class frame-relay Setde
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sun Apr 03 2005 - 17:56:49 GMT-3