Redistributing OSPF into ISIS

From: Wayne Bellward (wbellward@gmail.com)
Date: Tue Mar 15 2005 - 13:52:58 GMT-3


Hi,

I trawled through the archives for hours and nothing seems to fit my
scenario exactly.

I have a frame network and want to mutally redistribute OSPF and ISIS,
I can redistribute ISIS into OSPF ok but not the other way around. I
have four routers as illustrated below.

           ________________R5
          /
        /
      /
R14___________________R3
                  \
                   \
                     \__________R1

R14 - R5 is point to point sub-interface (ISIS).
R14 - R3 & R1 is multi-point (OSPF).

The constraints of the lab specify that R14 - R5 ISIS must be type 1
and that OSPF must be redistributed in as type 2, all redistributed to
be performed on R14.

my configs are as follows any insights into what's going wrong would
be welcome I'm sure it's something simple but wood for the trees as
they say.

version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R14-
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 15.15.14.14 255.255.255.0
 ip router isis
!
interface Ethernet0
 ip address 10.1.5.4 255.255.255.248
 ip ospf priority 255
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
!
interface Serial0.1 point-to-point
 ip address 10.1.12.193 255.255.255.240
 ip router isis
 frame-relay interface-dlci 105
!
interface Serial0.2 multipoint
 ip address 10.1.11.14 255.255.255.0
 ip ospf network broadcast
 ip ospf priority 255
 frame-relay map ip 10.1.11.1 102 broadcast
 frame-relay map ip 10.1.11.3 103 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 100
 router-id 15.15.14.14
 log-adjacency-changes
 redistribute connected subnets
 redistribute isis level-1 subnets
 network 10.1.5.0 0.0.0.7 area 10
 network 10.1.11.0 0.0.0.255 area 0
 default-metric 10
!
router isis
 net 00.0001.0000.0c38.79ff.00
 redistribute ospf 100 metric 20 metric-type external
 is-type level-1
!
ip classless
ip http server
!
!
ip access-list standard Lo0-redistribute
 permit 15.15.14.14
route-map Lo0-into-ospf permit 10
 match ip address Lo0-redistribute
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
-----------------------------------------------------------------

version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname R5-
!
!
no ip domain-lookup
clns routing
isdn switch-type basic-net3
!
interface Loopback0
 ip address 15.15.5.5 255.255.255.0
 ip router isis
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
!
interface Serial0.1 point-to-point
 ip address 10.1.12.194 255.255.255.240
 ip router isis
 frame-relay interface-dlci 501
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 10.1.35.5 255.255.255.252
 shutdown
!
router isis
 net 00.0001.00d0.58ad.40cb.00
 is-type level-1
!
ip classless
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
---------------------------------------------------------------------
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3-
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 15.15.3.3 255.255.255.0
!
interface Serial0
 ip address 10.1.11.3 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 no fair-queue
 frame-relay map ip 10.1.11.14 301 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
!
router ospf 100
 router-id 15.15.3.3
 log-adjacency-changes
 network 10.1.11.0 0.0.0.255 area 0
!
ip classless
ip http server
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
----------------------------------------------------------------
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1-
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 15.15.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 ip address 10.1.11.1 255.255.255.0
 encapsulation frame-relay
 ip ospf network broadcast
 ip ospf priority 0
 frame-relay map ip 10.1.11.14 201 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 ip address 200.200.200.1 255.255.255.0
 clockrate 2000000
!
router ospf 100
 router-id 15.15.1.1
 log-adjacency-changes
 network 10.1.11.0 0.0.0.255 area 0
 network 15.15.1.0 0.0.0.255 area 0
 network 200.200.200.0 0.0.0.255 area 20
!
ip classless
ip http server
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 login
!
end
-----------------------------------------------------------------------
Many Thanks

Wayne



This archive was generated by hypermail 2.1.4 : Sun Apr 03 2005 - 17:56:45 GMT-3