From: simon hart (simon.hart@btinternet.com)
Date: Tue Mar 08 2005 - 17:02:24 GMT-3
Matt,
Yes you are right that there would be a problem with the K values, however
this would have been apparent once the neighbor relationship is attempted
(effectively one would get an error message on the console). This is in
actuality what I was trying to test. The AS number was the real issue - I
think I must be getting tired :(
Simon
-----Original Message-----
From: Matt Mullen [mailto:mullenm@gmail.com]
Sent: 08 March 2005 19:59
To: simon hart
Cc: Group Study
Subject: Re: EIGRP problem
I totally missed the eigrp 10 vs 100 problem, but won't there also be
a problem with a K-Value mismatch because of the metric weights
command on R6? This URL would seem to confirm it:
http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuratio
n_guide_chapter09186a00800ca762.html
On Tue, 8 Mar 2005 19:17:56 -0000, simon hart <simon.hart@btinternet.com>
wrote:
> Brian,
>
> Here are the configs
>
> version 12.2
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname terminal_bb1
> !
> enable password CISCO
> !
> username ROUTER6 password 0 CISCO
> ip subnet-zero
> ip tcp intercept list TCP
> ip tcp intercept max-incomplete low 500
> ip tcp intercept max-incomplete high 1000
> ip tcp intercept mode watch
> no ip domain-lookup
> ip host R4 2004 1.1.1.1
> ip host R5 2005 1.1.1.1
> ip host r2 2007 1.1.1.1
> ip host r6 2006 1.1.1.1
> ip host bb1 2007 1.1.1.1
> ip host R1 2001 1.1.1.1
> ip host r3 2003 1.1.1.1
> ip host cat 2002 1.1.1.1
> ip host BB3 2008 1.1.1.1
> !
> ip accounting-threshold 50000
> !
> key chain EIGRP
> key 1
> key-string CISCO
> !
> !Loads of Loopbacks - cut out from the config
> !
> interface Serial0
> ip address 54.1.1.254 255.255.255.0
> clock rate 64000
> !
> interface Serial1
> description HDLC link to BB3 for BGP Peering
> ip address 172.16.4.1 255.255.255.0
> clock rate 64000
> !
> router eigrp 100
> network 54.1.1.254 0.0.0.0
> network 54.1.4.254 0.0.0.0
> no auto-summary
> no eigrp log-neighbor-changes
> !
> router ospf 100
> log-adjacency-changes
> network 132.1.0.2 0.0.0.0 area 0
> !
> router rip
> version 2
> network 192.168.0.0
> network 212.18.0.0
> network 212.18.1.0
> network 212.18.2.0
> network 212.18.3.0
> no auto-summary
> !
> router bgp 54
> no synchronization
> bgp log-neighbor-changes
> network 112.0.0.0
> network 113.0.0.0
> network 114.0.0.0 route-map SET_COMMUNITY_54
> network 115.0.0.0 route-map SET_COMMUNITY_54
> network 116.0.0.0
> network 117.0.0.0
> network 118.0.0.0
> network 119.0.0.0
> neighbor RACKS peer-group
> neighbor RACKS remote-as 100
> neighbor RACKS send-community
> neighbor RACKS default-originate
> neighbor RACKS route-map BGP_OUT out
> neighbor 54.1.1.6 peer-group RACKS
> neighbor 54.1.2.6 peer-group RACKS
> neighbor 54.1.3.6 peer-group RACKS
> neighbor 54.1.4.6 peer-group RACKS
> neighbor 54.1.5.6 peer-group RACKS
> neighbor 54.1.6.6 peer-group RACKS
> neighbor 54.1.7.6 peer-group RACKS
> neighbor 54.1.8.6 peer-group RACKS
> neighbor 172.16.4.3 remote-as 54
> neighbor 172.16.4.3 next-hop-self
> neighbor 172.16.4.3 send-community
> no auto-summary
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 192.168.0.1
> ip route 204.12.1.0 255.255.255.0 172.16.4.3
> ip http server
> ip as-path access-list 1 permit ^$
> ip pim bidir-enable
> !
> !
> ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8
> ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8
> !
> ip access-list standard EIGRP
> permit 200.0.0.0 0.0.3.255
> ip access-list standard RIP
> permit 212.18.0.0 0.0.3.0
> !
> ip access-list extended TCP
> permit tcp any host 167.1.4.119 eq www
> route-map SET_COMMUNITY_54 permit 10
> set community 54
> !
> route-map BGP_OUT permit 10
> match ip address prefix-list BGP_PREPEND_1
> set as-path prepend 50 60
> !
> route-map BGP_OUT permit 10000
> match as-path 1
> !
> line con 0
> exec-timeout 0 0
> line 1 8
> no exec
> transport input all
> line aux 0
> modem InOut
> transport input all
> speed 38400
> line vty 0 4
> password CISCO
> login
> !
> ntp authentication-key 1 md5 02252D682829 7
> ntp master 4
> end
>
> And for the other router...........................
>
> version 12.2
> service timestamps debug datetime msec
> service timestamps log datetime msec
> no service password-encryption
> !
> hostname Rack1R6
> !
> logging queue-limit 100
> enable password cisco
> !
> ip subnet-zero
> !
> !
> no ip domain lookup
>
> no voice hpi capture buffer
> no voice hpi capture destination
> !
> !
> mta receive maximum-recipients 0
> !
> !
> interface Loopback0
> ip address 150.1.6.6 255.255.255.0
> !
> interface Ethernet0/0
> ip address 156.1.67.6 255.255.255.0
> half-duplex
> !
> interface Ethernet0/0.52
> !
> interface Serial0/0
> ip address 54.1.1.6 255.255.255.0
> !
> interface BRI0/0
> no ip address
> shutdown
> !
> interface Dialer1
> no ip address
> !
> router eigrp 10
> network 54.1.1.6 0.0.0.0
> network 54.1.4.6 0.0.0.0
> network 156.1.6.6 0.0.0.0
> network 156.1.67.6 0.0.0.0
> metric weights 0 3 1 1 1 1
> no auto-summary
> !
> ip http server
> ip classless
> !
> !
> call rsvp-sync
> !
> voice-port 1/0/0
> !
> voice-port 1/0/1
> !
> mgcp profile default
> !
> dial-peer cor custom
> !
> line con 0
> exec-timeout 0 0
> privilege level 15
> logging synchronous
> line aux 0
> exec-timeout 0 0
> privilege level 15
> line vty 0 4
> password cisco
> login
> !
> !
> end
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Brian
> McGahan
> Sent: 08 March 2005 19:06
> To: simon hart; Group Study
> Subject: RE: EIGRP problem
>
> Simon,
>
> Paste your full config for both of these devices.
>
> Brian McGahan, CCIE #8593
> bmcgahan@internetworkexpert.com
>
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987 x 705
> Outside US: 775-826-4344 x 705
> 24/7 Support: http://forum.internetworkexpert.com
> Live Chat: http://www.internetworkexpert.com/chat/
>
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of
> > simon hart
> > Sent: Tuesday, March 08, 2005 12:38 PM
> > To: Group Study
> > Subject: EIGRP problem
> >
> > Hi,
> >
> > I have a peculiar problem that I cannot seem to get to the bottom of.
> >
> > Two routers connected via a serial cable using HDLC
> >
> > R1---------------------R2
> >
> > R1 S0 ip address 54.1.1.6
> >
> > R2 S0 ip address 54.1.1.254
> >
> >
> >
> > EIGRP has been configured on both interfaces, however the two routers
> do
> > not
> > become neighbors.
> >
> > I have looked at debug ip packet from router 2 and it is sending eigrp
> > packets and recieving eigpr packets from router 1. Similar results
> are
> > seen
> > on router 1.
> >
> > s=54.1.1.254 (local), d=224.0.0.10 (Serial0), len 60, sending
> > broad/multicast
> > 00:20:58: IP: s=54.1.1.6 (Serial0), d=224.0.0.10, len 60, rcvd 2
> > 00:21:02: IP: s=54.1.1.254 (local), d=224.0.0.10 (Serial0), len 60,
> > sending
> > broad/multicast
> > 00:21:03: IP: s=54.1.1.6 (Serial0), d=224.0.0.10, len 60, rcvd
> 2undebug
> > all
> >
> > However if I debug eigrp packets I do not see that I am recieving any
> > packets, only that I am sending them (again similar results seen on
> router
> > 1)
> >
> > 0:19:57: EIGRP: Sending HELLO on Serial0
> > 00:19:57: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
> > 00:20:01: EIGRP: Sending HELLO on Serial0
> > 00:20:01: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
> > 00:20:06: EIGRP: Sending HELLO on Serial0
> > 00:20:06: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
> > 00:20:10: EIGRP: Sending HELLO on Serial0
> > 00:20:10: AS 100, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
> > 00:20:15: EIGRP: Sending HELLO on Serial0
> >
> > If I look at eigrp traffic this confirmed
> >
> > Hellos sent/received: 497/0
> > Updates sent/received: 0/0
> > Queries sent/received: 0/0
> > Replies sent/received: 0/0
> > Acks sent/received: 0/0
> > Input queue high water mark 0, 0 drops
> > SIA-Queries sent/received: 0/0
> > SIA-Replies sent/received: 0/0
> >
> > Any suggestions on why this should be the case??
> >
> > Thanks
> >
> > Simon
> >
> >
> >
> > --
> > No virus found in this outgoing message.
> > Checked by AVG Anti-Virus.
> > Version: 7.0.308 / Virus Database: 266.6.4 - Release Date: 07/03/2005
> >
> >
> _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
> --
> No virus found in this incoming message.
> Checked by AVG Anti-Virus.
> Version: 7.0.308 / Virus Database: 266.6.4 - Release Date: 07/03/2005
>
> --
> No virus found in this outgoing message.
> Checked by AVG Anti-Virus.
> Version: 7.0.308 / Virus Database: 266.6.4 - Release Date: 07/03/2005
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
-- No virus found in this incoming message. Checked by AVG Anti-Virus. Version: 7.0.308 / Virus Database: 266.6.4 - Release Date: 07/03/2005-- No virus found in this outgoing message. Checked by AVG Anti-Virus. Version: 7.0.308 / Virus Database: 266.6.4 - Release Date: 07/03/2005
This archive was generated by hypermail 2.1.4 : Sun Apr 03 2005 - 17:56:43 GMT-3