Re: routing problem

From: Ed Lui (edwlui@gmail.com)
Date: Tue Feb 15 2005 - 00:40:06 GMT-3


Finally, I got it up and running without knowing why it wasn't
working. I must have done something wrong. Anyway, check them out and
DO comment....:-)

net100----net10 net10-net20 net20-net30
e0/.1 s1/.1 s2/.2 s3/.1 s1/.2 e0/.1
(LAN)RouterA---------RouterB--------RouterC--(LAN)

======================================================
RouterA#sh ip ro

     100.0.0.0/24 is subnetted, 1 subnets
C 100.100.100.0 is directly connected, Ethernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX 20.20.20.0 [170/3072256] via 10.10.10.2, 00:16:52, Serial1
     10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial1
     30.0.0.0/24 is subnetted, 1 subnets
D EX 30.30.30.0 [170/3072256] via 10.10.10.2, 00:13:35, Serial1

version 12.2
!
hostname RouterA
!
interface Ethernet0
 description LAN interface
 ip address 100.100.100.1 255.255.255.0
 no keepalive
!
interface Serial1
 description 2 RouterB
 ip address 10.10.10.1 255.255.255.0
!
router eigrp 1
 network 10.10.10.0 0.0.0.255
 network 100.100.100.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
end

======================================================
RouterB#sh ip ro

     100.0.0.0/24 is subnetted, 1 subnets
D 100.100.100.0 [90/22798336] via 10.10.10.1, 00:26:07, Serial2
     20.0.0.0/24 is subnetted, 1 subnets
C 20.20.20.0 is directly connected, Serial3
     10.0.0.0/24 is subnetted, 1 subnets
C 10.10.10.0 is directly connected, Serial2
     30.0.0.0/24 is subnetted, 1 subnets
B 30.30.30.0 [200/0] via 20.20.20.2, 00:19:14

version 12.2
!
hostname RouterB
!
ip subnet-zero
no ip finger
!
interface Serial2
 description 2 RouterA
 ip address 10.10.10.2 255.255.255.0
 clockrate 64000
!
interface Serial3
 description 2 RouterC
 ip address 20.20.20.1 255.255.255.0
 clockrate 64000
!
router eigrp 1
 redistribute bgp 1 metric 1000 1 255 1 1500
 network 10.10.10.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
router bgp 1
 no synchronization
 bgp redistribute-internal
 bgp log-neighbor-changes
 network 20.20.20.0 mask 255.255.255.0
 redistribute eigrp 1
 neighbor 20.20.20.2 remote-as 1
!
end
======================================================
RouterC#sh ip ro

B 100.0.0.0/8 [200/0] via 20.20.20.1, 00:21:42
     20.0.0.0/24 is subnetted, 1 subnets
C 20.20.20.0 is directly connected, Serial1
B 10.0.0.0/8 [200/0] via 20.20.20.1, 00:21:42
     30.0.0.0/24 is subnetted, 1 subnets
C 30.30.30.0 is directly connected, Ethernet0

hostname RouterC
!
Ethernet0
 description RouterC-LAN
 ip address 30.30.30.1 255.255.255.0
 no keepalive
!
interface Serial1
 description 2 RouterB
 ip address 20.20.20.2 255.255.255.0
!
router bgp 1
 no synchronization
 bgp redistribute-internal
 bgp log-neighbor-changes
 network 20.20.20.0 mask 255.255.255.0
 network 30.30.30.0 mask 255.255.255.0
 neighbor 20.20.20.1 remote-as 1
!
end

-- 
Edward 
(A+, Net+, MCP, MCP+I, MCSE, CCNA, CCNP)


This archive was generated by hypermail 2.1.4 : Thu Mar 03 2005 - 08:51:20 GMT-3