RE: IGRP=default-network EIGRP=?

From: Brian McGahan (bmcgahan@internetworkexpert.com)
Date: Fri Jan 14 2005 - 18:14:59 GMT-3


Mark,

        What you are seeing is the usage of the standalone command
"default", whish is used to reset an option to it's default
configuration:

R1(config)#do sh run int e0/0
Building configuration...

Current configuration : 110 bytes
!
interface Ethernet0/0
 ip address 10.0.0.1 255.0.0.0
 ip access-group 1 in
 ip nat inside
 half-duplex
end

R1(config)#default interface ethernet0/0
Building configuration...

Interface Ethernet0/0 set to default configuration
R1(config)#do sh run int e0/0
Building configuration...

Current configuration : 57 bytes
!
interface Ethernet0/0
 no ip address
 half-duplex
end

R1(config)#router rip
R1(config-router)#network 10.0.0.0
R1(config-router)#do sh run | b router rip
router rip
 network 10.0.0.0
!
<snip>

R1(config-router)#default network 10.0.0.0
R1(config-router)#do sh run | b router rip
router rip
!
<snip>

        It's similar to the "no" command, but has additional
functionality like the "default interface" option.

HTH,

Brian McGahan, CCIE #8593
bmcgahan@internetworkexpert.com

Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987 x 705
Outside US: 775-826-4344 x 705
24/7 Support: http://forum.internetworkexpert.com
Live Chat: http://www.internetworkexpert.com/chat/

> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
Of
> Mark Lasarko
> Sent: Friday, January 14, 2005 1:56 PM
> To: ccielab@groupstudy.com; bdennis@internetworkexpert.com
> Subject: RE: IGRP=default-network EIGRP=?
>
> Thank You Brian,
>
> I do get the classful thing...
> I made note of that in my example, as a response to validate the
> default-network command for jellyboy.
> (And maybe learn something from Robert M.)
>
> My bad, I was trying to clarify one thing and questioned another at
the
> same time.
> I certainly could have been more clear :)
> Fortunately, there's always room for improvement!
>
> My question here is in regards to phantom commands that don't seem to
> do much, if anything.
> Like "default network" (no dash), within the routing process itself.
> I've been stumbling over a few of these lately that either don't do
> what they are supposed to or do nothing at all.
> That's what I mean when I say I am confused.
>
> You may have just confirmed another?
> "There isn't a "default-information originate" command for EIGRP. "
> Yet another one where the command is there, and will be accepted, but
> does nothing.
>
> I see this now @
>
http://www.cisco.com/univercd/cc/td/doc/product/software/ios123/123cgcr/
ip
> rrp_r/ip2_c1g.htm
>
> I keep thinking there should be some addendum, a master list of stuff
> that does not work
> Sometimes I forget that in the Cisco world it (usually) "depends" :)
>
> Thanx again for the clarification.
> Have a great day,
> ~M
>
>
>
>
> >>> "Brian Dennis" <bdennis@internetworkexpert.com> 1/14/2005 2:38:40
> PM >>>
>
> Mark,
> Mark,
> The default-network should be a classful network. See below:
>
> Rack2R1#sho ip route eigrp
> D 172.16.0.0/16 [90/409600] via 10.1.1.2, 00:01:28, Ethernet0/0
> 150.2.0.0/32 is subnetted, 1 subnets
> D 150.2.2.2 [90/409600] via 10.1.1.2, 00:01:31, Ethernet0/0
> Rack2R1#sho run | in ip route <-- Notice: no static routes
> Rack2R1#conf t
> Enter configuration commands, one per line. End with CNTL/Z.
> Rack2R1(config)#ip default-network 150.2.2.2 <-- Not classful
> Rack2R1(config)#do sho run | in (default-network|ip route)
> ip route 150.2.0.0 255.255.0.0 150.2.2.2
> Rack2R1(config)#ip default-network 172.16.0.0 <-- Classful
> Rack2R1(config)#do sho run | in (default-network|ip route)
> ip default-network 172.16.0.0
> ip route 150.2.0.0 255.255.0.0 150.2.2.2
> Rack2R1(config)#do sho ip route eigrp
> D* 172.16.0.0/16 [90/409600] via 10.1.1.2, 00:03:58, Ethernet0/0
> 150.2.0.0/16 is variably subnetted, 2 subnets, 2 masks
> D 150.2.2.2/32 [90/409600] via 10.1.1.2, 00:04:01, Ethernet0/0
> Rack2R1(config)#
>
> Notice that a static route was put in my configuration when I used the
> default-network command for a non-classful network.
>
> HTH
>
> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> bdennis@internetworkexpert.com
>
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
> Toll Free: 877-224-8987
> Direct: 775-745-6404 (Outside the US and Canada)
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf
> Of
> Mark Lasarko
> Sent: Friday, January 14, 2005 9:21 AM
> To: jellyboy@gmail.com; ccielab@groupstudy.com;
> robert.mccallum@thus.net
> Subject: RE: IGRP=default-network EIGRP=?
>
> default-gateway?
>
> I thought this was only applicable when the router was not being a
> router??
>
> Anyway, I was a bit curious, as I remember that, at least on recent
> code,
> IOS will parse EIGRP code in interesting ways with options that do not
>
> seem to exist, for example:
>
> 3725#config t
> Enter configuration commands, one per line. End with CNTL/Z.
> 3725(config)#router eigrp 1
> 3725(config-router)#default ?
> address-family Enter Address Family command mode
> auto-summary Enable automatic network number summarization
> default-information Control distribution of default information
> default-metric Set metric of redistributed routes
> distance Define an administrative distance
> distribute-list Filter networks in routing updates
> eigrp EIGRP specific commands
> maximum-paths Forward packets over multiple paths
> metric Modify EIGRP routing metrics and parameters
> neighbor Specify a neighbor router
> network Enable routing on an IP network
> offset-list Add or subtract offset from RIP metrics
> passive-interface Suppress routing updates on an interface
> redistribute Redistribute information from another routing
> protocol
> timers Adjust routing timers
> traffic-share How to compute traffic share over alternate
> paths
> variance Control load balancing variance
>
> 3725(config-router)#default network ?
> A.B.C.D Network number
>
> 3725(config-router)#default network 100.100.100.0
> 3725(config-router)#end
>
> This does nothing, the router just accepts the command and forgets
> about it?
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> Now, on to the default-network...
> First, we see our EIGRP AS has two networks defined with no static
> routes.
>
> router eigrp 1
> network 1.1.1.0 0.0.0.255
> network 2.2.2.0 0.0.0.255
> no auto-summary
> !
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> Now we issue the command "ip default-network 100.100.100.0"
>
> 3725#config t
> Enter configuration commands, one per line. End with CNTL/Z.
> 3725(config)#ip default-network 100.100.100.0
> 3725(config)#end
> 3725#sh run
> !
> router eigrp 1
> network 1.1.1.0 0.0.0.255
> network 2.2.2.0 0.0.0.255
> no auto-summary
> !
> ip route 100.0.0.0 255.0.0.0 100.100.100.0
> !
>
> We see that the command inserted the line "ip route 100.0.0.0
> 255.0.0.0
> 100.100.100.0"
> A classful route was entered as a result of the command
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> Let's add a second default-network...
>
> 3725#
> 3725#config t
> Enter configuration commands, one per line. End with CNTL/Z.
> 3725(config)#ip default-network 172.172.172.0
> 3725(config)#end
> 3725#sh run
> !
> router eigrp 1
> network 1.1.1.0 0.0.0.255
> network 2.2.2.0 0.0.0.255
> no auto-summary
> !
> ip route 100.0.0.0 255.0.0.0 100.100.100.0
> ip route 172.172.0.0 255.255.0.0 172.172.172.0
> !
>
> Again we see a classful static route installed for the network we
> defined.
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> Not trying to over-simplify, just understand more :) ?????
> Now I am more confused than when I started.
> Can anyone explain this better?
>
> I understand the installation of the classful networks,
> it's the anomalies I can't get past
> Commands that do nothing
> April fools?
>
> Not that it matters:
> 3725#sh ver
> Cisco Internetwork Operating System Software
> IOS (tm) 3700 Software (C3725-JK9S-M), Version 12.3(9b), RELEASE
> SOFTWARE (fc1)
>
> ~M
>
>
>
>
> >>> "McCallum, Robert" <robert.mccallum@thus.net> 1/14/2005 10:07:06
> AM
> >>>
>
> try default-gateway
>
> Robert McCallum
>
>
> > -----Original Message-----
> > From: jellyboy [mailto:jellyboy@gmail.com]
> > Sent: 14 January 2005 15:03
> > To: ccielab@groupstudy.com
> > Subject: IGRP=default-network EIGRP=?
> >
> >
> > Hi all, I was doing a lab which was running IGRP. My newer
> > routers do not have IGRP in the IOS (!), so I was using EIGRP
> > with auto-summary so simulate the classful properties of IGRP
> > if you get my drift. The original exercise was not to allow
> > an redistribution of static routes, but to allow a default
> > route to another IGRP neighbor. The original solution was to
> > use the default-network command which is automatically
> > redistributed into IGRP. With running EIGRP instead of IGRP
> > in my case the default-network does not seem to propogate a
> > default route to its EIGRP neighbor. Apart from using a
> > 0.0.0.0 and redistrubute static or redisributing a quad zero
> > into another routing protocol and then redistribute that with
> > EIGRP, does anyone know how to do the equivalent of the
> > default-network with IGRP in EIGRP?
> >
> > Cheers,
> >
> > jellyboy
> >
> > ______________________________________________________________
> > _________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
>



This archive was generated by hypermail 2.1.4 : Wed Feb 02 2005 - 22:10:23 GMT-3