Re: BGP peering using secondary IP addresses ?!...

From: Vytautas Valancius (valas@mail.lt)
Date: Thu Jan 13 2005 - 04:53:03 GMT-3


Hi!

I guess I am missing something in this discussion.
I found no problems connecting peer using secondary addresses. The same
applies for iBGP and eBGP - for eBGP you just need to add ebgp-multihop 2 to
at least one side.

Here are my results for iBGP:
R2:
interface Serial0/0.23 point-to-point
 ip address 10.0.123.2 255.255.255.0 secondary
 ip address 10.0.23.2 255.255.255.0
 frame-relay interface-dlci 203
end

router bgp 23
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.0.123.3 remote-as 23
 no auto-summary

R3:
interface Serial0/0.23 point-to-point
 ip address 10.0.123.3 255.255.255.0 secondary
 ip address 10.0.23.3 255.255.255.0
 frame-relay interface-dlci 302

router bgp 23
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.0.123.2 remote-as 23
 no auto-summary

R3#sh ip bgp nei
BGP neighbor is 10.0.123.2, remote AS 23, internal link
[skip]
Local host: 10.0.123.3, Local port: 179
Foreign host: 10.0.123.2, Foreign port: 52126

So what is the problem? Enlighten me.

Regards,
Vytautas Valancius

----- Original Message -----
From: <micsoniu@telus.net>
To: "Alexander Arsenyev (GU/ETL)" <alexander.arsenyev@ericsson.com>
Cc: "Group Study" <ccielab@groupstudy.com>
Sent: Thursday, January 13, 2005 9:38 PM
Subject: RE: BGP peering using secondary IP addresses ?!...

> Full wording:
>
> Router R1 will peer with R2 using the secondary IP addresses assigned to
> their
> directly connected interfaces. You are not allowed to add new IP subnets
> to
> the existing scenario.
>
> The presented scenario does not have any loopback interfaces configured on
> these two routers.
>
> Thank you
>
> Quoting "Alexander Arsenyev (GU/ETL)" <alexander.arsenyev@ericsson.com>:
>
>> Not sure what are You asking for this time...Full task wording , please?
>> The solution actually isn't adding any new IP addresses, it uses
>> secondary
>> which is part of the original task.
>> Cheers
>> Alex
>>
>> -----Original Message-----
>> From: micsoniu@telus.net [mailto:micsoniu@telus.net]
>> Sent: 13 January 2005 19:22
>> To: Radu Pavaloiu
>> Cc: Alexander Arsenyev (GU/ETL); Vazman@aol.com; Group Study
>> Subject: RE: BGP peering using secondary IP addresses ?!...
>>
>>
>> This is good solution. Thank you.
>>
>> Let's add to the drama: - you are not allowed to add any new IP addresses
>> to
>>
>> the network and there are no loopback interfaces pre-configured with IP
>> addresses ?!...
>>
>>
>>
>> Quoting Radu Pavaloiu <Radu.Pavaloiu@connex.ro>:
>>
>> > It's works:
>> >
>> > R1
>> >
>> > interface Loopback1
>> > ip address 1.1.1.1 255.255.255.255
>> > ip nat inside
>> > !
>> > interface FastEthernet0/0
>> > ip address 192.168.1.1 255.255.255.0 secondary
>> > ip address 10.0.0.1 255.255.255.0
>> > ip nat outside
>> > duplex auto
>> > speed auto
>> >
>> > router bgp 100
>> > no synchronization
>> > bgp log-neighbor-changes
>> > neighbor 192.168.1.2 remote-as 100
>> > no auto-summary
>> > !
>> > ip local policy route-map bgp
>> > ip nat inside source static 10.0.0.1 192.168.1.1 extendable
>> > ip http server
>> > ip classless
>> > !
>> > !
>> > !
>> > access-list 100 permit tcp any any eq bgp
>> > !
>> > route-map bgp permit 10
>> > match ip address 100
>> > set interface Loopback1
>> >
>> >
>> > R2
>> >
>> > interface FastEthernet0/0
>> > ip address 192.168.1.2 255.255.255.0 secondary
>> > ip address 10.0.0.2 255.255.255.0
>> > duplex auto
>> > speed auto
>> >
>> > router bgp 100
>> > no synchronization
>> > bgp log-neighbor-changes
>> > neighbor 192.168.1.1 remote-as 100
>> > no auto-summary
>> >
>> >
>> > R1#show ip bgp summary
>> > BGP router identifier 10.0.0.1, local AS number 100
>> > BGP table version is 1, main routing table version 1
>> >
>> > Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
>> > State/PfxRcd
>> > 192.168.1.2 4 100 19 19 1 0 0 00:03:54
>> > 0
>> >
>> > R2#show ip bgp summary
>> > BGP router identifier 2.2.2.2, local AS number 100
>> > BGP table version is 1, main routing table version 1
>> >
>> > Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down
>> > State/PfxRcd
>> > 192.168.1.1 4 100 23 23 1 0 0 00:07:33
>> > 0
>> >
>> > R1#show ip nat translations
>> > Pro Inside global Inside local Outside local Outside
>> > global
>> > --- 192.168.1.1 10.0.0.1 --- ---
>> > tcp 192.168.1.1:11011 10.0.0.1:11011 192.168.1.2:179
>> > 192.168.1.2:179
>> >
>> >
>> > Regards,
>> >
>> > I die. I fracture into thousands of fragments of flushed embarrassment.
>> > My body parts fly, connectionless, over a badly constructed spanning
>> > tree that isn't quite loop free.
>> > I fall screaming into 127.0.0.1.
>> >
>> >
>> > Radu
>> > #2658
>> >
>> > -----Original Message-----
>> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
>> > Alexander Arsenyev (GU/ETL)
>> > Sent: Thursday, January 13, 2005 8:00 PM
>> > To: 'Vazman@aol.com'; Group Study
>> > Subject: RE: BGP peering using secondary IP addresses ?!...
>> >
>> >
>> > Hello,
>> >
>> > My take on it:
>> > 1) PBR to loopback - "ip local policy route-map" and route-map should
>> > have match on BGP and "set interface LoXX"
>> > 2) "ip nat inside" on that loopback
>> > 3) "ip nat inside source static" to translate primary into secondary
>> > 4) "ip nat outside" on the outgoing interface
>> >
>> > Don't have a rack to test it at the moment :-]
>> >
>> > Anyone tell me why it shouldn't work?
>> >
>> > HTH,
>> > Cheers
>> > Alex
>> >
>> > -----Original Message-----
>> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]
>> > Sent: 13 January 2005 17:33
>> > To: micsoniu@telus.net; Group Study
>> > Subject: Re: BGP peering using secondary IP addresses ?!...
>> >
>> >
>> > By default, BGP will use the IP address of the outgoing interface as
>> > the
>> > source. The command "update-source" does not apply in this case as the
>> > interface is still the same. The only thing that I can think of is to
>> > use the BGP peering address as the primary address.
>> >
>> > Good scenario btw.
>> >
>> > _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>> >
>> > _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>> >
>> > _______________________________________________________________________
>> > Subscription information may be found at:
>> > http://www.groupstudy.com/list/CCIELab.html
>>
>> _______________________________________________________________________
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Wed Feb 02 2005 - 22:10:22 GMT-3