Re: INEv2 lab 3

From: Joseph D. Phillips (josephdphillips@fastmail.us)
Date: Tue Dec 14 2004 - 12:29:18 GMT-3


Actually, I finally solved the problem.

The configuration as listed in the solutions guide does not prevent route
feedback, which is what I was getting.

I resolved the route feedback problem and got the correct flow of traffic by
using the following configurations on the three routers doing the
redistribution.

(I cheated a bit on Router 6, which, on the rack I was using, offered me
several Ethernet interfaces, so I didn't have to use subs.)

I am sooooooooooooo jazzed. :-)

ROUTER SIX

router eigrp 100
 redistribute rip route-map r2e
 passive-interface default
 no passive-interface Ethernet2/0
 network 136.1.136.6 0.0.0.0
 network 150.1.6.6 0.0.0.0
 default-metric 1500 1 255 1 1500
 no auto-summary
 eigrp router-id 150.1.6.6

router rip
 version 2
 redistribute eigrp 100 route-map e2r
 passive-interface default
 no passive-interface ATM0/0/0.1
 no passive-interface Ethernet2/1
 network 54.0.0.0
 network 204.12.1.0
 default-metric 3
 no auto-summary

ip prefix-list bb1routes seq 5 permit 212.18.0.0/22 ge 24 le 24
ip prefix-list bb3routes seq 5 permit 30.0.0.0/14 ge 16 le 16
ip prefix-list bb3routes seq 10 permit 31.0.0.0/14 ge 16 le 16

route-map r2e deny 10
 match tag 90
route-map r2e permit 20
 match ip address prefix-list bb1routes
 set tag 111
route-map r2e permit 30
 match ip address prefix-list bb3routes
 set tag 333
route-map r2e permit 40
 set tag 120

route-map e2r deny 10
 match tag 120
route-map e2r permit 20
 set tag 90

-------------------------------------------------------

ROUTER ONE

router eigrp 100
 redistribute ospf 110 route-map o2e
 passive-interface default
 no passive-interface Ethernet0/0
 network 136.1.136.1 0.0.0.0
 default-metric 1500 1 255 1 1500
 no auto-summary
 eigrp router-id 150.1.1.1

router ospf 110
 router-id 150.1.1.1
 redistribute eigrp 100 subnets route-map e2o
 network 136.1.15.1 0.0.0.0 area 0
 network 150.1.1.1 0.0.0.0 area 0
 default-metric 100
 distance ospf external 171

route-map e2o deny 10
 match tag 110
route-map e2o permit 20
 match tag 111
 set metric 111
route-map e2o permit 30
 match tag 333
 set metric 333
route-map e2o permit 40
 set tag 90

route-map o2e deny 10
 match tag 90
route-map o2e permit 20
 set tag 110

------------------------------

ROUTER TWO

router eigrp 100
 redistribute ospf 110 route-map o2e
 passive-interface default
 no passive-interface Serial0/1
 network 136.1.23.2 0.0.0.0
 network 150.1.2.2 0.0.0.0
 default-metric 1500 1 255 1 1500
 no auto-summary
 eigrp router-id 150.1.2.2

router ospf 110
 router-id 150.1.2.2
 redistribute eigrp 100 subnets route-map e2o
 network 136.1.245.2 0.0.0.0 area 0
 default-metric 100
 distance ospf external 171

route-map e2o deny 10
 match tag 110
route-map e2o permit 20
 match tag 111
 set metric 333
route-map e2o permit 30
 match tag 333
 set metric 111
route-map e2o permit 40
 set tag 90

route-map o2e deny 10
 match tag 90
route-map o2e permit 20
 set tag 110



This archive was generated by hypermail 2.1.4 : Mon Jan 03 2005 - 10:31:26 GMT-3