Re: FRTS again pls help

From: Bob Sinclair (bsin@cox.net)
Date: Mon Dec 06 2004 - 00:08:56 GMT-3


Edi,

One way to set the DE bit for traffic exceeding 48K would be to apply a
policy-map like this:

policy-map POLICE
    class class-default
        police cir 48000 conform-action transmit exceed-action
set-fr-de-transmit

You can apply this policy outbound on a physical interface, subinterface, or
within a map-class frame-relay. On the far side enter "show frame pvc XXX"
where XXX is the DLCI, and you will see the counter for in DE pkts increase,
if traffic exceeds 48K.

HTH,

Bob Sinclair
CCIE #10427, CCSI 30427, CISSP
www.netmasterclass.net

----- Original Message -----
From: "Edi Guntoro" <eguntoro@sisindosat.co.id>
To: "Edi Guntoro" <eguntoro@sisindosat.co.id>; <ccielab@groupstudy.com>
Sent: Sunday, December 05, 2004 8:42 PM
Subject: RE: FRTS again pls help

> Hi all,
>
> I try using de-list to set de bit, using below config now all my packet
> get de bit set. My original question, how to set de bit for traffic
> above 48k ?
>
> Regards
>
>
> r2#p 148.1.26.6
>
> Type escape sequence to abort.
> Sending 5, 100-byte ICMP Echos to 148.1.26.6, timeout is 2 seconds:
> !!!!!
> Success rate is 100 percent (5/5), round-trip min/avg/max = 56/56/60 ms
> r2#sh frame-relay pvc 206
>
> PVC Statistics for interface Serial0/0 (Frame Relay DTE)
>
> DLCI = 206, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
> Serial0/0
>
> input pkts 6 output pkts 6 in bytes 604
> out bytes 604 dropped pkts 0 in pkts dropped 0
>
> out pkts dropped 0 out bytes dropped 0
> in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
>
> out BECN pkts 0 in DE pkts 0 out DE pkts 6
>
> out bcast pkts 1 out bcast bytes 84
> 5 minute input rate 0 bits/sec, 0 packets/sec
> 5 minute output rate 0 bits/sec, 0 packets/sec
> Shaping adapts to BECN
> pvc create time 1d14h, last time pvc status changed 1d14h
> cir 48000 bc 6000 be 6000 byte limit 1500 interval 125
>
> mincir 48000 byte increment 750 Adaptive Shaping BECN
> pkts 6 bytes 604 pkts delayed 0 bytes delayed 0
>
> shaping inactive
> traffic shaping drops 0
> Queueing strategy: fifo
> Output queue 0/40, 0 drop, 0 dequeued
> r2#sh run int s0/0
> Building configuration...
>
> Current configuration : 291 bytes
> !
> interface Serial0/0
> ip address 148.1.26.2 255.255.255.0
> encapsulation frame-relay
> ip ospf network point-to-point
> no fair-queue
> frame-relay class 48k
> frame-relay traffic-shaping
> frame-relay de-group 1 206
> frame-relay map ip 148.1.26.6 206 broadcast
> no frame-relay inverse-arp
> end
>
> r2#sh run | in frame-relay de-list
> frame-relay de-list 1 protocol ip list 102
> r2#sh run | b map-class
> map-class frame-relay 48k
> frame-relay cir 48000
> frame-relay bc 6000
> frame-relay be 6000
> frame-relay mincir 48000
> frame-relay adaptive-shaping becn
>
> access-list 102 permit ip any any
> end
>
> -----Original Message-----
> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
> Edi Guntoro
> Sent: Monday, December 06, 2004 8:19 AM
> To: ccielab@groupstudy.com
> Subject: RE: FRTS again pls help
>
>
> Hi Ccie2b, Gladston
>
> I actually have try these two feature before and its works regarding
> assigning de bit. Ok lets say that the article is incorrect, But can you
> or any body can conform that we have to set it manually ?
>
> Regards,
>
>
> -----Original Message-----
> From: ccie2be [mailto:ccie2be@nyc.rr.com]
> Sent: Sunday, December 05, 2004 8:51 PM
> To: Edi Guntoro; ccielab@groupstudy.com
> Subject: Re: FRTS again pls help
>
>
> You can verify if the DE bit is set a couple of ways.
>
> The easiest is to do a show fram pvc <dlci#> and look at the field, "DE
> packets" or "DE bytes". Before doing that, however, make sure you clear
> the counters.
>
> The other way that comes to mind is to use MQC to create a class-map
> which matches on the DE bit, create a policy-map, and then and then
> apply the policy-map to the incoming interface. After generating some
> traffic, do a show policy-map interface X to see if there were any
> matches.
>
> HTH, Tim
>
>
> ----- Original Message -----
> From: "Edi Guntoro" <eguntoro@sisindosat.co.id>
> To: <ccielab@groupstudy.com>
> Sent: Saturday, December 04, 2004 10:03 PM
> Subject: FRTS again pls help
>
>
>> Hi Groups,
>> According to CCIE PS I page 345, regarding FRTS when the traffic
>> exceed configured CIR will have DE bit set. now I have dificulties on
>> how to verify my config, I try to ping with large datagram size, but
>> no packet with de set. or may be, I have to set it manually with
>> legacy F/R feature (de-list) ?
>>
>> Thanks for reading.
>>
>> Regards,
>>
>>
>>
>> r2#sh run | b map-class
>> map-class frame-relay 48k
>> frame-relay cir 48000
>> frame-relay bc 6000
>> frame-relay be 6000
>> frame-relay mincir 48000
>> frame-relay adaptive-shaping becn
>>
>> r2#sh run int s0/0
>> Building configuration...
>>
>> Current configuration : 231 bytes
>> !
>> interface Serial0/0
>> ip address 148.1.26.2 255.255.255.0
>> encapsulation frame-relay
>> no fair-queue
>> frame-relay class 48k
>> frame-relay traffic-shaping
>> frame-relay map ip 148.1.26.6 206 broadcast
>> no frame-relay inverse-arp
>> end
>>
>> r2#clear count
>> Clear "show interface" counters on all interfaces [confirm] r2# *Mar
>> 1 17:13:36.365: %CLEAR-5-COUNTERS: Clear counter on all
> interfaces
>> by console
>> r2#p
>> Protocol [ip]:
>> Target IP address: 148.1.26.6
>> Repeat count [5]:
>> Datagram size [100]: 7000
>> Timeout in seconds [2]:
>> Extended commands [n]:
>> Sweep range of sizes [n]:
>> Type escape sequence to abort.
>> Sending 5, 7000-byte ICMP Echos to 148.1.26.6, timeout is 2 seconds:
>> ..... Success rate is 0 percent (0/5)
>> r2#sh frame-relay pvc 206
>>
>> PVC Statistics for interface Serial0/0 (Frame Relay DTE)
>>
>> DLCI = 206, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE =
>> Serial0/0
>>
>> input pkts 25 output pkts 25 in bytes 35500
>> out bytes 35500 dropped pkts 0 in pkts dropped 0
>>
>> out pkts dropped 0 out bytes dropped 0
>> in FECN pkts 0 in BECN pkts 0 out FECN pkts 0
>>
>> out BECN pkts 0 in DE pkts 0 out DE pkts 0
>>
>> out bcast pkts 0 out bcast bytes 0
>> 5 minute input rate 1000 bits/sec, 0 packets/sec
>> 5 minute output rate 0 bits/sec, 0 packets/sec
>> Shaping adapts to BECN
>> pvc create time 16:14:22, last time pvc status changed 16:13:37
>> cir 48000 bc 6000 be 6000 byte limit 1500 interval
> 125
>>
>> mincir 48000 byte increment 750 Adaptive Shaping BECN
>> pkts 25 bytes 35500 pkts delayed 20 bytes delayed
>> 27980
>> shaping inactive
>> traffic shaping drops 0
>> Queueing strategy: fifo
>> Output queue 0/40, 0 drop, 20 dequeued
>> r2#
>>
>> ______________________________________________________________________
>> _
>> Subscription information may be found at:
>> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Mon Jan 03 2005 - 10:31:24 GMT-3