Re: dialer watch

From: DaveW (kapsi1911@hotmail.com)
Date: Wed Nov 24 2004 - 19:10:18 GMT-3


Ade,

Thanks for the reply, I don't think you need a dialer group/list to make
dialer watch work. I changed my lab slightly and did my dialer watch configs
on another router (r6) and have it watching the loopback interface of r5.
See diagram below. The only two interfaces that are in area 1 are the serial
interfaces that connect r5 to r6 through the frame cloud. All other
interfaces are in area 1. I also included r5's loopback interface
(5.5.5.5/32) in area 1. This loopback interface is summarized into area 0 to
5.0.0.0/8 with an "area 1 range" command". R6 is watching this summary route
and is configured to bring up the ISDN link if it disappears. The relevant
portions of the configs for r1, r5, and r6 are below. This time everything
worked fine but I'm still at a loss why my previous dialer-watch setup
failed to bring up the link. I didn't use dialer lists/groups below. My
config below works without them........ For kicks I added a dialer
list/group command before I tore down my old setup, to denied all ip
traffic, but still no luck. I'm not sure why this setup works but my
configuration in my original post failed. They are very similar.

r5 --->PVC to r6
|
|
|
|
r1 ------------(ISDN)----------r6 --->PVC to r5

r6#

interface Serial0/0.1 point-to-poin
 description PVC to r5
 ip address 10.0.0.2 255.255.255.0
 frame-relay interface-dlci 104
  class traffic-shape
!
interface BRI1/0
 ip address 10.1.1.2 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 30
 dialer map ip 5.0.0.0 name r1 broadcast 6098824555 (watch route)
 dialer map ip 10.1.1.1 name r1 broadcast 6098824555
 dialer load-threshold 2 either
 dialer watch-group 1
 isdn switch-type basic-ni
 no peer neighbor-route
 priority-group 1
 compress stac
 ppp authentication chap
 ppp multilink
!
!
router ospf 1
 log-adjacency-changes
 no discard-route internal
 network 10.0.0.0 0.0.255.255 area 0
 network 10.1.0.0 0.0.255.255 area 1
!
dialer watch-list 1 ip 5.0.0.0 255.0.0.0
!

#r1
!
interface BRI0/0
 ip address 10.1.1.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 0
 dialer map ip 10.1.1.2 name r6 broadcast 3013455042
 isdn switch-type basic-ni
 no peer neighbor-route
 compress stac
 priority-group 1
 ppp authentication chap
 ppp multilink
!

#r5
interface Serial1.1 point-to-point
 descrption PVC to r6
 ip address 10.0.1.1 255.255.255.0
 frame-relay interface-dlci 103
  class traffic-shape
!
!
router ospf 1
 log-adjacency-changes
 area 0 range 10.0.0.0 255.255.0.0
 area 1 range 5.0.0.0 255.0.0.0
 area 1 range 10.1.0.0 255.255.0.0
 network 5.5.5.5 0.0.0.0 area 1
 network 10.0.0.0 0.0.255.255 area 0
 network 10.1.0.0 0.0.255.255 area 1

Logs:
r6(config)#int serial 0/0
r6(config-if)#shut
r6(config-if)#
1d23h: %OSPF-5-ADJCHG: Process 1, Nbr 2.2.2.2 on Serial0/0.1 from FULL to
DOWN,
Neighbor Down: Interface down or detached
1d23h: %OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on Serial0/0.2 from FULL to
DOWN,
Neighbor Down: Interface down or detached
1d23h: DDR: Dialer Watch: watch-group = 1
1d23h: DDR: network 5.0.0.0/255.0.0.0 DOWN,
1d23h: DDR: primary DOWN
1d23h: DDR: Dialer Watch: Dial Reason: Primary of group 1 DOWN
1d23h: DDR: Dialer Watch: watch-group = 1,
1d23h: DDR: dialing secondary by dialer map 5.0.0.0 on BR1/0
1d23h: BR1/0 DDR: Attempting to dial 6098824555
1d23h: %LINK-3-UPDOWN: Interface BRI1/0:1, changed state to up
1d23h: BR1/0:1 DDR: Dialer Watch: resetting call in progress
1d23h: %LINK-5-CHANGED: Interface Serial0/0, changed state to
administratively d
own
1d23h: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
1d23h: Vi1 DDR: Dialer statechange to up
1d23h: Vi1 DDR: Dialer Watch: resetting call in progress
1d23h: Vi1 DDR: Dialer call has been placed
1d23h: Vi1 DDR: dialer protocol up
1d23h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed
state
to down
1d23h: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/0:1, changed
state t
o up
1d23h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1,
changed
state to up
1d23h: %OSPF-5-ADJCHG: Process 1, Nbr 1.1.1.1 on BRI1/0 from LOADING to
FULL, Lo
ading Done
1d23h: %ISDN-6-CONNECT: Interface BRI1/0:1 is now connected to 6098824555 r1

-dave

----- Original Message -----
From: <adeolu@sympatico.ca>
To: "DaveW" <kapsi1911@hotmail.com>; "Cisco certification"
<ccielab@groupstudy.com>
Sent: Wednesday, November 24, 2004 9:13 AM
Subject: Re: dialer watch

> Hi Dave,
>
> I do not know if your question has been answered already. However, I
think you need to put a dialer-group statement under the BRI interface. You
can deny all traffic in the dialer-list if you need to but I feel this
command is needed for the interface to behave as desired.
>
> Just my two cents....
>
> Ade
>
> >
> > From: "DaveW" <kapsi1911@hotmail.com>
> > Date: 2004/11/22 Mon PM 10:08:35 EST
> > To: "Cisco certification" <ccielab@groupstudy.com>
> > Subject: dialer watch
> >
> > I'm having trouble getting my dialer-watch groups to bring up a bri line
once
> > the routes being watched disappear. I have the following setup:
> >
> > r5 ---------- r3 ------- ISDN -------r2
> >
> > When I shut the serial 0/0 interface on r3 (to r5) I can't get r3 to
bring the
> > BRI link to r2. Although going through the dialer debugs it seems that
the
> > watch process recognizes the watched route has disappeared. If I add a
dialer
> > list/group on r3 for all IP traffic, the link comes up fine. Configs and
> > debugs below:
> >
> > r3
> > interface BRI0/0
> > ip address 10.1.1.1 255.255.255.0
> > encapsulation ppp
> > dialer map ip 10.1.0.0 broadcast 3013455042
> > dialer map ip 10.1.1.2 broadcast 3013455042
> > dialer load-threshold 1 either
> > dialer watch-group 2
> > isdn switch-type basic-ni
> > compress stac
> > priority-group 1
> > ppp multilink
> > !
> > dialer watch-list 2 ip 10.1.0.0 255.255.255.0
> > !
> > interface Serial0/0
> > ip address 10.1.0.1 255.255.255.0
> >
> > r3#show ip route
> > Gateway of last resort is not set
> >
> > 1.0.0.0/24 is subnetted, 1 subnets
> > C 1.1.1.0 is directly connected, Loopback0
> > 10.0.0.0/24 is subnetted, 2 subnets
> > C 10.1.1.0 is directly connected, BRI0/0
> > C 10.1.0.0 is directly connected, Serial0/0
> >
> >
> >
> >
> > r2
> > !
> > interface BRI1/0
> > ip address 10.1.1.2 255.255.255.0
> > encapsulation ppp
> > dialer map ip 10.1.1.1 broadcast 6098831000
> > isdn switch-type basic-ni
> > priority-group 1
> > compress stac
> > ppp multilink
> > !
> >
> >
> >
> >
> >
> > r3(config)#int serial 0/0
> > r3(config-if)#shut
> > r1(config-if)#
> > Nov 22 09:38:23: %OSPF-5-ADJCHG: Process 1, Nbr 5.5.5.5 on Serial0/0
from
> > FULL
> > to DOWN, Neighbor Down: Interface down or detached
> > 03:46:42: DDR: Dialer Watch: watch-group = 2
> > 03:46:42: DDR: network 10.1.0.0/255.255.255.0 DOWN,
> > 03:46:42: DDR: primary DOWN
> > 03:46:42: DDR: Dialer Watch: Dial Reason: Primary of group 2 DOWN
> > 03:46:42: DDR: Dialer Watch: watch-group = 2,
> > 03:46:44: DDR: Dialer Watch: watch-group = 2
> > 03:46:44: DDR: network 10.1.0.0/255.255.255.0 DOWN,
> > 03:46:44: DDR: primary DOWN
> > 03:46:44: DDR: Dialer Watch: Dial Reason: Primary of group 2 DOWN
> > 03:46:44: DDR: Dialer Watch: watch-group = 2,
> > Nov 22 09:38:25: %LINK-5-CHANGED: Interface Serial0/0, changed state to
> > adminis
> > tratively down
> > Nov 22 09:38:26: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0,
> > cha
> > nged state to down
> >
> > _______________________________________________________________________
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Thu Dec 02 2004 - 06:57:49 GMT-3