Re: virtual links over ip unnumbered

From: Kirk Graham (kgraham@instructors.net)
Date: Sun Nov 21 2004 - 22:46:14 GMT-3


Vytautas,

I believe you found the correct entry in the RFC of why its not working.

I've run into this exact problem before with Bay Networks. I used to teach
their courses before teaching Cisco. We had two routers connected with a
frame-relay between them, and a point-to-point that was unnumbered and
associated to the 2 router's ethernets. The ethernet's and unnumbered
pt-to-pt were all in one area, the FR was in Area 0. There was a third
router behind one of the others that was in a separate area. If the FR was
disconnected, then the virtual link broke. So its not a "Cisco thing", but
an "OSPF thing."

I setup two Cisco routers and used your basic config. The same thing
happened to me... the Virtual link would not come up.

Then I configured a 2nd serial link between the two routers in area 16, and
the virtual link came up. If it matters, I was using v12.2(10b) Enterprise
Plus IOS on both routers.

What is going on is that OSPF needs both of the two endpoints of a virtual
link to be numbered IP. I believe, but have not verified, that if you had
say... 4 routers in a line (Ra-Rb-Rc-Rd), with RouterA having an intf in
Area 0 and RouterD being a 2nd ABR but no Area 0 connection, that a serial
link between RouterB and RouterC could be unnumbered IP, but not the links
between RouterA and RouterB, or RouterC and RouterD, and then you could
still get the Virtual Link to work. Does that make sense? I think that's
what they are "trying" to say in the RFC section you found for us.

Maybe Howard Berkowitz can translate that section for us! <g> I don't want
to dig out my OSPF source code again!

Here are my configs... for the curious. I used names Central & Branch
because I was teaching BCRAN last week. <g>

----------------------------------------------------------------------------------------------------------------------------------------------------Central#sh
run
Building configuration...

Current configuration : 1086 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Central
!
!
ip subnet-zero
no ip domain-lookup
ip host revt 2017 172.16.1.1
!
!
!
!
interface Loopback1
  description Area 0
  ip address 172.16.1.1 255.255.255.0
  ip ospf network point-to-point
!
interface Loopback101
  description Area 16
  ip address 172.16.101.1 255.255.255.0
  ip ospf network point-to-point
!
interface Ethernet0
  no ip address
  shutdown
!
interface Serial0
  description Area 16
  bandwidth 2000
  ip unnumbered Loopback101
  no fair-queue
!
interface Serial1
  description Area 16
  bandwidth 1000
  ip address 172.16.102.1 255.255.255.0
!
router ospf 1
  router-id 172.16.101.1
  log-adjacency-changes
  area 16 virtual-link 172.16.106.1
  network 172.16.1.1 0.0.0.0 area 0
  network 172.16.101.1 0.0.0.0 area 16
  network 172.16.102.1 0.0.0.0 area 16
!
ip classless
ip http server
ip pim bidir-enable
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line 1 16
  flush-at-activation
line aux 0
  no exec
  transport input telnet
line vty 0 4
  login
!
end
----------------------------------------------------------------------------------------------------------------------------------------------------
Branch#sh run
Building configuration...

Current configuration : 985 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Branch
!
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback100
  ip address 172.16.100.1 255.255.255.0
  ip ospf network point-to-point
!
interface Loopback101
  ip address 172.16.106.1 255.255.255.0
  ip ospf network point-to-point
!
interface Ethernet0
  no ip address
  shutdown
!
interface Serial0
  bandwidth 2000
  ip unnumbered Loopback101
  clockrate 2000000
!
interface Serial1
  bandwidth 1000
  ip address 172.16.102.2 255.255.255.0
  clockrate 1000000
!
router ospf 1
  router-id 172.16.106.1
  log-adjacency-changes
  area 16 virtual-link 172.16.101.1
  network 172.16.100.1 0.0.0.0 area 100
  network 172.16.102.2 0.0.0.0 area 16
  network 172.16.106.1 0.0.0.0 area 16
!
ip classless
ip http server
ip pim bidir-enable
!
!
!
line con 0
  exec-timeout 0 0
  privilege level 15
  logging synchronous
line 1 16
  flush-at-activation
line aux 0
line vty 0 4
!
end
----------------------------------------------------------------------------------------------------------------------------------------------------
If I have time tomorrow, maybe I'll setup a 4 router network like I
mentioned above and give it a try.

I hope this helps some,
Kirk Graham, CCNP, CCSI

---
Pay for my failed attempts and I'll try the CCIE lab! <g>

At 04:42 PM 11/21/2004, you wrote: >Hi Group, > >I found a hint on virtual-link problem i have. My guess is that it is >impossible to build up virtual link if at least one of the routers is >connected to transit area only with ip unnumbered link. Here is an excerpt >from RFC2328: > >--- >Just as the virtual link's cost and viability are determined by the routing >table build process (through construction of the routing table entry for the >other endpoint), so are the IP >interface address for the virtual interface and the virtual neighbor's IP >address. These are used when sending OSPF >protocol packets over the virtual link. Note that when one (or both) of the >virtual link endpoints connect to the Transit area via an unnumbered >point-to-point link, it may be impossible to calculate either the virtual >interface's IP address and/or the virtual neighbor's IP address, thereby >causing the virtual link to fail. >--- > >As you see it is not clearly stated that link will definately fail. It is >writen 'may'. Any ideas on what topology virtual-link with ip unnumbered >would work? > >Cheers, >Vytautas Valancius > >----- Original Message ----- >From: "Vytautas Valancius" <valas@mail.lt> >To: <ccielab@groupstudy.com> >Sent: Sunday, November 21, 2004 4:50 PM >Subject: Re: virtual links over ip unnumbered > > > > Hi Group, > > > > Can anybody confirm that they succeed in running direct OSPF virtual-link > > over ip > > unnumebered? Maybe it is not possible to do and I'm sticking to this >problem > > too much. > > > > Cheers, > > Vytautas Valancius > > > > ----- Original Message ----- > > From: "Vytautas Valancius" <valas@mail.lt> > > To: <ccielab@groupstudy.com> > > Sent: Sunday, November 21, 2004 12:51 AM > > Subject: Re: virtual links over ip unnumbered > > > > > > > Hi, > > > > > > Below are super simple configurations for two routers connected with > > serial > > > line. > > > > > > Virtual links are down even in this simple config. Network >172.16.100.0/24 > > > is not in R1 because of that. As I said more interesting things happen > > when > > > we have complex ISDN setup, but I guess before debuging that one should > > > understand why this simple configuration is not working... > > > > > > There are no error messages. 'debug ip ospf adj' does not show any >output. > > > 'debug ip ospf packet' behaves as there is no virtual link configured - >no > > > packets are sent ir received to establish it. > > > > > > R1: > > > ! > > > interface Loopback1 > > > description area 0 > > > ip address 172.16.1.1 255.255.255.0 > > > ip ospf network point-to-point > > > ! > > > interface Loopback101 > > > ip address 172.16.101.1 255.255.255.0 > > > ip ospf network point-to-point > > > ! > > > interface Serial4/6 > > > ip unnumbered Loopback101 > > > ! > > > router ospf 1 > > > router-id 172.16.101.1 > > > log-adjacency-changes > > > area 16 virtual-link 172.16.106.1 > > > passive-interface Loopback1 > > > network 172.16.1.1 0.0.0.0 area 0 > > > network 172.16.101.1 0.0.0.0 area 16 > > > ! > > > > > > R1#sh ip ospf nei > > > > > > Neighbor ID Pri State Dead Time Address > > Interface > > > 172.16.106.1 1 FULL/ - 00:00:39 172.16.106.1 > > Serial4/6 > > > > > > R1#sh ip ospf virtual-links > > > Virtual Link OSPF_VL0 to router 172.16.106.1 is down > > > Run as demand circuit > > > DoNotAge LSA allowed. > > > Transit area 16, Cost of using 65535 > > > Transmit Delay is 1 sec, State DOWN, > > > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 > > > > > > R1#ping 172.16.106.1 > > > > > > Type escape sequence to abort. > > > Sending 5, 100-byte ICMP Echos to 172.16.106.1, timeout is 2 seconds: > > > !!!!! > > > Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms > > > R1#sh ip ro > > > Gateway of last resort is not set > > > > > > 172.16.0.0/24 is subnetted, 3 subnets > > > C 172.16.1.0 is directly connected, Loopback1 > > > O 172.16.106.0 [110/782] via 172.16.106.1, 00:04:47, Serial4/6 > > > C 172.16.101.0 is directly connected, Loopback101 > > > > > > > > > R6 output: > > > ! > > > interface Loopback100 > > > description area 100 > > > ip address 172.16.100.1 255.255.255.0 > > > ip ospf network point-to-point > > > ! > > > interface Loopback106 > > > ip address 172.16.106.1 255.255.255.0 > > > ip ospf network point-to-point > > > ! > > > interface Serial0 > > > ip unnumbered Loopback106 > > > no fair-queue > > > clockrate 125000 > > > ! > > > interface Serial1 > > > no ip address > > > shutdown > > > ! > > > router ospf 1 > > > router-id 172.16.106.1 > > > log-adjacency-changes > > > area 16 virtual-link 172.16.101.1 > > > network 172.16.100.1 0.0.0.0 area 100 > > > network 172.16.106.1 0.0.0.0 area 16 > > > ! > > > R6#sh ip ospf nei > > > > > > Neighbor ID Pri State Dead Time Address > > Interface > > > 172.16.101.1 1 FULL/ - 00:00:33 172.16.101.1 >Serial0 > > > R6# > > > R6#sh ip os > > > R6#sh ip ospf vir > > > Virtual Link OSPF_VL0 to router 172.16.101.1 is down > > > Run as demand circuit > > > DoNotAge LSA allowed. > > > Transit area 16, Cost of using 65535 > > > Transmit Delay is 1 sec, State DOWN, > > > Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5 > > > > > > R6#ping 172.16.101.1 > > > > > > Type escape sequence to abort. > > > Sending 5, 100-byte ICMP Echos to 172.16.101.1, timeout is 2 seconds: > > > !!!!! > > > Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/20 ms > > > R6# > > > R6#sh ip ro > > > > > > Gateway of last resort is not set > > > > > > 172.16.0.0/24 is subnetted, 4 subnets > > > O IA 172.16.1.0 [110/65] via 172.16.101.1, 00:04:34, Serial0 > > > C 172.16.106.0 is directly connected, Loopback106 > > > C 172.16.100.0 is directly connected, Loopback100 > > > O 172.16.101.0 [110/65] via 172.16.101.1, 00:04:44, Serial0 > > > > > > > > > ----- Original Message ----- > > > From: "ccie2be" <ccie2be@nyc.rr.com> > > > To: "Vytautas Valancius" <valas@mail.lt>; <ccielab@groupstudy.com> > > > Sent: Sunday, November 21, 2004 12:59 AM > > > Subject: Re: virtual links over ip unnumbered > > > > > > > > > > Could you post your configuration? Including show command output? >And, > > > > error messages? > > > > ----- Original Message ----- > > > > From: "Vytautas Valancius" <valas@mail.lt> > > > > To: <ccielab@groupstudy.com> > > > > Sent: Saturday, November 20, 2004 2:37 PM > > > > Subject: virtual links over ip unnumbered > > > > > > > > > > > > > Hi Group, > > > > > > > > > > Does OSPF virtual-link work over link with ip unnumbered on both > > sides? > > > > > > > > > > I did not succed to run it in pretty basic setups. Moreover, if I >run > > it > > > > > over unnumbered ISDN, demand-circuit feature is not working. Virtual > > > link > > > > is > > > > > UP only on one side and it keeps sending OSPF messages that brings > > ISDN > > > up > > > > > imediatelly after it goes down. > > > > > > > > > > Any comments are welcomed! > > > > > > > > > > valas > > > > > > > > > > > > _______________________________________________________________________ > > > > > Subscription information may be found at: > > > > > http://www.groupstudy.com/list/CCIELab.html > > > > > > _______________________________________________________________________ > > > Subscription information may be found at: > > > http://www.groupstudy.com/list/CCIELab.html > > > > _______________________________________________________________________ > > Subscription information may be found at: > > http://www.groupstudy.com/list/CCIELab.html > >_______________________________________________________________________ >Subscription information may be found at: >http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Thu Dec 02 2004 - 06:57:48 GMT-3