Multicast helper map seems to work, but doesn't actually

From: Edwards, Andrew M (andrew.m.edwards@boeing.com)
Date: Thu Nov 11 2004 - 14:07:03 GMT-3


Well, as is usual for most people, time is running short to study for my
next lab attempt and I ran into a very specific problem while digging
into multicast...

Normally I wont post so much output cause its hard to dig through, but
this one really bothers me. If you have time, please read on.

Basically, multicast helper map is working and forwarding multicast
packets, but they are not actually being sent out the interface (e.g.
neighbor doensn't get the (*,G) entry because no packets are being
received).

R4 is getting RIP broadcasts. R4 has Mroute for the helper map. R4
debug ip mpacket shows mforward on the helper mapped packet. But, R2 is
NOT getting the packet???

If you have a minute to look this over I could use some insight... thx

---------

Setup: Basic setup with of RIP broadcast version 1 packets multicast
helper mapped in dense mode flood.

CAT2------- e1/0--- R4 ----e0/0 --------e0/0---R2

And, R4 and R2 are with cross over cable (removed potential for catalyst
to be involved)

show run
Building configuration...

Current configuration : 2439 bytes
!
version 12.3
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$z12f$r8O3R5b.Z54IQ4kAYt4zB1
!
clock timezone PST -8
clock summer-time DST recurring
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup
ip multicast-routing
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 140.40.102.1 255.255.255.0
no clns route-cache
!
interface Ethernet0/0
bandwidth 10000
ip address 140.40.40.2 255.255.255.0
ip pim dense-mode
half-duplex
no clns route-cache
!
interface Serial0/0
no ip address
encapsulation frame-relay
no arp frame-relay
no clns route-cache
no frame-relay inverse-arp
!
interface Serial0/0.234 point-to-point
ip address 140.40.234.2 255.255.255.240
ip pim dense-mode
ip ospf network broadcast
ip ospf priority 0
frame-relay interface-dlci 201
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
no clns route-cache
!
interface Serial0/1
no ip address
shutdown
no clns route-cache
!
interface BRI1/0
no ip address
shutdown
no clns route-cache
!
interface Ethernet1/0
no ip address
shutdown
half-duplex
no clns route-cache
!
router eigrp 100
redistribute ospf 1 metric 10000 1 255 1 1500
passive-interface default
no passive-interface Ethernet0/0
network 140.40.40.0 0.0.0.255
network 140.40.102.0 0.0.0.255
default-metric 64 1 255 1 1500
no auto-summary
!
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute eigrp 100 metric 200 metric-type 1 subnets
network 140.40.234.2 0.0.0.0 area 0
default-metric 2000
distance ospf external 180
!
router bgp 100
no synchronization
bgp router-id 2.2.2.2
bgp log-neighbor-changes
neighbor 140.40.103.1 remote-as 100
neighbor 140.40.103.1 update-source Loopback0
neighbor 140.40.105.1 remote-as 500
neighbor 140.40.105.1 ebgp-multihop 255
neighbor 140.40.105.1 update-source Loopback0
neighbor 140.40.105.1 send-community
neighbor 140.40.105.1 route-map set_comm_to_R5 out
no auto-summary
!
ip http server
ip classless
!
ip bgp-community new-format
!
access-list 4 permit 128.128.0.0 0.0.127.255
!
route-map set_comm_to_R5 permit 10
match ip address 4
set community 100:120 additive
!
route-map set_comm_to_R5 permit 20
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
!
end

R2#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP
Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast
Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.0.1.40), 00:16:44/00:02:48, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:01:35/00:00:00
    Serial0/0.234, Forward/Dense, 00:16:40/00:00:00

R2#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

D EX 140.12.0.0/16 [170/281856] via 140.40.40.4, 00:01:36, Ethernet0/0
     140.40.0.0/16 is variably subnetted, 9 subnets, 2 masks
C 140.40.234.0/28 is directly connected, Serial0/0.234
C 140.40.40.0/24 is directly connected, Ethernet0/0
O IA 140.40.20.0/24 [110/65] via 140.40.234.1, 00:18:06,
Serial0/0.234
D EX 140.40.30.0/24 [170/281856] via 140.40.40.4, 00:01:36,
Ethernet0/0
O IA 140.40.101.0/24 [110/65] via 140.40.234.1, 00:18:06,
Serial0/0.234
C 140.40.102.0/24 is directly connected, Loopback0
O E1 140.40.103.0/24 [180/364] via 140.40.234.3, 00:18:07,
Serial0/0.234
D EX 140.40.104.0/24 [170/281856] via 140.40.40.4, 00:01:37,
Ethernet0/0
O IA 140.40.105.0/24 [110/66] via 140.40.234.1, 00:18:07,
Serial0/0.234
     128.128.0.0/17 is subnetted, 1 subnets
D 128.128.0.0 [90/409600] via 140.40.40.4, 00:01:37, Ethernet0/0
     150.40.0.0/24 is subnetted, 4 subnets
B 150.40.30.0 [20/0] via 140.40.105.1, 00:18:02
B 150.40.31.0 [20/0] via 140.40.105.1, 00:18:02
B 150.40.28.0 [20/0] via 140.40.105.1, 00:18:02
B 150.40.29.0 [20/0] via 140.40.105.1, 00:18:02
R2#

------

R4
Building configuration...

Current configuration : 1927 bytes
!
version 12.3
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
logging buffered 4096 debugging
enable secret 5 $1$mz8n$ZIB80CuUYS7qHBaONkUvy1
!
clock timezone PST -8
clock summer-time DST recurring
no aaa new-model
ip subnet-zero
!
!
no ip domain lookup

ip multicast-routing
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 140.40.104.1 255.255.255.0
ip pim dense-mode
ip igmp join-group 225.5.5.5
no clns route-cache
interface Loopback1
ip address 128.128.1.1 255.255.128.0
no clns route-cache
!
interface Ethernet0/0
ip address 140.40.40.4 255.255.255.0
ip directed-broadcast
ip pim dr-priority 10
ip pim dense-mode
half-duplex
no clns route-cache
!
interface Serial0/0
no ip address
shutdown
no clns route-cache
!
interface TokenRing0/0
no ip address
shutdown
ring-speed 16
no clns route-cache

interface Ethernet1/0
ip address 140.40.30.4 255.255.255.0
ip directed-broadcast
ip pim dense-mode
ip multicast helper-map broadcast 224.9.9.9 100
half-duplex
no clns route-cache
!
interface TokenRing1/0
no ip address
shutdown
ring-speed 16
no clns route-cache
!
router eigrp 100
redistribute rip metric 10000 1 255 1 1500
passive-interface default
no passive-interface Ethernet0/0
network 128.128.0.0
network 140.40.40.0 0.0.0.255
default-metric 64 1 255 1 1500
no auto-summary

router rip
redistribute eigrp 100 metric 2
passive-interface default
no passive-interface Ethernet1/0
network 140.40.0.0
!
no ip http server
ip classless
ip forward-protocol udp rip
!
!
access-list 100 permit udp any any eq rip
access-list 102 permit udp any any log
!
!
!
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
password cisco
login
!
!
end

R4#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C -
Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP
Advertisement,
       U - URD, I - Received Source Specific Host Report, Z - Multicast
Tunnel
       Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 225.5.5.5), 00:13:57/00:02:34, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:01:59/00:00:00
    Loopback0, Forward/Dense, 00:13:57/00:00:00

(*, 224.9.9.9), 00:43:42/stopped, RP 0.0.0.0, flags: D
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:01:59/00:00:00

(140.40.30.12, 224.9.9.9), 00:17:05/00:02:31, flags: T <-CAT2
translation
  Incoming interface: Ethernet1/0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:02:01/00:00:00

(*, 224.0.1.40), 01:24:23/00:02:36, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Ethernet0/0, Forward/Dense, 00:02:01/00:00:00
    Ethernet1/0, Forward/Dense, 00:02:09/00:00:00

R4#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static
route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

R 140.12.0.0/16 [120/1] via 140.40.30.12, 00:00:04, Ethernet1/0
     140.40.0.0/16 is variably subnetted, 9 subnets, 2 masks
D EX 140.40.234.0/28 [170/281856] via 140.40.40.2, 00:02:00,
Ethernet0/0
C 140.40.40.0/24 is directly connected, Ethernet0/0
D EX 140.40.20.0/24 [170/281856] via 140.40.40.2, 00:02:00,
Ethernet0/0
C 140.40.30.0/24 is directly connected, Ethernet1/0
D EX 140.40.101.0/24 [170/281856] via 140.40.40.2, 00:02:00,
Ethernet0/0
D 140.40.102.0/24 [90/409600] via 140.40.40.2, 00:02:01,
Ethernet0/0
D EX 140.40.103.0/24 [170/281856] via 140.40.40.2, 00:02:01,
Ethernet0/0
C 140.40.104.0/24 is directly connected, Loopback0
D EX 140.40.105.0/24 [170/281856] via 140.40.40.2, 00:02:01,
Ethernet0/0
     128.128.0.0/17 is subnetted, 1 subnets
C 128.128.0.0 is directly connected, Loopback1

R4#debug ip packet 100 det
IP packet debugging is on (detailed) for access list 100
R4#
*Mar 1 01:24:59: IP: s=140.40.30.4 (local), d=255.255.255.255
(Ethernet1/0), len 192, sending broad/multicast
*Mar 1 01:24:59: UDP src=520, dst=520
R4#
*Mar 1 01:25:02: IP: s=140.40.30.12 (Ethernet1/0), d=255.255.255.255,
len 52, rcvd 2
*Mar 1 01:25:02: UDP src=520, dst=520

R4#un all
All possible debugging has been turned off

R4#debug ip mpacket
IP multicast packets debugging is on
R4#
*Mar 1 01:25:29: IP(0): s=140.40.30.12 (Ethernet1/0) d=224.9.9.9
(Ethernet0/0) id=0, prot=17, len=52(52), mforward

R4#un all
All possible debugging has been turned off

R4#ping 140.40.40.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 140.40.40.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms
R4#



This archive was generated by hypermail 2.1.4 : Thu Dec 02 2004 - 06:57:41 GMT-3