From: Kian Wah Lai (kian_wah@qala.com.sg)
Date: Fri Oct 29 2004 - 03:04:21 GMT-3
At the interface level, you can't configure fair-queue with
random-detect, they're mutually exclusive.
2620(config-if)#fair
Must remove RED configuration first.
2620(config-if)#service-policy out TEST
Must remove RED configuration first.
In class-map and in class-default, you can enable both of them.
The following example configures policy for the default class included
in the policy map called policy8. The *fair-queue* command reserves 20
dynamic queues to be used for the default class. For congestion
avoidance, Weighted Random Early Detection (WRED) packet drop is used,
not tail drop.
policy-map policy8
class class-default
fair-queue 20
random-detect
----------------
Regards,
Kian Wah
Singapore Cisco User Group
http://www.sgcug.org/
3 routers and one PIX rental at SGD2/hr or USD1.30/hr
Cisco Net wrote:
>Guys,
>I am so confused now...
>so on non distributed systems should i enable fairq for wred ?
>Please help and verify...
>Cert
>
>
>On Fri, 29 Oct 2004 00:44:00 +0800, Kian Wah Lai <kian_wah@qala.com.sg> wrote:
>
>
>>I checked the Knowledgenet Implementing QoS course and it stated
>>'Nondistributed WRED cannot be combined with fancy queuing - FIFO queuing
>>has to be used'.
>>
>>----------------
>>
>>
>Regards,
>Kian Wah
>Singapore Cisco User
>
>
>>Group
>>
>>
>http://www.sgcug.org/
>3 routers and one PIX rental at SGD2/hr or
>
>
>>USD1.30/hr
>>
>>
>>
>>Jongsoo.Kim@Intelsat.com wrote:
>>I think WREQ or queue-limit can be used with Fair Queue, which is of
>>course
>>
>>
>subject of critic audit.
>Fair Queue defines queue depth
>
>
>>(congestive-discard-threshold, DF=64 )and
>>
>>
>WRED or Queue limit define how
>
>
>>packets should be dropped when the queue
>>
>>
>depth exceeds. With WRED, the
>
>
>>packet will be dropped based on WRED feature
>>
>>
>and with queue limit, the
>
>
>>packet will be dropped based on FIFO
>>
>>
>
>By the way, I am taking lab tomorrow
>
>
>>and hope this doesn't show up.
>>
>>
>
>Regards
>
>Jongsoo
>
>
>
>
>-----Original
>
>
>>Message-----
>>
>>
>From: AK Singh [mailto:singh.anand@gmail.com]
>Sent: Thursday,
>
>
>>28 October, 2004 3:16 AM
>>
>>
>To: John Matus
>Cc: Cisco Net; Group Study
>Subject:
>
>
>>Re: WRED without fairq / cb-wfq ?
>>
>>
>
>
>I am still not clear if fair queuing
>
>
>>needs to be enabled before
>>
>>
>configuring WRED (say on ethernet
>
>
>>interface)
>>
>>
>
>http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos
>_c/fqcprt3/qcfwred.htm#22292
>
>The
>
>
>>documentation and example doesn't say that. I also observe that
>>
>>
>both
>
>
>>fair-queue and random detect seems to be mutually exclusive and
>>
>>
>if you
>
>
>>configure one other is gone, In fact if "random detect" is
>>
>>
>configured, IOS
>
>
>>won't let you configure "fair-queue". See the log
>>
>>
>below. Can someone clear
>
>
>>this doubt for me:
>>
>>
>
>R2#sh running-config interface e0/2
>Building
>
>
>>configuration...
>>
>>
>
>Current configuration : 216 bytes
>!
>interface Ethernet0/2
>
>
>>ip address 169.1.27.2 255.255.255.0
>>
>>
> no ip mroute-cache
>
>
>>half-duplex
>>
>>
>end
>
>R2#c
>Enter configuration commands, one per line. End with
>
>
>>CNTL/Z.
>>
>>
>R2(config)#interface ethernet 0/2
>R2(config-if)#fair-queue
>
>
>R2(config-if)#^Z
>R2#sh running-config interface e0/2
>*Mar 6 05:47:03.976:
>
>
>>%SYS-5-CONFIG_I: Configured from console by console
>>
>>
>R2#sh running-config
>
>
>>interface e0/2
>>
>>
>Building configuration...
>
>Current configuration : 228
>
>
>>bytes
>>
>>
>!
>interface Ethernet0/2
> ip address 169.1.27.2 255.255.255.0
> no ip
>
>
>>mroute-cache
>>
>>
> half-duplex
> fair-queue
>end
>
>R2#sh queueing interface
>
>
>>e0/2
>>
>>
>Interface Ethernet0/2 queueing strategy: fair
> Input queue: 0/75/0/0
>
>
>>(size/max/drops/flushes); Total output drops: 0
>>
>>
> Queueing strategy: weighted
>
>
>>fair
>>
>>
> Output queue: 0/1000/64/0 (size/max total/threshold/drops)
>
>
>>Conversations 0/1/256 (active/max active/max total)
>>
>>
> Reserved Conversations
>
>
>>0/0 (allocated/max allocated)
>>
>>
> Available Bandwidth 7500
>
>
>>kilobits/sec
>>
>>
>
>
>R2#c
>Enter configuration commands, one per line. End with
>
>
>>CNTL/Z.
>>
>>
>R2(config)#int e0/2
>R2(config-if)#ran
>R2(config-if)#random-detect
>
>
>R2(config-if)#^Z
>R2#sh queueing interface e0/2
>Interface Ethernet0/2
>
>
>>queueing strategy: random early detection (WRED)
>>
>>
> Exp-weight-constant: 9
>
>
>>(1/512)
>>
>>
> Mean queue depth: 0
>
> class Random drop Tail drop Minimum Maximum
>
>
>>Mark
>>
>>
> pkts/bytes pkts/bytes thresh thresh prob
> 0 0/0 0/0 20 40 1/10
> 1 0/0
>
>
>>0/0 22 40 1/10
>>
>>
> 2 0/0 0/0 24 40 1/10
> 3 0/0 0/0 26 40 1/10
> 4 0/0 0/0 28 40
>
>
>>1/10
>>
>>
> 5 0/0 0/0 31 40 1/10
> 6 0/0 0/0 33 40 1/10
> 7 0/0 0/0 35 40 1/10
> rsvp
>
>
>>0/0 0/0 37 40 1/10
>>
>>
>
>R2#sh running-config interface e0/2
>Building
>
>
>>configuration...
>>
>>
>
>Current configuration : 232 bytes
>!
>interface Ethernet0/2
>
>
>>ip address 169.1.27.2 255.255.255.0
>>
>>
> no ip mroute-cache
> half-duplex
>
>
>>random-detect
>>
>>
>end
>
>R2#c
>Enter configuration commands, one per line. End
>
>
>>with CNTL/Z.
>>
>>
>R2(config)#in
>R2(config)#interface
>
>
>>e0/2
>>
>>
>R2(config-if)#fa
>R2(config-if)#fair-queue
>Must remove RED
>
>
>>configuration first.
>>
>>
>R2(config-if)#^Z
>R2#
>*Mar 6 05:47:56.596:
>
>
>>%SYS-5-CONFIG_I: Configured from
>>
>>
>
>
>On Wed, 27 Oct 2004 22:16:14 -0700, John
>
>
>>Matus <jmatus@pacbell.net> wrote:
>>
>>
>
>
>
>>now, a question that has come up is weather you have to specify a queue
>>size
>>
>>
>
>
>
>>when you configure 'fair-queue'. from what i'm told the default queue
>>
>>
> size
>
>
>>is zero so unless you create queues the whole thing doesn't
>>practically
>>
>>
>work......
>anyone care to comment on this?
>
>
>
>
>Regards,
>
>John D.
>
>
>>Matus
>>
>>
>MCSE, CCNP
>Office: 818-782-2061
>Cell:
>
>
>>818-430-8372
>>
>>
>jmatus@pacbell.net
>----- Original Message -----
>From: "Cisco
>
>
>>Net" <network.cisco@gmail.com>
>>
>>
>To: "Group Study"
>
>
>><ccielab@groupstudy.com>
>>
>>
>Sent: Wednesday, October 27, 2004 7:13 PM
>Subject:
>
>
>>WRED without fairq / cb-wfq ?
>>
>>
>
>
>
>
>>Hi
>>
>>
>Is fairq or cb-wfq is a requirement for wred... ?
>So far i was thinking
>
>
>>this is the requirement until somebody mentioned
>>
>>
> me
>
>
>
>>it is not a requirement.So i am seeking help here to verify this..
>>
>>
>
>1) Can i
>
>
>>enable wred on an ethernet interface without changing the fifo
>>
>>
> to
>
>
>
>>fairq
>>
>>
> queueing. I tried and it dows not complain but i am not whether i
>am
>
>
>>doing right
>>
>>
> or wrong.
>2) I know that in MQC i can enable on class-default.
>
>
>>Also the default
>>
>>
>q is fair q here
> How about if i have a class with cbwfq
>
>
>>(bandwith) and LLQ
>>
>>
>(priority). Can i use
> wred on these classes...
>
>Thank
>
>
>>you for your
>>help..
>>
>>
>Regards
>Cert
>
>_______________________________________________________________________
>Subscription
>
>
>>information may be found at:
>>
>>
>http://www.groupstudy.com/list/CCIELab.html
>
>
>>_______________________________________________________________________
>>
>>
>Subscription
>
>
>>information may be found at:
>>
>>
>http://www.groupstudy.com/list/CCIELab.html
>
>
>>_______________________________________________________________________
>>
>>
>Subscription
>
>
>>information may be found at:
>>
>>
>>
>http://www.groupstudy.com/list/CCIELab.html
>
>############################################################
>
>Building
>
>
>>on 40 Years of Leadership - As a global communications leader with 40 years
>>of experience, Intelsat helps service providers,
>>
>>
>broadcasters, corporations
>
>
>>and governments deliver information and entertainment anywhere in the world,
>>instantly, securely and
>>reliably.
>>
>>
>
>############################################################
>This
>
>
>>email message is for the sole use of the intended
>>
>>
>recipient(s) and may
>
>
>>contain confidential and privileged
>>
>>
>information. Any unauthorized review,
>
>
>>use, disclosure or
>>
>>
>distribution is prohibited. If you are not the intended
>
>
>recipient, please contact the sender by reply email and
>destroy all copies
>
>
>>of the original message. Any views
>>
>>
>expressed in this message are those of
>
>
>>the individual
>>
>>
>sender, except where the sender specifically states them
>to
>
>
>>be the views of Intelsat, Ltd. and its
>>subsidiaries.
>>
>>
>############################################################
>
>_______________________________________________________________________
>Subscription
>
>
>>information may be found at:
>>
>>
>http://www.groupstudy.com/list/CCIELab.html
>
>_______________________________________________________________________
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sat Nov 06 2004 - 17:11:54 GMT-3