From: Roberto Adjakou (radjakou@cfao.sn)
Date: Tue Oct 26 2004 - 13:43:02 GMT-3
On R5 (callback client), u must habe "ppp callback request".
-----Message d'origine-----
De : Balogh, Jim [mailto:jim.balogh@gwl.com]
Envoyi : mardi 26 octobre 2004 14:50
@ : ccielab@groupstudy.com
Objet : Problem with ISDN Callin - Multiprotocol Challenge 'B'
I am working on Multiprotocol Challenge 'B from the IPexpert Workbook
6.0, and cannot seem to get my ISDN callin to work correctly.
With the config below, R5 is supposed to call R2 and disconnect. R2 is
then supposed to call R5 back. When I ping the remote end of the ISDN
connection, both R2 and R5 will successfully place ISDN calls. When R5
places a call to R2, the call is recognized as a ppp callin and
disconnected (as it should). R2 never calls R5 back though....any ideas
(debug ppp negotiation from R2 is below). On my debug ppp negotiation
from R5, I never see: Callback negotiated.
hostname r2
!
username r5 password cisco
!
interface BRI0
ip address 150.50.9.2 255.255.255.192
encapsulation ppp
ip ospf authentication
ip ospf authentication-key cisco
ip ospf demand-circuit
dialer map ip 150.50.9.5 name r5 class test broadcast xxxxxxxx
dialer map ip 150.50.9.5 name r5 class test broadcast yyyyyyyy
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 uuuuuuu
isdn spid2 vvvvvvv
ppp callback accept
ppp authentication chap
!
router ospf 1
router-id 200.0.0.2
log-adjacency-changes
area 0 authentication
network 150.50.9.2 0.0.0.0 area 0
distribute-list 5 in BRI0
!
map-class dialer test
dialer callback-server username
access-list 5 deny any
access-list 199 permit ip any any
dialer-list 1 protocol ip list 199
************************************************************************
*****************
hostname r5
!
username r2 password cisco
!
interface BRI0/0
ip address 150.50.9.5 255.255.255.192
encapsulation ppp
ip ospf authentication
ip ospf authentication-key cisco
ip ospf demand-circuit
dialer map ip 150.50.9.2 name r2 broadcast uuuuuuu
dialer map ip 150.50.9.2 name r2 broadcast vvvvvvv
dialer load-threshold 1 either
dialer-group 1
isdn switch-type basic-ni
isdn spid1 xxxxx
isdn spid2 yyyyy
ppp callback request
ppp authentication chap
!
router ospf 1
router-id 255.255.255.250
log-adjacency-changes
area 0 authentication
network 150.50.9.5 0.0.0.0 area 0
distribute-list 5 in BRI0/0
!
access-list 5 deny any
access-list 199 permit ip any any
dialer-list 1 protocol ip list 199
r2#sh isdn stat
Global ISDN Switchtype = basic-ni
ISDN BRI0 interface
dsl 0, interface ISDN Switchtype = basic-ni
Layer 1 Status:
ACTIVE
Layer 2 Status:
TEI = 64, Ces = 1, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI = 73, Ces = 2, SAPI = 0, State = MULTIPLE_FRAME_ESTABLISHED
TEI 64, ces = 1, state = 8(established)
spid1 configured, spid1 sent, spid1 valid
Endpoint ID Info: epsf = 0, usid = 0, tid = B
TEI 73, ces = 2, state = 8(established)
spid2 configured, spid2 sent, spid2 valid
Endpoint ID Info: epsf = 0, usid = 1, tid = B
Layer 3 Status:
0 Active Layer 3 Call(s)
Active dsl 0 CCBs = 0
The Free Channel Mask: 0x80000003
Total Allocated ISDN CCBs = 0
r2#
2d19h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to up
2d19h: BR0:1 PPP: Using dialer call direction
2d19h: BR0:1 PPP: Treating connection as a callin
2d19h: BR0:1 PPP: Phase is ESTABLISHING, Passive Open [0 sess, 0 load]
2d19h: BR0:1 LCP: State is Listen
2d19h: BR0:1 LCP: I CONFREQ [Listen] id 138 len 18
2d19h: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
2d19h: BR0:1 LCP: MagicNumber 0x5EFC44DD (0x05065EFC44DD)
2d19h: BR0:1 LCP: Callback 0 (0x0D0300)
2d19h: BR0:1 LCP: O CONFREQ [Listen] id 136 len 15
2d19h: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
2d19h: BR0:1 LCP: MagicNumber 0x1F01944C (0x05061F01944C)
2d19h: BR0:1 LCP: O CONFACK [Listen] id 138 len 18
2d19h: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
2d19h: BR0:1 LCP: MagicNumber 0x5EFC44DD (0x05065EFC44DD)
2d19h: BR0:1 LCP: Callback 0 (0x0D0300)
2d19h: BR0:1 LCP: I CONFACK [ACKsent] id 136 len 15
2d19h: BR0:1 LCP: AuthProto CHAP (0x0305C22305)
2d19h: BR0:1 LCP: MagicNumber 0x1F
r2#01944C (0x05061F01944C)
2d19h: BR0:1 LCP: State is Open
2d19h: BR0:1 PPP: Phase is AUTHENTICATING, by both [0 sess, 0 load]
2d19h: BR0:1 CHAP: O CHALLENGE id 136 len 23 from "r2"
2d19h: BR0:1 CHAP: I CHALLENGE id 136 len 23 from "r5"
2d19h: BR0:1 CHAP: Waiting for peer to authenticate first
2d19h: BR0:1 CHAP: I RESPONSE id 136 len 23 from "r5"
2d19h: BR0:1 CHAP: O SUCCESS id 136 len 4
2d19h: BR0:1 CHAP: Processing saved Challenge, id 136
2d19h: BR0:1 CHAP: O RESPONSE id 136 len 23 from "r2"
2d19h: %ISDN-6-CONNECT: Interface BRI0:1 is now connected to 7204935774
r5
2d19h: %LINK-3-UPDOWN: Interface BRI0:1, changed state to down
2d19h: BR0:1 PPP: Phase is TERMINATING [0 sess, 0 load]
2d19h: BR0:1 LCP: State is Closed
2d19h: BR0:1 PPP: Phase is DOWN [0 sess, 0 load]
r2#
This archive was generated by hypermail 2.1.4 : Sat Nov 06 2004 - 17:11:53 GMT-3