From: Art Lee (bahia111@comcast.net)
Date: Fri Oct 15 2004 - 18:06:44 GMT-3
Hello Gurus,
I have two back-to back routers (R4-peer & R5-dhcp server) connected
across ISDN (dialers). Cannot get the DHCP server to assign 1 address to
the peer. Here are my configs for R4 & R5 & the debug ppp negotiation
from R5:
R4
hostname Rack1R4
!
logging queue-limit 100
enable password cisco
!
username all
memory-size iomem 15
ip subnet-zero
!
!
no ip domain lookup
!
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
!
!
isdn switch-type basic-ni
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
ip address 150.1.4.4 255.255.255.0
!
interface Ethernet0/0
ip address 204.12.1.4 255.255.255.0
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay IETF
shutdown
frame-relay lmi-type cisco
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 0555100001 5551000
!
interface Ethernet0/1
ip address 139.1.48.4 255.255.255.0
half-duplex
!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
dialer idle-timeout 300
dialer string 5552000
dialer-group 1
!
router rip
version 2
network 139.1.0.0
network 150.1.0.0
no auto-summary
!
router bgp 100
synchronization
bgp router-id 150.1.4.4
bgp log-neighbor-changes
aggregate-address 139.1.0.0 255.255.0.0
neighbor 150.1.6.6 remote-as 100
neighbor 150.1.6.6 update-source Loopback0
neighbor 150.1.6.6 next-hop-self
neighbor 204.12.1.254 remote-as 54
neighbor 204.12.1.254 soft-reconfiguration inbound
no auto-summary
!
ip http server
no ip http secure-server
ip classless
ip route 139.1.7.0 255.255.255.0 150.1.5.5
ip route 150.1.7.0 255.255.255.0 150.1.5.5
!
!
!
access-list 100 deny udp any any eq rip
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
call rsvp-sync
R5
hostname Rack1R5
!
logging queue-limit 100
enable password cisco
!
memory-size iomem 15
ip subnet-zero
!
!
no ip domain lookup
ip dhcp excluded-address 139.1.45.0 139.1.45.3
ip dhcp excluded-address 139.1.45.5 139.1.45.255
!
ip dhcp pool FOR_R4
network 139.1.45.0 255.255.255.0
default-router 139.1.45.5
!
ip multicast-routing
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
!
!
isdn switch-type basic-ni
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
ip address 150.1.5.5 255.255.255.0
!
interface Ethernet0/0
ip address 139.6.5.5 255.255.255.0
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay
no fair-queue
no frame-relay inverse-arp
frame-relay lmi-type cisco
!
interface Serial0/0.501 multipoint
ip address 139.1.15.5 255.255.255.0
ip router isis
frame-relay map clns 501 broadcast
frame-relay map ip 139.1.15.1 501 broadcast
!
interface Serial0/0.502 multipoint
ip address 139.1.25.5 255.255.255.0
ip router isis
frame-relay map clns 502 broadcast
frame-relay map ip 139.1.25.2 502 broadcast
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 0555200001 5552000
!
interface Ethernet0/1
ip address 139.1.58.5 255.255.255.0
half-duplex
!
interface Dialer1
ip address 139.1.45.5 255.255.255.0
encapsulation ppp
dialer pool 1
dialer idle-timeout 300
dialer string 5551000
dialer-group 1
no peer default ip address
!
router isis
net 49.0125.0001.0001.0005.00
is-type level-1
redistribute rip level-1
passive-interface Loopback0
passive-interface Ethernet0/0
!
router rip
version 2
redistribute connected
redistribute isis level-1 metric 1
network 139.1.0.0
network 150.1.0.0
no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
!
!
access-list 100 deny udp any any eq rip
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100
!
!
call rsvp-sync
Debug PPP Negotiation from R5 w/ isdn test call int b0/0 5551000
Rack1R5#sh debu
PPP:
PPP protocol negotiation debugging is on
DHCP server packet debugging is on.
DHCP server event debugging is on.
Rack1R5#
*Mar 1 14:08:13.624: DHCPD: checking for expired leases.
Rack1R5#isdn test call int b0/0 5551000
Rack1R5#
*Mar 1 14:08:28.616: %LINK-3-UPDOWN: Interface BRI0/0:1, changed state
to up
*Mar 1 14:08:28.620: BR0/0:1 PPP: Using dialer call direction
*Mar 1 14:08:28.620: BR0/0:1 PPP: Treating connection as a callout
*Mar 1 14:08:28.620: BR0/0:1 PPP: Phase is ESTABLISHING, Active Open
*Mar 1 14:08:28.624: BR0/0:1 PPP: No remote authentication for call-out
*Mar 1 14:08:28.624: BR0/0:1 LCP: O CONFREQ [Closed] id 32 len 10
*Mar 1 14:08:28.624: BR0/0:1 LCP: MagicNumber 0x1384994A
(0x05061384994A)
*Mar 1 14:08:28.632: BR0/0:1 LCP: I CONFREQ [REQsent] id 21 len 10
*Mar 1 14:08:28.632: BR0/0:1 LCP: MagicNumber 0x095C3516
(0x0506095C3516)
*Mar 1 14:08:28.632: BR0/0:1 LCP: O CONFACK [REQsent] id 21 len 10
*Mar 1 14:08:28.632: BR0/0:1 LCP: MagicNumber 0x095C3516
(0x0506095C3516)
*Mar 1 14:08:28.636: BR0/0:1 LCP: I CONFACK [ACKsent] id 32 len 10
*Mar 1 14:08:28.636: BR0/0:1 LCP: MagicNumber 0x1384994A
(0x05061384994A)
Rack1R5#14:08:28.636: BR0/0:1 LCP: State is Open
*Mar 1 14:08:28.636: BR0/0:1 PPP: Phase is FORWARDING, Attempting Forward
*Mar 1 14:08:28.636: BR0/0:1 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 1 14:08:28.636: BR0/0:1 PPP: Phase is UP
*Mar 1 14:08:28.640: BR0/0:1 CDPCP: O CONFREQ [Closed] id 1 len 4
*Mar 1 14:08:28.640: BR0/0:1 PPP: Process pending packets
*Mar 1 14:08:28.644: BR0/0:1 IPCP: I CONFREQ [Not negotiated] id 1 len 10
*Mar 1 14:08:28.644: BR0/0:1 IPCP: Address 0.0.0.0 (0x030600000000)
*Mar 1 14:08:28.644: BR0/0:1 LCP: O PROTREJ [Open] id 33 len 16
protocol IPCP (0x80210101000A030600000000)
*Mar 1 14:08:28.648: BR0/0:1 CDPCP: I CONFREQ [REQsent] id 1 len 4
*Mar 1 14:08:28.648: BR0/0:1 CDPCP: O CONFACK [REQsent] id 1 len 4
*Mar 1 14:08:28.648: BR0/0:1 CDPCP: I CONFACK [ACKsent] id 1 len 4
*Mar 1 14:08:28.648: BR0/0:1 CDPCP: State is Open
Rack1R5#
*Mar 1 14:08:29.636: %LINEPROTO-5-UPDOWN: Line protocol on Interface
BRI0/0:1, changed state to up
Rack1R5#
*Mar 1 14:08:34.620: %ISDN-6-CONNECT: Interface BRI0/0:1 is now
connected to 5551000
Rack1R5#ping 139.1.45.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 139.1.45.4, timeout is 2 seconds:
*Mar 1 14:08:51.416: %LINK-3-UPDOWN: Interface BRI0/0:2, changed state
to up
*Mar 1 14:08:51.416: %DIALER-6-BIND: Interface BR0/0:2 bound to profile Di1
*Mar 1 14:08:51.420: BR0/0:2 PPP: Using dialer call direction
*Mar 1 14:08:51.420: BR0/0:2 PPP: Treating connection as a callout
*Mar 1 14:08:51.420: BR0/0:2 PPP: Phase is ESTABLISHING, Active Open
*Mar 1 14:08:51.420: BR0/0:2 PPP: No remote authentication for call-out
*Mar 1 14:08:51.420: BR0/0:2 LCP: O CONFREQ [Closed] id 3 len 10
*Mar 1 14:08:51.420: BR0/0:2 LCP: MagicNumber 0x1384F25B
(0x05061384F25B)
*Mar 1 14:08:51.428: BR0/0:2 LCP: I CONFREQ [REQsent] id 3 len 10
*Mar 1 14:08:51.432: BR0/0:2 LCP: MagicNumber 0x095C8E27
(0x0506095C8E27)
*Mar 1 14:08:51.432: BR0/0:2 LCP: O CONFACK [REQsent] id 3 len 10
*Mar 1 14:08:51.432: BR0/0:2 LCP: MagicNumber 0x095C8E27
(0x0506095C8E27)
*Mar 1 14:08:51.432: BR0/0:2 LCP: I CONFACK [ACKsent] id 3 len 10
*Mar 1 14:08:51.432: BR0/0:2 LCP: MagicNumber 0x13.U84F25B
(0x05061384F25B)
*Mar 1 14:08:51.432: BR0/0:2 LCP: State is Open
*Mar 1 14:08:51.432: BR0/0:2 PPP: Phase is FORWARDING, Attempting Forward
*Mar 1 14:08:51.436: BR0/0:2 PPP: Phase is ESTABLISHING, Finish LCP
*Mar 1 14:08:51.436: BR0/0:2 PPP: Phase is UP
*Mar 1 14:08:51.436: BR0/0:2 IPCP: O CONFREQ [Closed] id 1 len 10
*Mar 1 14:08:51.436: BR0/0:2 IPCP: Address 139.1.45.5 (0x03068B012D05)
*Mar 1 14:08:51.436: BR0/0:2 CDPCP: O CONFREQ [Closed] id 1 len 4
*Mar 1 14:08:51.436: BR0/0:2 PPP: Process pending packets
*Mar 1 14:08:51.444: BR0/0:2 IPCP: I CONFREQ [REQsent] id 1 len 10
*Mar 1 14:08:51.444: BR0/0:2 IPCP: Address 0.0.0.0 (0x030600000000)
*Mar 1 14:08:51.444: BR0/0:2 IPCP: No peer address configured
*Mar 1 14:08:51.444: BR0/0:2 IPCP: Neither side knows remote address
*Mar 1 14:08:51.444: BR0/0:2 IPCP: O CONFREJ [REQsent] id 1 len 10
*Mar 1 14:08:51.444: BR0/0:2 IPCP: Address 0.0.0.0 (0x030600000000)
*Mar 1 14:08:51.444: BR0/0:2 CDPCP: I CONFREQ [REQsent] id 1 len 4
*Mar 1 14:08:51.444: BR0/0:2 CDPCP: O CONFACK [REQsent] id 1 len 4
*Mar 1 14:08:51.448: BR0/0:2 IPCP: I CONFACK [REQsent] id 1 len 10
*Mar 1 14:08:51.448: BR0/0:2 IPCP: Address 139.1.45.5 (0x03068B012D05)
*Mar 1 14:08:51.448: BR0/0:2 CDPCP: I CONFACK [ACKsent] id 1 len 4
*Mar 1 14:08:51.448: BR0/0:2 CDPCP: State is Open
*Mar 1 14:08:51.452: BR0/0:2 IPCP: I CONFREQ [ACKrcvd] id 2 len 4
*Mar 1 14:08:51.452: BR0/0:2 IPCP: O CONFACK [ACKrcvd] id 2 len 4
*Mar 1 14:08:51.452: BR0/0:2 IPCP: State is Open
*Mar 1 14:08:52.436: %LINEPROTO-5-UPDOWN: Line protocol on Interface
BRI0/0:2, changed state to up.U.
Success rate is 0 percent (0/5)
Rack1R5#
*Mar 1 14:08:57.416: %ISDN-6-CONNECT: Interface BRI0/0:2 is now
connected to 5551000
Rack1R5#ping 139.1.45.4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 139.1.45.4, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
As you can see R4 is sending the request for IPCP address to R5, but R5
is acting like it isn't a server (No DHCPOFFER pacs to R4). What could
this be???
-- *********************** Art Lee bahia111@comcast.net Digital Pixels
This archive was generated by hypermail 2.1.4 : Sat Nov 06 2004 - 17:11:48 GMT-3