RE: isis never-set-attached-bit hidden command

From: "Hoonpongsimanont
Date: Fri Oct 08 2004 - 12:04:40 GMT-3


Hello Sameh,

Thanks a lot. It does help!

R7 Configuration
!
router isis
 net 47.0007.7777.7777.7777.00
 set-attached-bit route-map set-att
 redistribute isis ip level-2 into level-1 distribute-list 100
 passive-interface Loopback0
!
route-map set-att deny 10
!

On R5,
r5#show isis database

IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r5.00-00 * 0x00000011 0xB160 358 0/0/0
r7.00-00 0x00000019 0x73DD 1056 0/0/0 <-
r7.01-00 0x0000000E 0x0CA3 852 0/0/0
r5#show ip route isis
     150.50.0.0/16 is variably subnetted, 19 subnets, 3 masks
i L1 150.50.60.0/24 [115/20] via 150.50.50.7, FastEthernet0/0
i ia 150.50.4.0/24 [115/158] via 150.50.50.7, FastEthernet0/0
i ia 150.50.8.8/32 [115/148] via 150.50.50.7, FastEthernet0/0
i L1 150.50.7.7/32 [115/10] via 150.50.50.7, FastEthernet0/0
i L1 150.50.101.0/30 [115/20] via 150.50.50.7, FastEthernet0/0

Anyway, I have another problem with IS-IS redistribution into OSPF. On this
R5, I redistribute IS-IS into OSPF.

r5#show run | be router ospf 1
router ospf 1
 router-id 150.50.5.5
 log-adjacency-changes
 redistribute isis level-1-2 metric 10000 subnets tag 100
 network 150.50.5.5 0.0.0.0 area 0
 network 150.50.100.0 0.0.0.255 area 0
 network 150.50.101.4 0.0.0.3 area 0
 distance 120 0.0.0.0 255.255.255.255 1
!
router isis
 net 47.0007.5555.5555.5555.00
 is-type level-1
!
r5#show isis database detail

IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
r5.00-00 * 0x00000012 0xAF61 1101 0/0/0
  Area Address: 47.0007
  NLPID: 0xCC
  Hostname: r5
  IP Address: 150.50.50.5
  Metric: 10 IP 150.50.50.0 255.255.255.0
  Metric: 10 IS r7.01
r7.00-00 0x00000019 0x73DD 954 0/0/0
  Area Address: 47.0007
  NLPID: 0xCC
  Hostname: r7
  IP Address: 150.50.7.7
  Metric: 10 IP 150.50.50.0 255.255.255.0
  Metric: 10 IP 150.50.60.0 255.255.255.0
  Metric: 10 IP 150.50.101.0 255.255.255.252
  Metric: 0 IP 150.50.7.7 255.255.255.255
  Metric: 10 IS r7.01
  Metric: 148 IP-Interarea 150.50.4.0 255.255.255.0
  Metric: 138 IP-Interarea 150.50.8.8 255.255.255.255
  Metric: 138 IP-Interarea 150.50.6.6 255.255.255.255
r7.01-00 0x0000000E 0x0CA3 749 0/0/0
  Metric: 0 IS r7.00
  Metric: 0 IS r5.00
r5#show ip route isis
     150.50.0.0/16 is variably subnetted, 19 subnets, 3 masks
i L1 150.50.60.0/24 [115/20] via 150.50.50.7, FastEthernet0/0
i ia 150.50.4.0/24 [115/158] via 150.50.50.7, FastEthernet0/0
i ia 150.50.8.8/32 [115/148] via 150.50.50.7, FastEthernet0/0
i L1 150.50.7.7/32 [115/10] via 150.50.50.7, FastEthernet0/0
i L1 150.50.101.0/30 [115/20] via 150.50.50.7, FastEthernet0/0

r5#show ip ospf database | be External
                Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
150.50.6.6 150.50.6.6 961 0x80000006 0x0034BD 0
150.50.7.7 150.50.5.5 315 0x80000004 0x0077F4 100 <- ISIS
150.50.60.0 150.50.5.5 315 0x80000004 0x0074C9 100 <- ISIS
150.50.101.0 150.50.5.5 315 0x80000004 0x009D7A 100 <- ISIS
150.50.200.0 150.50.2.2 888 0x80000006 0x00343E 0
192.168.1.0 150.50.2.2 888 0x80000006 0x001881 0
192.168.2.0 150.50.2.2 888 0x80000006 0x000D8B 0
192.168.3.0 150.50.2.2 888 0x80000006 0x000295 0
192.168.4.0 150.50.2.2 888 0x80000006 0x00F69F 0

It looks like Inter Area route in ISIS will not be redistributed into other
routing protocols. This looks like another ISIS behavior that needs to
redistribute connected interface. However, these routes are not connected,
but learned routes. Any idea how to get these inter area routes into OSPF?
Thanks again ..

Cheers,
David

-----Original Message-----
From: eltawil@free.fr [mailto:eltawil@free.fr]
Sent: Friday, October 08, 2004 9:23 PM
To: Hoonpongsimanont, Chalermchai
Cc: ccielab@groupstudy.com
Subject: Re: isis never-set-attached-bit hidden command

David,

You can conditionally set the attached bit using the command
"set-attached-bit
<route-map>" The route map is used the same way you use a route map to
conditionally advertise a default route with the "default-information
originate".

Hope this helps,

Cheers,
Sameh

Selon "Hoonpongsimanont, Chalermchai"
<chalermchai.hoonpongsimanont@atosorigin.com>:

> Hi Folks,
>
>
>
> I have a problem when trying to filter default route on ISIS Level 1
router.
>
>
>
>
> R5 (L1) --- R7 (L1/L2)
>
>
>
> On R5,
>
>
>
> r5#show isis database
>
>
>
> IS-IS Level-1 Link State Database:
>
> LSPID LSP Seq Num LSP Checksum LSP Holdtime
ATT/P/OL
>
> r5.00-00 * 0x00000009 0xC158 661 0/0/0
>
> r7.00-00 0x0000000F 0x8FC3 1192 1/0/0
<-
> ATT Set to 1
>
> r7.01-00 0x00000005 0x1E9A 660 0/0/0
>
>
>
> r5#sh ip route isis
>
> 150.50.0.0/16 is variably subnetted, 19 subnets, 3 masks
>
> i L1 150.50.60.0/24 [115/20] via 150.50.50.7, FastEthernet0/0
>
> i ia 150.50.4.0/24 [115/158] via 150.50.50.7, FastEthernet0/0
>
> i ia 150.50.8.8/32 [115/148] via 150.50.50.7, FastEthernet0/0
>
> i L1 150.50.7.7/32 [115/10] via 150.50.50.7, FastEthernet0/0
>
> i L1 150.50.101.0/30 [115/20] via 150.50.50.7, FastEthernet0/0
>
> i*L1 0.0.0.0/0 [115/10] via 150.50.50.7, FastEthernet0/0
>
>
>
> R7 Configuration
>
> !
>
> router isis
>
> net 47.0007.7777.7777.7777.00
>
> redistribute isis ip level-2 into level-1 distribute-list 100
>
> passive-interface Loopback0
>
> !
>
>
>
> I don't want this default route to show up on R5. The only one way I found
> is configuring hidden command "never-set-attached-bit" under router isis
of
> R7, and it's working fine.
>
>
>
> R7 Configuration
>
> !
>
> router isis
>
> net 47.0007.7777.7777.7777.00
>
> never-set-attached-bit
>
> redistribute isis ip level-2 into level-1 distribute-list 100
>
> passive-interface Loopback0
>
> !
>
>
>
> On R5,
>
> r5#show isis database
>
>
>
> IS-IS Level-1 Link State Database:
>
> LSPID LSP Seq Num LSP Checksum LSP Holdtime
ATT/P/OL
>
> r5.00-00 * 0x00000009 0xC158 431 0/0/0
>
> r7.00-00 0x00000010 0x85D4 1153 0/0/0
<-
> ATT Set to 0
>
> r7.01-00 0x00000006 0x1C9B 1166 0/0/0
>
> r5#show ip route isis
>
> 150.50.0.0/16 is variably subnetted, 19 subnets, 3 masks
>
> i L1 150.50.60.0/24 [115/20] via 150.50.50.7, FastEthernet0/0
>
> i ia 150.50.4.0/24 [115/158] via 150.50.50.7, FastEthernet0/0
>
> i ia 150.50.8.8/32 [115/148] via 150.50.50.7, FastEthernet0/0
>
> i L1 150.50.7.7/32 [115/10] via 150.50.50.7, FastEthernet0/0
>
> i L1 150.50.101.0/30 [115/20] via 150.50.50.7, FastEthernet0/0
>
> <- Default route is gone ->
>
>
>
> I don't think I will get the point when using hidden command in real lab.
Is
> there any other way to do this kind of thing? Thanks in advance.
>
>
>
> Cheers,
>
> David
>
> _______________________________________________________________________
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Nov 06 2004 - 17:11:45 GMT-3