Re: DLSW+ over Frame

From: alsontra@hotmail.com
Date: Sun Aug 15 2004 - 14:25:42 GMT-3


Richard,
A while back, I started defining ports attached to DLSW peers as follows:

!
interface FastEthernet0/10
 switchport mode access
 switchport nonegotiate
 spanning-tree bpdufilter enable
or
span bpduguard enable
!

I've never disable BPDU's on the bridge-group itself. Keeping in mind that
both methods pretty much do the same thing, do you see an advantage to using
either method?

Thanks,
Alsontra

----- Original Message -----
From: "Richard Dumoulin" <richard.dumoulin@vanco.es>
To: "Jesse Loggins" <jlogginsccie@san.rr.com>
Cc: <ccielab@groupstudy.com>
Sent: Sunday, August 15, 2004 2:15 AM
Subject: RE: DLSW+ over Frame

> You had the switch port in dynamic desirable mode so when enabling
> "bridge-group 1" on the router it starting to send BPDUs. So the switch
> tried to negociate a trunk ,
>
> --Richard
>
> -----Original Message-----
> From: Jesse Loggins [mailto:jlogginsccie@san.rr.com]
> Sent: domingo, 15 de agosto de 2004 4:49
> To: Richard Dumoulin
> Cc: ccielab@groupstudy.com
> Subject: Re: DLSW+ over Frame
>
>
> Thanks hardcoding switchport mode access solved the issue. Now can you (or
> someone) explain why?
>
>
>
> On Saturday 14 August 2004 02:41, Richard Dumoulin wrote:
> > Hardcode "switchport mode access" on the ports of the catalyst. Also,
> > do you have bpduguard or filter on any of the ports ? If yes then you
> > can disable spanning-tree on the ethernet interfaces of the routers
> > with "bridge-group 1 spanning-tree disable",
> >
> > --Richard
> >
> > -----Original Message-----
> > From: jlogginsccie@san.rr.com [mailto:jlogginsccie@san.rr.com]
> > Sent: sabado, 14 de agosto de 2004 1:07
> > To: ccielab@groupstudy.com; jlogginsccie@san.rr.com
> > Subject: DLSW+ over Frame
> >
> >
> > R1-e0------e0-R2s0-------Frame-----s0---R5e0
> >
> > I am doing a lab set up as above. DLSW is running between R2 and R5.
> > R2 is set to Promiscuous mode R5 has a static peer statement pointing
> > to R2. The DLSW transport is TCP. R2 is running BGP with R1 and R5 is
> > running OSPF and BGP over its e0 interface with 2 other routers. The
> > issue that I am facing is that when I put R0s Ethernet interface
> > and/or R5s Ethernet interface into the DLSW bridge group and a dlsw
> > connection is established I loose all routing functions over the
> > Ethernet interfaces. Thus I loose my BGP and OSPF peering. I also see
> > the peering sessions (BGP/OSPF) going up and down over time. Has
> > anyone seen a similar issue to this?
> >
> > the configs are as follows:
> >
> > R2
> >
> > hostname r2
> >
> > !
> >
> > !
> >
> > username r5 password 0 ipexpert
> >
> > ip subnet-zero
> >
> > !
> >
> > ip multicast-routing
> >
> > frame-relay de-list 1 interface Ethernet0
> >
> > isdn switch-type basic-net3
> >
> > !
> >
> > !
> >
> > dlsw local-peer peer-id 150.50.2.2 promiscuous
> >
> > dlsw bridge-group 1
> >
> > !
> >
> > interface Loopback0
> >
> > ip address 150.50.2.2 255.255.255.255
> >
> > ip pim sparse-dense-mode
> >
> > !
> >
> > interface Loopback1
> >
> > no ip address
> >
> > !
> >
> > interface Ethernet0
> >
> > ip address 150.50.12.2 255.255.255.0
> >
> > bridge-group 1
> >
> > !
> >
> > interface Serial0
> >
> > ip address 150.50.10.2 255.255.255.0
> >
> > ip pim nbma-mode
> >
> > ip pim sparse-dense-mode
> >
> > encapsulation frame-relay
> >
> > ip ospf priority 10
> >
> > frame-relay de-group 1 204
> >
> > frame-relay de-group 1 205
> >
> > frame-relay de-group 1 206
> >
> > frame-relay map ip 150.50.10.2 204 broadcast
> >
> > frame-relay map ip 150.50.10.4 204 broadcast
> >
> > frame-relay map ip 150.50.10.5 205 broadcast
> >
> > frame-relay map ip 150.50.10.6 206 broadcast
> >
> > no frame-relay inverse-arp
> >
> > frame-relay lmi-type cisco
> >
> > !
> >
> > interface Serial1
> >
> > no ip address
> >
> > shutdown
> >
> > !
> >
> > interface BRI0
> >
> > ip address 150.50.9.6 255.255.255.252
> >
> > encapsulation ppp
> >
> > dialer map ip 150.50.9.5 name r2 broadcast 5552221
> >
> > dialer load-threshold 1 outbound
> >
> > dialer-group 1
> >
> > isdn switch-type basic-net3
> >
> > ppp authentication pap
> >
> > ppp pap sent-username hub password 0 ipexpert
> >
> > ppp multilink
> >
> > !
> >
> > router ospf 1
> >
> > log-adjacency-changes
> >
> > area 1 nssa default-information-originate
> >
> > redistribute connected subnets route-map connect2ospf
> >
> > network 150.50.9.4 0.0.0.3 area 0
> >
> > network 150.50.10.0 0.0.0.255 area 0
> >
> > network 150.50.12.0 0.0.0.255 area 1
> >
> > neighbor 150.50.10.6
> >
> > neighbor 150.50.10.5
> >
> > neighbor 150.50.10.4
> >
> > default-metric 20
> >
> > !
> >
> > router bgp 200
> >
> > bgp log-neighbor-changes
> >
> > neighbor 150.50.1.1 remote-as 8888
> >
> > neighbor 150.50.1.1 ebgp-multihop 3
> >
> > neighbor 150.50.1.1 update-source Loopback0
> >
> > neighbor 150.50.4.4 remote-as 200
> >
> > neighbor 150.50.4.4 update-source Loopback0
> >
> > neighbor 150.50.4.4 route-reflector-client
> >
> > neighbor 150.50.5.5 remote-as 200
> >
> > neighbor 150.50.5.5 update-source Loopback0
> >
> > neighbor 150.50.5.5 route-reflector-client
> >
> > neighbor 150.50.6.6 remote-as 200
> >
> > neighbor 150.50.6.6 update-source Loopback0
> >
> > neighbor 150.50.6.6 route-reflector-client
> >
> > !
> >
> > ip classless
> >
> > ip http server
> >
> > ip pim send-rp-announce Loopback0 scope 5
> >
> > ip pim send-rp-discovery Loopback0 scope 5
> >
> > !
> >
> > access-list 1 permit 150.50.2.2
> >
> > access-list 10 permit 233.0.0.1
> >
> > dialer-list 1 protocol ip permit
> >
> > route-map connect2ospf permit 10
> >
> > match ip address 1
> >
> > !
> >
> > !
> >
> > bridge 1 protocol ieee
> >
> > !
> >
> > line con 0
> >
> > exec-timeout 0 0
> >
> > logging synchronous
> >
> > line aux 0
> >
> > line vty 0 4
> >
> > password ipexpert
> >
> > logging synchronous
> >
> > login
> >
> > !
> >
> > End
> >
> > r2#show int e0 irb
> >
> > Ethernet0
> >
> > Routed protocols on Ethernet0:
> >
> > ip
> >
> > Bridged protocols on Ethernet0:
> >
> > appletalk clns decnet vines
> >
> > apollo xns
> >
> > Software MAC address filter on Ethernet0
> >
> > Hash Len Address Matches Act Type
> >
> > 0x00: 0 ffff.ffff.ffff 0 RCV Physical broadcast
> >
> > 0x2A: 0 0900.2b01.0001 0 RCV DEC spanning tree
> >
> > 0x58: 0 0100.5e00.0006 0 RCV IP multicast
> >
> > 0x5B: 0 0100.5e00.0005 158 RCV IP multicast
> >
> > 0x6B: 0 0000.0c3b.dc67 85 RCV Interface MAC address
> >
> > 0xC0: 0 0100.0ccc.cccc 92 RCV CDP
> >
> > 0xC2: 0 0180.c200.0000 9 RCV IEEE spanning tree
> >
> > 0xC2: 1 0180.c200.0000 0 RCV IBM spanning tree
> >
> > 0xC2: 2 0100.0ccd.cdce 0 RCV VLAN Bridge STP
> >
> > ---------------------------------------------------------------------
> > -----------------------------------------------------
> >
> > R5
> >
> > hostname r5
> >
> > !
> >
> > !
> >
> > username hub password 0 ipexpert
> >
> > ip subnet-zero
> >
> > !
> >
> > ip multicast-routing
> >
> > isdn switch-type basic-net3
> >
> > !
> >
> > !
> >
> > dlsw local-peer peer-id 150.50.5.5
> >
> > dlsw remote-peer 0 tcp 150.50.2.2
> >
> > dlsw bridge-group 1
> >
> > !
> >
> > interface Loopback0
> >
> > ip address 150.50.5.5 255.255.255.255
> >
> > !
> >
> > interface Ethernet0
> >
> > ip address 150.50.100.5 255.255.255.128
> >
> > ip pim sparse-dense-mode
> >
> > ip igmp helper-address 150.50.2.2
> >
> > ip igmp join-group 233.0.0.1
> >
> > standby 1 ip 150.50.100.10
> >
> > standby 1 priority 110
> >
> > standby 1 preempt
> >
> > standby 1 mac-address aaaa.aaaa.aaaa
> >
> > standby 1 track Serial0 15
> >
> > bridge-group 1
> >
> > !
> >
> > interface Serial0
> >
> > backup delay 10 300
> >
> > backup interface BRI0
> >
> > ip address 150.50.10.5 255.255.255.0
> >
> > ip pim sparse-dense-mode
> >
> > encapsulation frame-relay
> >
> > ip ospf network point-to-multipoint
> >
> > ip ospf priority 0
> >
> > frame-relay map ip 150.50.10.2 502 broadcast
> >
> > frame-relay map ip 150.50.10.4 502 broadcast
> >
> > frame-relay map ip 150.50.10.5 502 broadcast
> >
> > frame-relay map ip 150.50.10.6 502 broadcast
> >
> > no frame-relay inverse-arp
> >
> > frame-relay lmi-type cisco
> >
> > !
> >
> > interface Serial1
> >
> > no ip address
> >
> > shutdown
> >
> > !
> >
> > interface BRI0
> >
> > ip address 150.50.9.5 255.255.255.252
> >
> > encapsulation ppp
> >
> > dialer idle-timeout 90
> >
> > dialer map ip 150.50.9.6 name hub broadcast 5551111
> >
> > dialer load-threshold 1 outbound
> >
> > dialer-group 1
> >
> > isdn switch-type basic-net3
> >
> > ppp authentication pap
> >
> > ppp pap sent-username r5 password 0 ipexpert
> >
> > ppp multilink
> >
> > !
> >
> > router ospf 1
> >
> > log-adjacency-changes
> >
> > area 100 virtual-link 150.50.7.7
> >
> > redistribute connected subnets route-map connect2ospf
> >
> > network 150.50.9.4 0.0.0.3 area 0
> >
> > network 150.50.10.0 0.0.0.255 area 0
> >
> > network 150.50.100.0 0.0.0.127 area 100
> >
> > default-metric 20
> >
> > !
> >
> > router bgp 200
> >
> > no synchronization
> >
> > bgp log-neighbor-changes
> >
> > neighbor 150.50.2.2 remote-as 200
> >
> > neighbor 150.50.2.2 update-source Loopback0
> >
> > neighbor 150.50.8.8 remote-as 800
> >
> > neighbor 150.50.8.8 ebgp-multihop 5
> >
> > neighbor 150.50.8.8 update-source Loopback0
> >
> > neighbor 150.50.8.8 send-community
> >
> > neighbor 150.50.8.8 route-map bgpout out
> >
> > !
> >
> > ip classless
> >
> > ip http server
> >
> > !
> >
> > access-list 1 permit 150.50.5.5
> >
> > access-list 11 permit 172.16.1.0 0.0.0.255
> >
> > access-list 101 permit ip any 224.0.0.0 0.255.255.255
> >
> > access-list 101 permit ip 224.0.0.0 0.255.255.255 any
> >
> > dialer-list 1 protocol ip permit
> >
> > route-map bgpout permit 10
> >
> > match ip address 11
> >
> > set community no-export
> >
> > !
> >
> > route-map bgpout permit 20
> >
> > !
> >
> > route-map connect2ospf permit 10
> >
> > match ip address 1
> >
> > !
> >
> > !
> >
> > bridge 1 protocol ieee
> >
> > !
> >
> > line con 0
> >
> > exec-timeout 0 0
> >
> > logging synchronous
> >
> > line aux 0
> >
> > line vty 0 4
> >
> > password ipexpert
> >
> > logging synchronous
> >
> > login
> >
> > !
> >
> > End
> >
> > r5#show int e0 irb
> >
> > Ethernet0
> >
> > Routed protocols on Ethernet0:
> >
> > ip
> >
> > Bridged protocols on Ethernet0:
> >
> > appletalk clns decnet vines
> >
> > apollo xns
> >
> > Software MAC address filter on Ethernet0
> >
> > Hash Len Address Matches Act Type
> >
> > 0x00: 0 aaaa.aaaa.aaaa 201 RCV Interface MAC address
> >
> > 0x00: 1 ffff.ffff.ffff 6 RCV Physical broadcast
> >
> > 0x2A: 0 0900.2b01.0001 0 RCV DEC spanning tree
> >
> > 0xC0: 0 0100.0ccc.cccc 53 RCV CDP
> >
> > 0xC2: 0 0180.c200.0000 10 RCV IEEE spanning tree
> >
> > 0xC2: 1 0180.c200.0000 0 RCV IBM spanning tree
> >
> > 0xC2: 2 0100.0ccd.cdce 0 RCV VLAN Bridge STP
> >
> > ______________________________________________________________________
> > _
> > Please help support GroupStudy by purchasing your study materials from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> > **********************************************************************
> > Any opinions expressed in the email are those of the individual and
> > not necessarily the company. This email and any files transmitted with
> > it are confidential and solely for the use of the intended recipient.
> > If you are not the intended recipient or the person responsible for
> > delivering it to the intended recipient, be advised that you have
> > received this email in error and that any dissemination, distribution,
> > copying or use is strictly prohibited.
> >
> > If you have received this email in error, or if you are concerned with
> > the content of this email please e-mail to:
> > e-security.support@vanco.info
> >
> > The contents of an attachment to this e-mail may contain software
> > viruses which could damage your own computer system. While the sender
> > has taken every reasonable precaution to minimise this risk, we cannot
> > accept liability for any damage which you sustain as a result of
> > software viruses. You should carry out your own virus checks before
> > opening any attachments to this e-mail.
> > **********************************************************************
>
> _______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Fri Sep 03 2004 - 07:02:44 GMT-3