Re: TCL scripts

From: Joseph D. Phillips (josephdphillips@fastmail.us)
Date: Sun Jul 25 2004 - 18:16:02 GMT-3


OK, thanks!

----- Original Message -----
From: "Dan Shechter" <danshtr@yahoo.com>
To: "Joseph D. Phillips" <josephdphillips@fastmail.us>
Sent: Sunday, July 25, 2004 2:05 PM
Subject: Re: TCL scripts

> I think that pinging from ALL interfaces is not needed if the
> topology and the redistribution asked in the lab can't for loops.
>
> If you have a net like this:
>
> R1---RIP2---R2---EIGRP---R3
>
> what the point in pinging from any interface?
>
> So before you start to do crazy scripts, check if it is actually
> needed.
>
>
> --- "Joseph D. Phillips" <josephdphillips@fastmail.us> wrote:
> > I used a TCL script once. It's hard to remember for the exam.
> >
> > Assuming I could, should I ping every interface from every
> > interface? Is
> > that what you want a TCL script to do?
> >
> >
> > On Sun, 25 Jul 2004 16:14:30 -0400, "Brian Dennis"
> > <bdennis@internetworkexpert.com> said:
> > > You can use this for now. It's not perfect but it'll get the job
> > done
> > > for most situations ;-)
> > >
> > > Rack1R4#tclsh
> > > Rack1R4(tcl)#proc srp {protocol} {
> > > +> exec "term len 0"
> > > +> set output [exec "sho run | begin (^router $protocol)"]
> > > +> set end [lsearch $output !]
> > > +> puts [lrange $output 0 $end]
> > > +>}
> > >
> > > Rack1R4(tcl)#srp ospf
> > > router ospf 1
> > > router-id 150.1.4.4
> > > log-adjacency-changes
> > > area 0 authentication message-digest
> > > redistribute static subnets
> > > passive-interface default
> > > no passive-interface Ethernet0/0
> > > no passive-interface BRI0/0
> > > no passive-interface Serial0/0.34
> > > network 150.1.4.0 0.0.0.255 area 0
> > > network 191.1.34.0 0.0.0.255 area 0
> > > network 191.1.45.0 0.0.0.127 area 0
> > > network 191.1.114.0 0.0.0.255 area 0
> > > !
> > >
> > > Rack1R4#srp eigrp
> > > router eigrp 1
> > > network 10.255.255.0 0.0.0.255
> > > auto-summary
> > > !
> > >
> > > Rack1R4#
> > >
> > > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> > > bdennis@internetworkexpert.com
> > > Internetwork Expert, Inc.
> > > http://www.InternetworkExpert.com
> > > Toll Free: 877-224-8987
> > > Direct: 775-745-6404 (Outside the US and Canada)
> > >
> > >
> > > -----Original Message-----
> > > From: Joseph D. Phillips [mailto:josephdphillips@fastmail.us]
> > > Sent: Sunday, July 25, 2004 12:38 PM
> > > To: Brian Dennis; Tim Fletcher
> > > Cc: group study
> > > Subject: RE: Refining output of show running-config
> > >
> > > Fabulous. That will really help!
> > >
> > > Thanks again.
> > >
> > > On Sun, 25 Jul 2004 15:32:54 -0400, "Brian Dennis"
> > > <bdennis@internetworkexpert.com> said:
> > > > Officially released in 12.3(2)T.
> > > >
> > > > Show Command Section Filter
> > > >
> > >
> >
> http://www.cisco.com/en/US/products/sw/iosswrel/ps5207/products_feature_
> > > > guide09186a00801a7a94.html
> > > >
> > > > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> > > > bdennis@internetworkexpert.com
> > > > Internetwork Expert, Inc.
> > > > http://www.InternetworkExpert.com
> > > > Toll Free: 877-224-8987
> > > > Direct: 775-745-6404 (Outside the US and Canada)
> > > >
> > > >
> > > > -----Original Message-----
> > > > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On
> > Behalf
> > > Of
> > > > Joseph D. Phillips
> > > > Sent: Sunday, July 25, 2004 12:30 PM
> > > > To: Tim Fletcher
> > > > Cc: group study
> > > > Subject: Re: Refining output of show running-config
> > > >
> > > > Wow, does that work? I am not on a rack right now.
> > > >
> > > >
> > > > On Sun, 25 Jul 2004 15:27:15 -0400, "Tim Fletcher"
> > > > <groupstudy@fletchmail.net> said:
> > > > > How about "sh run | section include router isis".
> > > > >
> > > > > At 01:13 PM 7/25/2004, Joseph D. Phillips wrote:
> > > > > >I noticed you used parentheses in:
> > > > > >
> > > > > > show run | inc (router ospf)|(summary)
> > > > > >
> > > > > >That outputs every line that matches each parenthetical
> > phrase.
> > > Very
> > > > > >cool.
> > > > > >
> > > > > >I was wondering how you would go about showing the
> > running-config
> > > > > >beginning with "router isis" such that you would exclude the
> > > > references
> > > > > >to "ip router isis" within interface configurations.
> > > > > >
> > > > > >I hope this makes sense.
> > > > > >
> > > > > >When I do show run | begin router isis I always see more
> > than I
> > > want.
> > > > > >
> > > > > >
> > > > > >
> > > > > >On Sun, 25 Jul 2004 03:20:41 -0400, "Brian Dennis"
> > > > > ><bdennis@internetworkexpert.com> said:
> > > > > >> They are referring to EIGRP, OSPF, BGP, etc
> > summary/aggregate
> > > > routes
> > > > > >> that automatically point to null.
> > > > > >>
> > > > > >> Rack1R1#sho run | in (router ospf)|(summary)
> > > > > >> router ospf 1
> > > > > >> summary-address 172.16.0.0 255.255.0.0
> > > > > >> Rack1R1#sho ip rout | in Null
> > > > > >> O 172.16.0.0/16 is a summary, 00:00:44, Null0
> > > > > >> Rack1R1#
> > > > > >>
> > > > > >> Rack1R6#sho run | in (router bgp)|(aggregate)
> > > > > >> router bgp 100
> > > > > >> aggregate-address 96.0.0.0 224.0.0.0
> > > > > >> Rack1R6#sho ip route | in Null
> > > > > >> B 96.0.0.0/3 [200/0] via 0.0.0.0, 00:00:37, Null0
> > > > > >> Rack1R6#
> > > > > >>
> > > > > >> Rack1R3#sho run | in (interface
> > Serial1/0.34)|(summary-address)
> > > > > >>
> > > > > >> interface Serial1/0.34 point-to-point
> > > > > >> ip summary-address eigrp 1 191.1.0.0 255.255.128.0 5
> > > > > >> Rack1R3#sho ip route | in Null
> > > > > >>
> > > > > >> D 191.1.0.0/17 is a summary, 00:01:49, Null0
> > > > > >> Rack1R3#
> > > > > >>
> > > > > >> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> > > > > >> bdennis@internetworkexpert.com
> > > > > >> Internetwork Expert, Inc.
> > > > > >> http://www.InternetworkExpert.com
> > > > > >> Toll Free: 877-224-8987
> > > > > >> Direct: 775-745-6404 (Outside the US and Canada)
> > > > > >>
> > > > > >>
> > > > > >> -----Original Message-----
> > > > > >> From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]
> > On
> > > > Behalf Of
> > > > > >> Howard C. Berkowitz
> > > > > >> Sent: Saturday, July 24, 2004 11:34 PM
> > > > > >> To: group study
> > > > > >> Subject: RE: Using ip route to null 0 to advertise local
> > network
> > > to
> > > > BGP
> > > > > >> peer
> > > > > >>
> > > > > >> At 12:56 AM -0400 7/25/04, Brian Dennis wrote:
> > > > > >> >Joseph,
> > > > > >> > Here is a quote from the CCIE team's Networker's
> > > Presentation
> > > > > >> >concerning the use of static routes:
> > > > > >> >
> > > > > >> ><quote>
> > > > > >> >Unless a question says so, you are not permitted to
> > use**:
> > > > > >> >Static routes (of any kind)
> > > > > >> >Default routes
> > > > > >> >
> > > > > >> >**Dynamic routes to null are permitted
> > > > > >> ></quote>
> > > > > >> >
> > > > > >>
> > > > > >> Brian,
> > > > > >>
> > > > > >> Would you agree that "dynamic route to null" pretty much
> > has to
> > > be
> > > > a
> > > > > >> static route to null redistributed into a dynamic routing
> > > protocol?
> > > >
> > > > > >> Offhand, I don't think any dynamic routing protocol has
> > any
> > > > inherent
> > > > > >> knowledge of null, so the information really has to come
> > from a
> > > > > >> static route.
> > > > > >>
> > > > > >>
> > > >
> > >
> >
> _______________________________________________________________________
> > > > > >> Please help support GroupStudy by purchasing your study
> > materials
> > > > from:
> > > > > >> http://shop.groupstudy.com
> > > > > >>
> > > > > >> Subscription information may be found at:
> > > > > >> http://www.groupstudy.com/list/CCIELab.html
> > > > > >>
> > > > > >>
> > > >
> > >
> >
> _______________________________________________________________________
> > > > > >> Please help support GroupStudy by purchasing your study
> > materials
> > > > from:
> > > > > >> http://shop.groupstudy.com
> > > > > >>
> > > > > >> Subscription information may be found at:
> > > > > >> http://www.groupstudy.com/list/CCIELab.html
> > > > > >
> > > > >
> > > >
> > >
> >
> >_______________________________________________________________________
> > > > > >Please help support GroupStudy by purchasing your study
> > materials
> > > > from:
> > > > > >http://shop.groupstudy.com
> > > > > >
> > > > > >Subscription information may be found at:
> > > > > >http://www.groupstudy.com/list/CCIELab.html
> > > >
> > > >
> > >
> >
> _______________________________________________________________________
> > > > Please help support GroupStudy by purchasing your study
> > materials
> > > from:
> > > > http://shop.groupstudy.com
> > > >
> > > > Subscription information may be found at:
> > > > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> _______________________________________________________________________
> > Please help support GroupStudy by purchasing your study materials
> > from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
>
>
> =====
> Best Regards,
> Dan



This archive was generated by hypermail 2.1.4 : Sun Aug 01 2004 - 10:12:03 GMT-3