RE: Real World: Access List/NAT Issue

From: rexperts (routerexpert@yahoo.com)
Date: Thu Jul 01 2004 - 22:55:46 GMT-3


You can not do it that way, here is why:
 
Solution

The solution is to remove the old static routes to the LAN (172.31.10.0) and configure new static routes, this time specifying the interface through which the next hop must be reached. This will allow the floating static route on R1 to get installed when the Serial 3/2 interface is shut.

R1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#no ip route 172.31.10.0 255.255.255.0 10.10.10.2
R1(config)#no ip route 172.31.10.0 255.255.255.0 192.168.20.2 250
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/2 10.10.10.2
R1(config)#ip route 172.31.10.0 255.255.255.0 Serial3/3 192.168.20.2 250
R1(config)#end

Here is the full blown solution by CISCO
http://www.cisco.com/warp/public/105/ip_static_routes.html
 
But thanks just the same.
- - - - - - - - - - - - - - - - - - - - - -

john matijevic <matijevi@bellsouth.net> wrote:
Hello,
I was wondering about the following:
ip route 0.0.0.0 0.0.0.0 Ethernet0/0 66.102.3.6 250
can you modify to just:
ip route 0.0.0.0 0.0.0.0 Ethernet0/0 250

It appears that you have the next hop to both the interface and the ip
address. I would think you would only need the interface or the ip
address but not both. Please let us know the results.

Sincerely,
John Matijevic, CCIE #13254, MCSE, CNE, CCEA
Network Consultant
Hablo Espaqol
305-321-6232

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
rexperts
Sent: Thursday, July 01, 2004 8:44 PM
To: ccielab@groupstudy.com
Subject: Real World: Access List/NAT Issue

After my last posting I got request for more real world issues, so here
is another:

When the serial interface goes down, the ethernet interface comes up but
no one can get to the internet I think beacuse of an error in the access
list or NAT translations.

Thanks in advance

- - - - -

ip subnet-zero
!
!
no ip domain lookup
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.10.100 192.168.10.255
!
ip dhcp pool data
network 192.168.10.0 255.255.255.0
dns-server 24.29.99.17 24.29.99.18
default-router 192.168.10.1
lease 7
!
no ip cef
!
!
!
!
interface Ethernet0/0
ip address 66.102.3.6 255.255.255.248
ip nat outside
half-duplex
!
interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip nat inside
speed auto
!
interface Serial1/0
description T1 to AMP
ip address 12.34.47.6 255.255.255.248
ip nat outside
backup delay 5 20
backup interface Ethernet0/0
down-when-looped
service-module t1 timeslots 1-24
!
ip nat inside source list 2 interface Serial1/0 overload
ip nat inside source list 3 interface Ethernet0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Serial1/0 10
ip route 0.0.0.0 0.0.0.0 Ethernet0/0 66.102.3.6 250
no ip http server
!
access-list 2 permit 192.168.10.0 0.0.0.255
access-list 3 permit 192.168.10.0 0.0.0.255
!
!
!
end

---------------------------------
Do you Yahoo!?
Yahoo! Mail is new and improved - Check it out!



This archive was generated by hypermail 2.1.4 : Sun Aug 01 2004 - 10:11:44 GMT-3