From: Kenneth Wygand (KWygand@customonline.com)
Date: Wed Jun 16 2004 - 09:53:32 GMT-3
James,
When you specify any "redistribute (protocol)", the IOS internally
issues a "redistribute connected" for all interfaces where that protocol
is active. You just don't see that in the config when you do a "show
run" because it's in there by default and sometimes IOS will only show
you non-default configuration when you do a "show run".
When you then issue a "redistribute connected" command, this REPLACES
the internal "redistribute connected" that the IOS added by default to
redistribute the connected interface based upon your "redistribute
(protocol)" command.
Consequently, whenever you are using "redistribute (protocol)" and
"redistribute connected" on the same router, you must include all
interfaces in your "redistribute connected" command that are natively
running the protocol you specified in your "redistribute (protocol)"
command.
In your case, you must add R2's interface that goes to R4 in your ETHER
route-map.
Hope this helps,
Kenneth E. Wygand
Systems Engineer, Project Services
CISSP #37102, CCNP, CCDP, ACSP, Cisco IPT Design Specialist, MCP, CNA,
Network+, A+
Custom Computer Specialists, Inc.
"The only unattainable goal is the one not attempted."
-Anonymous
-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
James Marinas
Sent: Wednesday, June 16, 2004 7:03 AM
To: ccielab@groupstudy.com
Subject: Changing the Order of Redisribution Statements
I ran into a certain issue regarding redistribution. Here's the
scenario:
......................loop0....................
[...r1...]-------[...r2...]-------[...r3...]
..........EIGRP1.....|......EIGRP2.....
....................OSPF....................
.....................|......................
.................[...r4...].................
...................loop0....................
r1 <> r2 = 12.1.1.x/24 running EIGRP1
r2 <> r3 = 23.1.1.x/24 running EIGRP2
r2 <> r4 = 24.1.1.x/24 running OSPF
r2's loop0 = 2.2.2.2/24 is on OSPF area 0
r4's loop0 = 4.4.4.4/24 is on OSPF area 0
r2 is redistributing OSPF into EIGRP 1 & 2 and is redistributing EIGRP1
&
2 into OSPF. r2 is NOT redistributing between EIGRP 1 and 2.
r2 is, however, redistributing the connected interfaces between EIGRP 1
and 2.
r2's config:
router ospf 1
router-id 2.2.2.2
log-adjacency-changes
redistribute eigrp 1 metric-type 1 subnets
redistribute eigrp 2 metric-type 1 subnets
network 24.1.1.2 0.0.0.0 area 0
network 2.2.2.2 0.0.0.0 area 0
router eigrp 1
redistribute connected metric 1544 2000 254 1 1500 route-map ETHER
redistribute ospf 1 metric 1544 2000 254 1 1500
network 12.1.1.2 0.0.0.0
no auto-summary
router eigrp 2
redistribute connected metric 1544 200 254 1 1500 route-map SER
redistribute ospf 1 metric 1544 2000 254 1 1500
network 23.1.1.2 0.0.0.0
no auto-summary
route-map SER permit 10
match interface Serial0/1
!
route-map ETHER permit 10
match interface FastEthernet0/0
The routing table on r1 only has the routes for 23.1.1.0/24 which is the
connected interface specified in route-map ETHER and the loopback
interface on r4 4.4.4.0/24 which was redistributed into EIGRP 1. It does
NOT see the the routes for r2's loop0 and r2's link to r4.
The routing table on r3 is similar only being able to see the route
12.1.1.0 specified in route-map SER
R4 can see the routes for EIGRP 1 and 2 as well as the loopback on r2.
My guess is that the problem lies in the order of redistribution
statements for EIGRP 1 and 2. The 'redistribute connected' statement is
executed first before the 'redistribute ospf' statement, therefore
supressing the other connected interfaces on r2. Take out the
'redistribute connected' statements and r1 and r3 will see the connected
OSPF interfaces.
Which brings me to the question... Is there a way to change the order of
redistribution statements on EIGRP? I'm willing to bet that if
'redistribute ospf' was executed before 'redistribute connected',
everything should work as it should. I've tried entering the commands in
a different order, 'no router eigrp 1', and power cycling the thing. I'm
still unable to change the order.
This scenario is based on a practice lab I'm doing where the answer had
the 'redistribute ospf' before 'redistribute connected':
router eigrp 350
redistribute ospf 1 metric 1544 2000 254 1 1500
redistribute connected metric 1544 2000 254 1 1500 route-map ETHER
network 145.20.143.14 0.0.0.0
network 145.20.150.14 0.0.0.0
no auto-summary
------------------------------------------------------------------------
FREE pop-up blocking with the new MSN Toolbar get it now!
This archive was generated by hypermail 2.1.4 : Sat Jul 03 2004 - 19:40:41 GMT-3