From: Richard Dumoulin (richard.dumoulin@vanco.es)
Date: Tue Jun 08 2004 - 08:16:27 GMT-3
Try and configure NAT on R5 so that when R4 pings the BB router, it knows
how to answer
--Richard
-----Original Message-----
From: John Matus [mailto:jmatus@pacbell.net]
Sent: martes, 08 de junio de 2004 12:57
To: lab
Subject: bgp woes....synchronization problem<??>
i've got 2 router, r4 and r5 that are in the same as <200>. r5 connects to
a backbone router at 192.10.1.254 in as 254 and is learning additional
prefixes from there.
the problem i'm having is that i can ping 222.22.2.1 from r5 but not from
r4, even though i have the network in stalled in the bgp table. i've tried
various methods to remedy this <route-reflector, synchronization, next-hop
self>, but i can't seem to make it work <getting very frustrated here.
i've included the configs for r4 and r5 along w/ the bgp tables. any ideas
as to why i can't reach 222.22.2.1` would be MOST helpful!!!!!
r5#sh run
Building configuration...
Current configuration : 3165 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r5
!
logging queue-limit 100
enable password cisco
!
username r4 password 0 cisco
memory-size iomem 15
ip subnet-zero
!
!
no ip domain lookup
!
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
!
!
isdn switch-type basic-ni
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
ip address 150.1.5.5 255.255.255.0
!
interface Ethernet0/0
ip address 192.10.1.5 255.255.255.0
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0/0.45 point-to-point
ip address 173.1.54.5 255.255.255.0
backup interface BRI0/0
frame-relay interface-dlci 504
!
interface Serial0/0.125 multipoint
ip address 173.1.125.5 255.255.255.0
ip ospf network point-to-multipoint non-broadcast
ip ospf hello-interval 2
ip ospf dead-interval 6
ip ospf priority 5
frame-relay interface-dlci 501
frame-relay interface-dlci 502
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 0835866201 8358662
isdn spid2 0835866401 8358664
!
interface Ethernet1/0
ip address 173.1.5.5 255.255.255.0
half-duplex
!
interface Dialer0
ip address 173.1.45.5 255.255.255.0
ip bandwidth-percent eigrp 10 15
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
dialer string 8358661
dialer persistent
dialer-group 1
!
router eigrp 10
redistribute ospf 1 metric 1000 100 255 1 1500
network 173.1.5.5 0.0.0.0
network 173.1.45.5 0.0.0.0
network 173.1.54.5 0.0.0.0
no auto-summary
eigrp router-id 5.5.5.5
!
router ospf 1
router-id 5.5.5.5
log-adjacency-changes
redistribute eigrp 10 metric-type 1 subnets
network 150.1.5.5 0.0.0.0 area 0
network 173.1.125.5 0.0.0.0 area 0
neighbor 173.1.125.2 cost 1562
neighbor 173.1.125.1 cost 130
!
router bgp 200
no synchronization
bgp router-id 5.5.5.5
bgp log-neighbor-changes
network 192.10.1.0
network 192.10.1.254 mask 255.255.255.255
neighbor 150.1.1.1 remote-as 100
neighbor 150.1.1.1 ebgp-multihop 255
neighbor 150.1.1.1 update-source Loopback0
neighbor 150.1.2.2 remote-as 100
neighbor 150.1.2.2 ebgp-multihop 255
neighbor 150.1.2.2 update-source Loopback0
neighbor 150.1.4.4 remote-as 200
neighbor 150.1.4.4 update-source Loopback0
neighbor 150.1.6.6 remote-as 200
neighbor 150.1.6.6 update-source Loopback0
neighbor 192.10.1.254 remote-as 254
neighbor 192.10.1.254 password CISCO
no auto-summary
!
ip http server
no ip http secure-server
ip classless
!
ip ospf name-lookup
!
!
dialer-list 1 protocol ip permit
!
!
call rsvp-sync
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
!
alias exec c conf t
alias exec s show ip route
alias exec sib show ip interface brief
alias exec b show ip bgp sum
alias exec e show ip eig nei
alias exec o show ip o nei
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
password cisco
login
!
!
end
r5#sh ip b
BGP table version is 5, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 192.10.1.0 0.0.0.0 0 32768 i
*> 205.90.31.0 192.10.1.254 0 0 254 ?
*> 220.20.3.0 192.10.1.254 0 0 254 ?
*> 222.22.2.0 192.10.1.254 0 0 254 ?
r4#sh run
Building configuration...
Current configuration : 2823 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname r4
!
logging queue-limit 100
enable password cisco
!
username r5 password 0 cisco
memory-size iomem 15
ip subnet-zero
!
!
no ip domain lookup
!
ip multicast-routing
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
!
!
!
isdn switch-type basic-ni
!
!
!
!
!
!
!
!
!
no voice hpi capture buffer
no voice hpi capture destination
!
!
mta receive maximum-recipients 0
!
!
!
!
interface Loopback0
ip address 150.1.4.4 255.255.255.0
!
interface Tunnel0
ip address 173.1.47.4 255.255.255.0
ip pim dense-mode
ip multicast boundary 5
tunnel source Loopback0
tunnel destination 150.1.7.7
!
interface FastEthernet0/0
ip address 173.1.46.4 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
frame-relay lmi-type cisco
!
interface Serial0/0.45 point-to-point
ip address 173.1.54.4 255.255.255.0
frame-relay interface-dlci 405
!
interface BRI0/0
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-ni
isdn spid1 0835866101 8358661
isdn spid2 0835866301 8358663
!
interface FastEthernet0/1
ip address 173.1.4.4 255.255.255.0
ip pim dense-mode
ip multicast boundary 5
ip igmp join-group 227.69.53.7
duplex auto
speed auto
!
interface Dialer0
ip address 173.1.45.4 255.255.255.0
ip bandwidth-percent eigrp 10 15
encapsulation ppp
dialer pool 1
dialer idle-timeout 0
!
router eigrp 10
network 150.1.4.4 0.0.0.0
network 173.1.4.4 0.0.0.0
network 173.1.45.4 0.0.0.0
network 173.1.46.4 0.0.0.0
network 173.1.54.4 0.0.0.0
no auto-summary
eigrp router-id 4.4.4.4
!
router bgp 200
no synchronization
bgp router-id 4.4.4.4
bgp log-neighbor-changes
neighbor 150.1.5.5 remote-as 200
neighbor 150.1.5.5 update-source Loopback0
neighbor 150.1.6.6 remote-as 200
neighbor 150.1.6.6 update-source Loopback0
no auto-summary
!
ip http server
no ip http secure-server
ip classless
ip route 222.22.2.1 255.255.255.255 150.1.5.5
!
!
!
access-list 5 permit 227.69.53.7
dialer-list 1 protocol ip permit
!
!
call rsvp-sync
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
destination-pattern 5550001
port 1/0/0
!
dial-peer voice 2 pots
destination-pattern 5550002
port 1/0/1
!
dial-peer voice 3 voip
destination-pattern 5281101
session target ipv4:222.22.2.1
!
!
alias exec c conf t
alias exec s show ip route
alias exec sib show ip interface brief
alias exec b show ip bgp sum
alias exec e show ip eig nei
alias exec o show ip o nei
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
line vty 0 4
password cisco
login
r4#sh ip b
BGP table version is 13, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i192.10.1.0 150.1.5.5 0 100 0 i
*>i205.90.31.0 192.10.1.254 0 100 0 254 ?
*>i220.20.3.0 192.10.1.254 0 100 0 254 ?
*>i222.22.2.0 192.10.1.254 0 100 0 254 ?
!
!
end
Regards,
John D. Matus
MCSE, CCNP
818.782.2061 office
818.430.8372 mobile
jmatus@pacbell.net
This archive was generated by hypermail 2.1.4 : Sat Jul 03 2004 - 19:40:35 GMT-3