RE: summary route

From: Brian Dennis (bdennis@internetworkexpert.com)
Date: Tue Jun 01 2004 - 15:25:48 GMT-3


As the BGP FAQs kind of hint at, it depends on how you enter your
network statement under the BGP process. A classful network statement
without auto-summary enabled meant that the network would not get
advertised (IOS version 12.2(24)). If you enter a classful network
statement, you must have auto-summary enabled for the network to be
advertised. But summarization does not take place if you enter your
network statement in a non-classful format even when the auto-summary
command is enabled. This is where the confusion seems to be.

See below:

R1 (AS1) ----- R2 (AS2)

R2 is advertising two networks to R1.

Dev-Rack2-R2#sho run
<snip>
interface Loopback100
 ip address 20.0.0.2 255.255.255.0
!
interface Loopback101
 ip address 21.0.0.2 255.255.255.0
!
router bgp 2
 network 20.0.0.0
 network 21.0.0.0 mask 255.255.255.0
 neighbor 10.12.12.1 remote-as 1
 auto-summary <-- on by default in this IOS version

Now let's look at what R1 is receiving from R2:

Dev-Rack2-R1#sho ip bgp
BGP table version is 7, local router ID is 172.16.1.91
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 20.0.0.0 10.12.12.2 0 0 2 i
*> 21.0.0.0/24 10.12.12.2 0 0 2 i
Dev-Rack2-R1#

We'll now disable auto-summary and see what R1 receives:

Dev-Rack2-R2(config)#router bgp 2
Dev-Rack2-R2(config-router)#no auto-summary
Dev-Rack2-R2(config-router)#^Z
Dev-Rack2-R2#clear ip bgp *

Dev-Rack2-R1#sho ip bgp
BGP table version is 12, local router ID is 172.16.1.91
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 21.0.0.0/24 10.12.12.2 0 0 2 i
Dev-Rack2-R1#

As we can see, the 20.0.0.0/8 route isn't being advertised anymore.
We'll now redistribute the 20.0.0.0/24 network into BGP and remove the
network statement for it. First will try without auto-summary and then
with auto-summary.

With auto-summary disabled:

Dev-Rack2-R1#sho ip bgp
BGP table version is 15, local router ID is 172.16.1.91
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 20.0.0.0/24 10.12.12.2 0 0 2 ?
*> 21.0.0.0/24 10.12.12.2 0 0 2 i
Dev-Rack2-R1#

With auto-summary enabled:

Dev-Rack2-R1#sho ip bgp
BGP table version is 19, local router ID is 172.16.1.91
Status codes: s suppressed, d damped, h history, * valid, > best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network Next Hop Metric LocPrf Weight Path
*> 20.0.0.0 10.12.12.2 0 0 2 ?
*> 21.0.0.0/24 10.12.12.2 0 0 2 i
Dev-Rack2-R1#

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@internetworkexpert.com
Internetwork Expert, Inc.
http://www.InternetworkExpert.com
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com] On Behalf Of
Georg Pauwen
Sent: Tuesday, June 01, 2004 12:51 AM
To: richard.dumoulin@vanco.es; blackyeyes00@hotmail.com;
ahmed.mustafa@sbcglobal.net
Cc: ccielab@groupstudy.com
Subject: RE: summary route

Hello Richard,

BGP would need the summary route in the routing table, and just turning
on
auto-summary will not put it there. You could put a static route to null
in
your config for the summarized network...
Can you post your test configuration and the output of show ip route
from
the router where you have tested this ?

Regards,

Georg

>From: Richard Dumoulin <richard.dumoulin@vanco.es>
>Reply-To: Richard Dumoulin <richard.dumoulin@vanco.es>
>To: Yasser Aly <blackyeyes00@hotmail.com>, ahmed.mustafa@sbcglobal.net
>CC: ccielab@groupstudy.com
>Subject: RE: summary route
>Date: Mon, 31 May 2004 23:15:53 +0100
>
>Yasser, here I have to disagree. Did you read the BGP faq and did you
test
>it ? I did and auto-summary contrary to what the majority of people
think
>not only works with redistribution,
>
>--Richard
>
>-----Original Message-----
>From: Yasser Aly [mailto:blackyeyes00@hotmail.com]
>Sent: martes, 01 de junio de 2004 0:11
>To: Richard Dumoulin; ahmed.mustafa@sbcglobal.net
>Cc: ccielab@groupstudy.com
>Subject: RE: summary route
>
>
>Hello,
>
>Possibility #2 will not work.
>
>Auto-summary inside BGP acts only on redistributed routes not on routes
>entered in the BGP via the network command. You will need to
redistribute
>the route into BGP and turn on auto-summary. This will summarize it to
its
>classful boundary.
>
>Regards,
>Yasser
>===================
>But I already explained !
>
>Let's say R2 is connected to R1 and they run an igp like RIP. On R2,
>configure "ip summary-address rip 156.1.0.0 255.255.0.0". So now R1 has
the
>network in his routing table right ? You just injected the summary
through
>the igp. Now just redistribute RIP into BGP with filters if you wish
and
>you
>will be advertising the network.
>
>
>2) Another possibility as explained is :
>
>router bgp 1234
>auto-summary
>network 156.1.0.0
>
>
>And that's it. But it might not be the solution as per the requirements
>
>--Richard
>
>
>
>-----Original Message-----
>From: Ahmed Mustafa [mailto:ahmed.mustafa@sbcglobal.net]
>Sent: lunes, 31 de mayo de 2004 7:01
>To: Richard Dumoulin
>Subject: Re: summary route
>
>
>Richard,
>
>I have confused you with my question. I completely understand the BGP
>rules
>for advertising networks. What i was asking is let say that
>
>I have R1 connected to backbone via BGP. on R1 I have subnets of
network
>156.1.0.0 per se
>
>156.1.1.0
>156.1.2.0
>156.1.3.0
>156.1.4.0 and so on.
>
>I know just want to advertise the summary route to B1. The network
between
>BB and R1 is on 204.12.1.0/24.
>
>Is there any other solution besides using aggregate to advertise a
network
>156.1.0.0/16 to BB.
>
>Regards,
>
>Ahmed
>
>----- Original Message -----
>From: Richard Dumoulin <mailto:richard.dumoulin@vanco.es>
>To: Ahmed Mustafa <mailto:ahmed.mustafa@sbcglobal.net>
>Cc: ccielab@groupstudy.com <mailto:ccielab@groupstudy.com>
>Sent: Sunday, May 30, 2004 8:38 PM
>Subject: RE: summary route
>
>Ahmed, auto-summary is not only used when redistributing igp into bgp.
>Suppose you have the subnet 156.1.2.0/24 in your local routing table.
If
>you
>enable auto-summary and configure network 156.1.0.0 under BGP, you will
>advertise this route as a classful network.
>
>Attaching a prefix-list is only policing traffic. This is not a way to
>advertise a network. There 4 ways to advertise:
>
>redistribute
>network
>aggregate
>bgp inject-map
>
>So you solution should come from one of these four ways,
>
>HTH,
>
>
>--Richard
>
>
>
>-----Original Message-----
>From: Ahmed Mustafa [mailto:ahmed.mustafa@sbcglobal.net]
>Sent: lunes, 31 de mayo de 2004 4:58
>To: Richard Dumoulin
>Subject: Re: summary route
>
>
>Richard,
>
>I am confused. Under BGP process, the auto-summary keyword is only
used if
>I redistribute the route. CCIE labs don't allow to create a static
route,
>so that option is no permittable.
>
>2nd option to use aggregate address with the summary-only keyword.
That is
>also restricted by the task I am currently doing
>
>3rd option, I thought I could use prefix-list of 156.1.0.0/16 and
attach it
>with the neighbor command under the BGP process, but you are saying it
>won't
>work.
>
>Is it because that I have to have a same route 156.1.0.0/16 in my
routing
>table, and then prefix-list can allow only this route to be
advertiseable
>to
>the backbone, and then implicit deny will deny all the subnets of
156.1.0.0
>network.
>
>Now the question is how to do that.
>
>May be I could just advertise the network 156.1.0.0 under bgp process,
that
>will create a 156.1.0.0 route in a BGP table though, not routing table.
>
>I am lost.
>
>Any clue.
>
>Ahmed
>
>----- Original Message -----
>From: Richard Dumoulin <mailto:richard.dumoulin@vanco.es>
>To: Ahmed Mustafa <mailto:ahmed.mustafa@sbcglobal.net> ;
>ccielab@groupstudy.com <mailto:ccielab@groupstudy.com>
>Sent: Sunday, May 30, 2004 7:04 PM
>Subject: RE: summary route
>
>
>I don't see how you would end up advertising the route. With the
>prefix-list
>you are just allowing it. I can see three options: --Aggregate command
>--"auto-summary" + "network 156.1.0.0" under the bgp process. --you
>summarise in igp and redistribute it into bgp ,
>
>As the first two options use bgp summary features I would do the last
one,
>
>HTH,
>
>--Richard
>
>-----Original Message-----
>From: Ahmed Mustafa [mailto:ahmed.mustafa@sbcglobal.net
><mailto:ahmed.mustafa@sbcglobal.net> ]
>Sent: lunes, 31 de mayo de 2004 3:44
>To: ccielab@groupstudy.com
>Subject: summary route
>
>
>If I want to announce a summary route of my internal network towards
the
>Backbone router, and not allowed to use the route-summary in BGP.
>
>
>Will the following solution work:
>
>
>ip prefix-list TOBB permit 156.1.0.0/16 -------------------> Assuming
my
>internal network is comprise of 156.1.0.0/16 network, and scattered
>throughout the netowork with /24 bit mask.
>
>
>
>router bgp 100
>neighbor 1.1.1.1 remote-as 230
>neighbor 1.1.1.1 prefix-list TOBB out
>
>
>I didn't use the command aggregate-address. I am assuming by saying
not
>use
>route-summary means I can't use aggregation.
>
>
>The implicit deny at the end should block all the longer routes.
>
>Please advise
>
>_________________________________________________________________
>MSN Premium helps eliminate e-mail viruses. Get 2 months FREE*
>http://join.msn.com/?pgmarket=en-ca&page=byoa/prem&xAPID=1994&DI=1034&S
U=htt
>p://hotmail.com/enca&HL=Market_MSNIS_Taglines
>
>_______________________________________________________________________
>Please help support GroupStudy by purchasing your study materials from:
>http://shop.groupstudy.com
>
>Subscription information may be found at:
>http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Sat Jul 03 2004 - 19:40:31 GMT-3