RE: R1/R2 to ISPs BGP

From: MMoniz (ccie2002@tampabay.rr.com)
Date: Tue May 11 2004 - 10:19:02 GMT-3


Well I see a couple of things. First your AS-path list to your Ibgp peer
will only allow routes orignating from the router.
So you will not have redundancy if you lose the ISP on the other router.
(except for the default on the other router)

Which brings me to the second point of have equal distanced default routes
and defaults on each router. If you lose an ISP and are not passing the
customer routes to the other router it will use its default and play ping
pong with each other :)

But you didn't state if you were accepting full routes or just customer
routes from the ISP

Well that is what I notice

mike

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Jason Aarons
Sent: Tuesday, May 11, 2004 8:23 AM
To: ccielab@groupstudy.com
Subject: R1/R2 to ISPs BGP

I wrote this config by hand. R1 and R2 each have a T1 to different ISPs.
They should run iBGP to each other in the same AS, and eBGP to their ISPs.
Can you spot the mistakes? The IP addresses are fake -jason

Hostname R1-3725

!

interface FastEthernet0/0

ip address 218.209.240.1 255.255.255.0

!

interface Serial0/1

 description ISP-BellSouth

 ip address 162.17.81.98 255.255.255.252

!

router bgp 18545

 no synchronization

 bgp log-neighbor-changes

 bgp router-id 218.209.240.1

 network 218.209.240.0 mask 255.255.255.0

!

 neighbor 162.17.81.97 description "6381-BellSouth-eBGP"

 neighbor 162.17.81.97 remote-as 6381

 neighbor 162.17.81.97 filter-list 1 out

!

 neighbor 218.209.240.4 description "R2-3620-iBGP"

 neighbor 218.209.240.4 remote-as 18545

 neighbor 218.209.240.4 filter-list 1 out

 neighbor 218.209.240.4 next-hop-self

 no auto-summary

!

ip as-path access-list 1 permit ^$

ip route 0.0.0.0 0.0.0.0 162.17.81.97

Ip route 0.0.0.0 0.0.0.0 218.209.240.4

end

Hostname R2-3640

!

interface FastEthernet0/0

 ip address 218.209.240.4 255.255.255.0

 !

interface Serial0/0

 description AT&T

 ip address 12.125.93.186 255.255.255.252

!

router bgp 18545

 no synchronization

 bgp log-neighbor-changes

 bgp router-id 218.109.240.4

 network 218.209.240.0 mask 255.255.255.0

!

 neighbor 12.125.93.185 description "7019-AT&T-eBGP"

 neighbor 12.125.93.185 remote-as 7019

 neighbor 12.125.93.185 filter-list 1 out

!

 neighbor 218.209.240.1 description "R1-3620-iBGP"

 neighbor 218.209.240.1 remote-as 18545

 neighbor 218.209.240.1 filter-list 1 out

 neighbor 218.209.240.1 next-hop-self

!

No auto-summary

!

ip as-path access-list 1 permit ^$

ip route 0.0.0.0 0.0.0.0 12.124.93.185

Ip route 0.0.0.0 0.0.0.0 218.209.240.1



This archive was generated by hypermail 2.1.4 : Wed Jun 02 2004 - 11:12:09 GMT-3