EIGRP redistribution of loopback

From: Charles T. Alexander (charles.t.alexander@verizon.net)
Date: Tue May 11 2004 - 09:58:56 GMT-3


I'm having a problem with redistributing the loopback into EIGRP and being able to see it more than 1 router away.

cat3500XL---------------cat3550
 |
 |-------------r7--------r8
 |
BB3

EIGRP is on r7, r8, BB3, cat3550.
The loopback 0 is on r8 and being redistributed connected
Can ping loopback on r7 but not on bb3 or cat 3550

If I include the loopback in the routing process of r8, rather than redistributed it, there is no problem seeing it.

=======================
r8
r8#r
Building configuration...

Current configuration : 1618 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r8
!
logging buffered 10000 debugging
logging rate-limit console 10 except errors
enable password radnor
!
ip subnet-zero
no ip finger
ip tcp synwait-time 5
no ip domain-lookup
ip host r1 10.10.11.1
!
no ip dhcp-client network-discovery
!
key chain cta78
 key 1
  key-string cta78
!
!
!
!
interface Loopback0
 ip address 138.10.8.8 255.255.255.0
!
interface Ethernet0
 ip address 192.168.20.8 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 description Backdoor to R1
 bandwidth 64
 ip address 10.10.11.8 255.255.255.0
 clockrate 64000
!
interface TokenRing0
 ip address 138.10.78.8 255.255.255.0
 ip bandwidth-percent eigrp 100 60
 ip hold-time eigrp 100 179
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta78
 ring-speed 16
!
router eigrp 100
 timers active-time disabled
 redistribute connected metric 10000 10 255 1 1500
 passive-interface Loopback0
 network 138.10.78.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
ip route 80.0.0.0 255.0.0.0 192.168.20.100
ip http server
!
!
alias exec c config t
alias exec r show run
alias exec i show ip route
alias exec b show ip bgp
alias exec bs show ip bgp summary
alias exec u undebug all
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r8#
=======================
r7
r7#r
Building configuration...

Current configuration : 1424 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
logging buffered 10000 debugging
enable password radnor
!
!
!
!
!
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
!
!
key chain cta70
 key 1
  key-string cta70
key chain cta78
 key 1
  key-string cta78
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
!
!
interface Loopback0
 ip address 138.10.7.7 255.255.255.0
!
interface BRI0/0
 no ip address
 shutdown
!
interface Ethernet0/0
 ip address 138.10.70.7 255.255.255.0
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta70
!
interface TokenRing0/0
 ip address 138.10.78.7 255.255.255.0
 ip hold-time eigrp 100 179
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta78
 ring-speed 16
!
router eigrp 100
 passive-interface Loopback0
 network 138.10.7.0 0.0.0.255
 network 138.10.70.0 0.0.0.255
 network 138.10.78.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
!
alias exec c config t
alias exec r show run
alias exec i show ip route
alias exec b show ip bgp
alias exec bs show ip bgp summary
alias exec u undebug all
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r7#
=======================
cat3550
c1#r
Building configuration...

Current configuration : 4858 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c1
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
ip routing
ip tcp synwait-time 5
no ip domain-lookup
ip dhcp relay information option
!
!
!
key chain cta70
 key 1
  key-string cta70
!
spanning-tree extend system-id
spanning-tree vlan 40 max-age 30
system mtu 1518
!
!
!
interface Loopback0
 ip address 138.10.10.10 255.255.255.0
!
interface Loopback1
 ip address 138.10.11.10 255.255.255.0
!
interface Port-channel1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
!
interface FastEthernet0/1
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/2
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/3
 no ip address
!
interface FastEthernet0/4
 no ip address
!
interface FastEthernet0/5
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/6
 no ip address
!
interface FastEthernet0/7
 no ip address
!
interface FastEthernet0/8
 switchport access vlan 192
 no ip address
!
interface FastEthernet0/9
 no ip address
 random-detect
!
interface FastEthernet0/10
 no ip address
!
interface FastEthernet0/11
 switchport access vlan 125
 no ip address
!
interface FastEthernet0/12
 switchport access vlan 192
 no ip address
!
interface FastEthernet0/13
 no ip address
!
interface FastEthernet0/14
 no ip address
!
interface FastEthernet0/15
 no ip address
!
interface FastEthernet0/16
 switchport access vlan 14
 switchport mode dot1q-tunnel
 no ip address
 duplex full
 speed 100
 l2protocol-tunnel cdp
 l2protocol-tunnel stp
 l2protocol-tunnel vtp
 no cdp enable
!
interface FastEthernet0/17
 no ip address
!
interface FastEthernet0/18
 no ip address
!
interface FastEthernet0/19
 no ip address
!
interface FastEthernet0/20
 no ip address
!
interface FastEthernet0/21
 no switchport
 no ip address
!
interface FastEthernet0/22
 no ip address
!
interface FastEthernet0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 channel-group 1 mode on
!
interface GigabitEthernet0/1
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 ip address 138.10.20.1 255.255.255.0
!
interface Vlan30
 description vlan C
 ip address 192.168.30.10 255.255.255.0
!
interface Vlan40
 description vlan B
 ip address 138.10.40.10 255.255.255.0
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cta4690
 ip ospf mtu-ignore
!
interface Vlan70
 description vlan D
 ip address 138.10.70.10 255.255.255.0
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta70
 ip summary-address eigrp 100 203.1.0.0 255.255.252.0 255
!
interface Vlan96
 description vlan A
 ip address 138.10.96.10 255.255.255.224
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cta4690
 ip ospf mtu-ignore
!
interface Vlan125
 description vlan E
 ip address 138.10.125.10 255.255.255.0
 ip rip receive version 1 2
!
interface Vlan192
 description vlan F
 ip address 192.168.20.10 255.255.255.0
!
router eigrp 100
 redistribute ospf 1 metric 10000 40 254 1 1500
 redistribute ospf 2 metric 10000 40 254 1 1500
 redistribute rip metric 10000 40 255 1 1500
 passive-interface default
 no passive-interface Vlan30
 no passive-interface Vlan70
 network 138.10.70.0 0.0.0.255
 network 192.168.30.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 138.10.10.10
 log-adjacency-changes
 area 0 authentication message-digest
 redistribute eigrp 100 subnets
 redistribute ospf 2 subnets
 redistribute rip subnets
 network 138.10.40.0 0.0.0.255 area 0
!
router ospf 2
 router-id 138.10.11.10
 log-adjacency-changes
 auto-cost reference-bandwidth 6000
 area 0 authentication message-digest
 redistribute eigrp 100 subnets
 redistribute ospf 1 subnets
 redistribute rip subnets
 network 138.10.96.0 0.0.0.31 area 0
!
router rip
 version 2
 redistribute eigrp 100 metric 2
 redistribute ospf 1 metric 2
 redistribute ospf 2 metric 2
 passive-interface default
 no passive-interface Vlan125
 network 138.10.0.0
 input-queue 100
 no auto-summary
!
ip classless
ip http server
!
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line vty 0 4
 exec-timeout 0 0
 password bp
 login
line vty 5 15
 exec-timeout 0 0
 password bp
 login
!
!
monitor session 1 source interface Fa0/17
monitor session 1 filter vlan 10
monitor session 1 destination interface Fa0/18 encapsulation dot1q
end
          
c1#
=======================
cat3500XL
c2#r
Building configuration...

Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2
!
logging buffered 10000 debugging
enable password radnor
!
!
!
!
!
!
ip subnet-zero
ip tcp synwait-time 5
no ip domain-lookup
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
 switchport access vlan 30
!
interface FastEthernet0/4
 switchport access vlan 40
!
interface FastEthernet0/5
!
interface FastEthernet0/6
 switchport access vlan 96
!
interface FastEthernet0/7
 switchport access vlan 70
!
interface FastEthernet0/8
!
interface FastEthernet0/9
 switchport access vlan 96
!
interface FastEthernet0/10
!
interface FastEthernet0/11
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface FastEthernet0/12
 port group 1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 138.10.20.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 password bp
 login
line vty 5 15
 exec-timeout 0 0
 password bp
 login
!
end

c2#



This archive was generated by hypermail 2.1.4 : Wed Jun 02 2004 - 11:12:09 GMT-3