RIP offset-list

From: Tasuka Amano Hsu (tasuka@mac.com)
Date: Tue Apr 27 2004 - 06:50:22 GMT-3


Hi,
   I want to change the RIP incoming route metric, I think the
offset-list is the choice but seems not, after add offset-list, the
mutual path 172.16.100.0 will show me only one route in route table, if
I remove the offset-list at router rip, then will show me the redundant
route. Is that is my configuration problem ?

Singerely,

Tasuka

my IOS is 12.2(17) and configuration is :

version 12.2
service timestamps debug datetime msec localtime
service timestamps log datetime msec localtime
no service password-encryption
!
hostname FR-sw
!
!
memory-size iomem 15
ip subnet-zero
!
!
!
ip cef
ip cef load-sharing algorithm original
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
  ip address 4.4.4.4 255.255.255.255
!
interface Ethernet0/0
  no ip address
  half-duplex
!
interface Serial0/0
  ip address 11.0.3.1 255.255.255.0
  ip rip send version 2
  ip rip receive version 2
  encapsulation frame-relay IETF
  no keepalive
  frame-relay map ip 11.0.3.1 100
  frame-relay map ip 11.0.3.2 100 broadcast
  no frame-relay inverse-arp
!
interface Serial1/0
  no ip address
  shutdown
!
interface Serial1/1
  ip address 10.0.1.1 255.255.255.0
  ip rip send version 2
  ip rip receive version 2
  clockrate 128000
!
interface Serial1/2
  no ip address
  shutdown
!
interface Serial1/3
  ip address 10.0.2.1 255.255.255.0
  ip rip send version 2
  ip rip receive version 2
  encapsulation frame-relay IETF
  no keepalive
  frame-relay map ip 10.0.2.1 100
  frame-relay map ip 10.0.2.2 100 broadcast
  no frame-relay inverse-arp
!
router rip
  version 2
  passive-interface Loopback0
  offset-list 0 in 1 Serial1/3
  network 4.0.0.0
  network 10.0.0.0
  network 11.0.0.0
  maximum-paths 6
  no auto-summary
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Add offset-list

#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
        ia - IS-IS inter area, * - candidate default, U - per-user
static route
        o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.0.1.2, 00:00:11, Serial1/1
      4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
      172.16.0.0/24 is subnetted, 1 subnets
R 172.16.100.0 [120/1] via 11.0.3.2, 00:00:27, Serial0/0
      9.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 9.9.9.9/32 [120/2] via 10.0.1.2, 00:00:11, Serial1/1
R 9.0.1.0/24 [120/1] via 10.0.1.2, 00:00:11, Serial1/1
      10.0.0.0/24 is subnetted, 2 subnets
C 10.0.2.0 is directly connected, Serial1/3
C 10.0.1.0 is directly connected, Serial1/1
      11.0.0.0/24 is subnetted, 1 subnets
C 11.0.3.0 is directly connected, Serial0/0

no offset-list

FR-sw#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
        i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
level-2
        ia - IS-IS inter area, * - candidate default, U - per-user
static route
        o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
R 1.1.1.1 [120/1] via 10.0.1.2, 00:00:02, Serial1/1
      4.0.0.0/32 is subnetted, 1 subnets
C 4.4.4.4 is directly connected, Loopback0
      172.16.0.0/24 is subnetted, 1 subnets
R 172.16.100.0 [120/1] via 11.0.3.2, 00:00:02, Serial0/0
                      [120/1] via 10.0.2.2, 00:00:02, Serial1/3
      9.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R 9.9.9.9/32 [120/2] via 10.0.1.2, 00:00:02, Serial1/1
R 9.0.1.0/24 [120/1] via 10.0.1.2, 00:00:03, Serial1/1
      10.0.0.0/24 is subnetted, 2 subnets
C 10.0.2.0 is directly connected, Serial1/3
C 10.0.1.0 is directly connected, Serial1/1
      11.0.0.0/24 is subnetted, 1 subnets
C 11.0.3.0 is directly connected, Serial0/0

No offset-list

FR-sw#sh ip rip data
1.0.0.0/8 auto-summary
1.1.1.1/32
     [1] via 10.0.1.2, 00:00:26, Serial1/1
4.0.0.0/8 auto-summary
4.4.4.4/32 directly connected, Loopback0
9.0.0.0/8 auto-summary
9.0.1.0/24
     [1] via 10.0.1.2, 00:00:26, Serial1/1
9.9.9.9/32
     [2] via 10.0.1.2, 00:00:26, Serial1/1
10.0.0.0/8 auto-summary
10.0.1.0/24 directly connected, Serial1/1
10.0.2.0/24 directly connected, Serial1/3
11.0.0.0/8 auto-summary
11.0.3.0/24 directly connected, Serial0/0
172.16.0.0/16 auto-summary
172.16.100.0/24
     [1] via 10.0.2.2, 00:00:03, Serial1/3
     [1] via 11.0.3.2, 00:00:03, Serial0/0
FR-sw#

Has offset-list

FR-sw#sh ip rip data
1.0.0.0/8 auto-summary
1.1.1.1/32
     [1] via 10.0.1.2, 00:00:08, Serial1/1
4.0.0.0/8 auto-summary
4.4.4.4/32 directly connected, Loopback0
9.0.0.0/8 auto-summary
9.0.1.0/24
     [1] via 10.0.1.2, 00:00:08, Serial1/1
9.9.9.9/32
     [2] via 10.0.1.2, 00:00:08, Serial1/1
10.0.0.0/8 auto-summary
10.0.1.0/24 directly connected, Serial1/1
10.0.2.0/24 directly connected, Serial1/3
11.0.0.0/8 auto-summary
11.0.3.0/24 directly connected, Serial0/0
172.16.0.0/16 auto-summary
172.16.100.0/24
     [1] via 11.0.3.2, 00:00:08, Serial0/0



This archive was generated by hypermail 2.1.4 : Mon May 03 2004 - 19:48:56 GMT-3