Can't ping between two EIGRP frame-relay spokes

From: Joseph D. Phillips (jphillips@ufcwdrugtrust.org)
Date: Fri Apr 02 2004 - 18:41:12 GMT-3


I can ping all routes save two in my topology. The two routes I can't ping are in the routing tables of the spoke routers, but pings from spoke to spoke get black-holed at the hub frame router.

I know this is a frequently-encountered problem, and I thought I could solve it by disabling ip split, but nothing I do works.

Can one of you help?

Briefly, I have R3 as the hub and R1 and R5 as spokes. I am using PPP over FR using virtual templates. The adjacencies all form and I can ping all routes except 150.1.1.1 and 150.1.5.5

Here's my config:

hostname r1
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
no voice hpi capture buffer
no voice hpi capture destination
mta receive maximum-recipients 0
interface Loopback0
 ip address 150.1.1.1 255.255.255.0
interface Ethernet0/0
ip address 156.1.18.1 255.255.255.0
interface Serial0/0
 encapsulation frame-relay
 frame-relay interface-dlci 103 ppp Virtual-Template1
 frame-relay lmi-type cisco
interface Virtual-Template1
 ip address 156.1.31.1 255.255.255.0
 ip bandwidth-percent eigrp 10 10
router eigrp 10
 timers active-time 5
 network 150.1.0.0
 network 156.1.0.0
 neighbor 156.1.31.3 Virtual-Template1
 metric weights 0 3 1 1 1 1
 no auto-summary
 eigrp router-id 1.1.1.1

hostname r2
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
no voice hpi capture buffer
no voice hpi capture destination
mta receive maximum-recipients 0
interface Loopback0
 ip address 150.1.2.2 255.255.255.0
interface Ethernet0/0
 ip address 156.1.27.2 255.255.255.0
interface Serial0/0
 encapsulation frame-relay IETF
frame-relay lmi-type cisco
interface Ethernet0/1
interface Serial0/1
 ip address 156.1.23.2 255.255.255.0
 encapsulation ppp
 no ip mroute-cache
 compress stac
 ppp reliable-link
router eigrp 10
 timers active-time 5
 network 150.1.0.0
 network 156.1.0.0
 metric weights 0 3 1 1 1 1
 no auto-summary
 eigrp router-id 2.2.2.2

hostname r3
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
no voice hpi capture buffer
no voice hpi capture destination
mta receive maximum-recipients 0
interface Loopback0
 ip address 150.1.3.3 255.255.255.0
interface Ethernet0/0
ip address 156.1.3.3 255.255.255.0
interface Ethernet0/1
interface Serial1/0
 encapsulation frame-relay
 no ip split-horizon eigrp 10
 serial restart_delay 0
 frame-relay interface-dlci 301 ppp Virtual-Template31
 frame-relay interface-dlci 305 ppp Virtual-Template35
 frame-relay lmi-type cisco
interface Serial1/3
 ip address 156.1.23.3 255.255.255.0
 encapsulation ppp
 no ip mroute-cache
 compress stac
 serial restart_delay 0
 clockrate 1344000
 ppp reliable-link
interface Virtual-Template31
 ip address 156.1.31.3 255.255.255.0
 ip bandwidth-percent eigrp 10 10
 no ip split-horizon eigrp 10
interface Virtual-Template35
 ip address 156.1.35.3 255.255.255.0
 ip bandwidth-percent eigrp 10 10
 no ip split-horizon eigrp 10
router eigrp 10
 timers active-time 5
 network 150.1.0.0
 network 156.1.0.0
 neighbor 156.1.31.1 Virtual-Template31
 neighbor 156.1.35.5 Virtual-Template35
 metric weights 0 3 1 1 1 1
 no auto-summary
 eigrp router-id 3.3.3.3

hostname r4
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
isdn switch-type basic-ni
no voice hpi capture buffer
no voice hpi capture destination
mta receive maximum-recipients 0
interface Loopback0
 ip address 150.1.4.4 255.255.255.0
interface Ethernet0/0
 ip address 156.1.4.4 255.255.255.0
interface Serial0/0
 encapsulation frame-relay IETF
 frame-relay lmi-type cisco
interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 51552720240101 5272024
 isdn spid2 51552720260101 5272026
 ppp multilink
interface Ethernet0/1
 ip address 156.1.44.4 255.255.255.0
interface Ethernet2/0
interface Serial2/0
interface TokenRing2/0
 ring-speed 16
interface Dialer1
 ip address 156.1.45.4 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 0
dialer string 5272025
 dialer string 5272027
 dialer persistent
 dialer-group 1
 ppp chap refuse
 ppp pap sent-username ROUTER4 password 0 CISCO
 ppp multilink
 ppp multilink fragment-delay 10
 ppp multilink links minimum 2
 ppp multilink interleave
router odr
 neighbor 156.1.45.5
no ip http secure-server
dialer-list 1 protocol ip permit

hostname r5
logging queue-limit 100
no logging console
username ROUTER4 password 0 CISCO
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
isdn switch-type basic-ni
no voice hpi capture buffer
no voice hpi capture destination
mta receive maximum-recipients 0
interface Loopback0
ip address 150.1.5.5 255.255.255.0
interface Ethernet0/0
interface Ethernet0/0.52
 encapsulation dot1Q 52
 ip address 192.10.1.5 255.255.255.0
interface Ethernet0/0.53
 encapsulation dot1Q 53
 ip address 204.12.1.5 255.255.255.0
interface Serial0/0
 encapsulation frame-relay
 frame-relay interface-dlci 503 ppp Virtual-Template35
 frame-relay lmi-type cisco
interface BRI0/0
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 51552720250101 5272025
 isdn spid2 51552720270101 5272027
 ppp multilink
interface Ethernet0/1
 ip address 156.1.58.5 255.255.255.0
interface Ethernet2/0
interface Serial2/0
interface TokenRing2/0
 ring-speed 16
interface Serial2/1
interface Virtual-Template35
 ip address 156.1.35.5 255.255.255.0
 ip bandwidth-percent eigrp 10 10
interface Dialer1
 ip address 156.1.45.5 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer string 5272024
 dialer string 5272026
 dialer-group 1
 ppp authentication chap pap
 ppp multilink
 ppp multilink fragment-delay 10
router odr
 neighbor 156.1.45.4
router eigrp 10
 timers active-time 5
 network 150.1.0.0
 network 156.1.0.0
 neighbor 156.1.35.3 Virtual-Template35
 metric weights 0 3 1 1 1 1
 no auto-summary
 eigrp router-id 5.5.5.5
no ip http secure-server
access-list 101 permit ip any any
dialer-list 1 protocol ip list 101

hostname r6
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
key chain EIGRP
 key 1
  key-string CISCO
no voice hpi capture buffer
no voice hpi capture destination
interface Loopback0
 ip address 150.1.6.6 255.255.255.0
interface ATM0/0
 no atm ilmi-keepalive
 pvc 0/5 qsaal
 pvc 0/16 ilmi
interface ATM0/0.1 multipoint
 ip address 54.1.1.6 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
 pvc 0/101
  protocol ip 54.1.1.254 broadcast
  protocol ip 54.1.1.6
interface ATM0/0.2 multipoint
 ip address 54.1.4.6 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
 atm esi-address 012345678911.10
 svc joe nsap 47.00000000000000000000000A.012345678922.20
  protocol ip 54.1.4.254 broadcast
interface Serial1/0
 serial restart_delay 0
interface Serial1/1
serial restart_delay 0
interface Serial1/2
 serial restart_delay 0
interface Serial1/3
 serial restart_delay 0
interface Serial1/4
 serial restart_delay 0
interface Serial1/5
 serial restart_delay 0
interface Serial1/6
 serial restart_delay 0
interface Serial1/7
 serial restart_delay 0
interface Ethernet2/0
 ip address 156.1.67.6 255.255.255.0
router eigrp 10
 timers active-time 5
 network 54.0.0.0
 network 150.1.0.0
 network 156.1.0.0
 metric weights 0 3 1 1 1 1
 distribute-list evens in ATM0/0.1
 distribute-list odds in ATM0/0.2
 no auto-summary
 eigrp router-id 6.6.6.6
ip access-list standard evens
 deny 0.0.1.0 255.255.254.255
 permit any
ip access-list standard odds
 deny 0.0.0.0 255.255.254.255
 permit any

hostname 3550-01
no logging console
ip subnet-zero
ip routing
ip tcp synwait-time 5
no ip domain-lookup
ip multicast-routing
ip ssh time-out 120
ip ssh authentication-retries 3
spanning-tree mode pvst
spanning-tree extend system-id
interface Loopback0
 ip address 150.1.7.7 255.255.255.0
interface FastEthernet0/1
 switchport access vlan 18
 switchport mode access
interface FastEthernet0/2
 switchport access vlan 27
 switchport mode access
interface FastEthernet0/3
 switchport access vlan 3
 switchport mode access
interface FastEthernet0/4
 switchport access vlan 4
 switchport mode access
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 52,53
 switchport mode trunk
interface FastEthernet0/6
 no switchport
 ip address 156.1.67.7 255.255.255.0
interface FastEthernet0/7
 switchport mode dynamic desirable
interface FastEthernet0/8
 switchport access vlan 52
 switchport mode access
interface FastEthernet0/9
 switchport access vlan 53
switchport mode access
interface Vlan27
 ip address 156.1.27.7 255.255.255.0
router eigrp 10
 network 150.1.0.0
 network 156.1.0.0
 metric weights 0 3 1 1 1 1
 no auto-summary
 eigrp router-id 7.7.7.7
 no eigrp log-neighbor-changes

hostname 3550-02
no logging console
ip subnet-zero
ip routing
ip tcp synwait-time 5
no ip domain-lookup
ip multicast-routing
ip ssh time-out 120
ip ssh authentication-retries 3
spanning-tree mode pvst
spanning-tree extend system-id
interface FastEthernet0/1
 switchport mode dynamic desirable
interface FastEthernet0/2
 switchport mode dynamic desirable
interface FastEthernet0/3
switchport mode dynamic desirable
interface FastEthernet0/4
 switchport access vlan 44
 switchport mode access
interface FastEthernet0/5
 switchport access vlan 58
 switchport mode access
interface Vlan8
 ip address 156.1.8.8 255.255.255.0
interface Vlan18
 ip address 156.1.18.8 255.255.255.0
interface Vlan58
 ip address 156.1.58.8 255.255.255.0
router eigrp 10
 network 150.1.0.0
 network 156.1.0.0
 metric weights 0 3 1 1 1 1
 no auto-summary
 eigrp router-id 8.8.8.8
 eigrp stub connected
 no eigrp log-neighbor-changes

hostname bb1
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
ip audit notify log
ip audit po max-events 100
mpls ldp logging neighbor-changes
key chain EIGRP
 key 1
  key-string CISCO
no voice hpi capture buffer
no voice hpi capture destination
interface Loopback112
 ip address 112.0.0.1 255.0.0.0
interface Loopback113
 ip address 113.0.0.1 255.0.0.0
interface Loopback114
 ip address 114.0.0.1 255.0.0.0
interface Loopback115
 ip address 115.0.0.1 255.0.0.0
interface Loopback116
 ip address 116.0.0.1 255.0.0.0
interface Loopback117
 ip address 117.0.0.1 255.0.0.0
interface Loopback118
 ip address 118.0.0.1 255.0.0.0
interface Loopback119
 ip address 119.0.0.1 255.0.0.0
interface Loopback51001
 ip address 51.0.0.1 255.255.0.0
interface Loopback51101
 ip address 51.1.0.1 255.255.0.0
interface Loopback51201
 ip address 51.2.0.1 255.255.0.0
interface Loopback51301
ip address 51.3.0.1 255.255.0.0
interface Loopback51401
 ip address 51.4.0.1 255.255.0.0
interface Loopback51501
 ip address 51.5.0.1 255.255.0.0
interface Loopback51601
 ip address 51.6.0.1 255.255.0.0
interface Loopback51701
 ip address 51.7.0.1 255.255.0.0
interface Loopback200000
 ip address 200.0.0.1 255.255.255.0
interface Loopback200010
 ip address 200.0.1.1 255.255.255.0
interface Loopback200020
 ip address 200.0.2.1 255.255.255.0
interface Loopback200030
 ip address 200.0.3.1 255.255.255.0
interface Loopback2121801
 ip address 212.18.0.1 255.255.255.0
interface Loopback2121811
 ip address 212.18.1.1 255.255.255.0
interface Loopback2121821
 ip address 212.18.2.1 255.255.255.0
interface Loopback2121831
 ip address 212.18.3.1 255.255.255.0
interface Loopback12109150
 ip address 12.109.15.0 255.255.255.255
interface Loopback12109151
 ip address 12.109.15.1 255.255.255.255
interface Loopback12109152
 ip address 12.109.15.2 255.255.255.255
interface Loopback12109153
 ip address 12.109.15.3 255.255.255.255
interface Loopback12109154
 ip address 12.109.15.4 255.255.255.255
interface Loopback12109155
 ip address 12.109.15.5 255.255.255.255
interface Loopback12109156
 ip address 12.109.15.6 255.255.255.255
interface Loopback12109157
 ip address 12.109.15.7 255.255.255.255
interface ATM0/0
 no atm ilmi-keepalive
 pvc 0/5 qsaal
 pvc 0/16 ilmi
interface ATM0/0.1 multipoint
ip address 54.1.1.254 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
 pvc 0/101
  protocol ip 54.1.1.6 broadcast
interface ATM0/0.2 multipoint
 ip address 54.1.4.254 255.255.255.0
 ip authentication mode eigrp 10 md5
 ip authentication key-chain eigrp 10 EIGRP
 atm esi-address 012345678922.20
 svc joe nsap 47.00000000000000000000000A.012345678911.10
  protocol ip 54.1.4.6 broadcast
interface Serial1/0
 ip address 172.16.4.1 255.255.255.0
 encapsulation frame-relay
 serial restart_delay 0
 frame-relay map ip 172.16.4.3 709 broadcast
 frame-relay lmi-type cisco
router eigrp 10
 network 54.0.0.0
 network 200.0.0.0 0.0.3.255
 metric weights 0 3 1 1 1 1
 distribute-list EIGRP out
 no auto-summary
 eigrp router-id 9.9.9.9
router bgp 54
no synchronization
 bgp log-neighbor-changes
 network 112.0.0.0
 network 113.0.0.0
 network 114.0.0.0 route-map SET_COMMUNITY_54
 network 115.0.0.0 route-map SET_COMMUNITY_54
 network 116.0.0.0
 network 117.0.0.0
 network 118.0.0.0
 network 119.0.0.0
 neighbor RACKS peer-group
 neighbor RACKS remote-as 100
 neighbor RACKS send-community
 neighbor RACKS route-map BGP_OUT out
 neighbor 54.1.1.6 peer-group RACKS
 neighbor 54.1.4.6 peer-group RACKS
 neighbor 172.16.4.3 remote-as 54
 neighbor 172.16.4.3 send-community
 no auto-summary
ip route 0.0.0.0 0.0.0.0 Null0
ip route 204.12.1.0 255.255.255.0 172.16.4.3
no ip http secure-server
ip as-path access-list 1 permit ^$
ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8
ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8
ip access-list standard EIGRP
 permit 200.0.0.0 0.0.3.255
ip access-list standard RIP
 permit 212.18.0.0 0.0.3.0
route-map SET_COMMUNITY_54 permit 10
 set community 54
route-map BGP_OUT permit 10
 match ip address prefix-list BGP_PREPEND_1
 set as-path prepend 50 60
route-map BGP_OUT permit 10000
 match as-path 1

hostname bb2
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
mpls ldp logging neighbor-changes
key chain RIP
 key 1
  key-string CISCO
no voice hpi capture buffer
no voice hpi capture destination
mta receive maximum-recipients 0
interface Loopback0
 description Addresses for VoIP
ip address 220.20.3.192 255.255.255.0
interface Loopback1
 description Addresses for VoIP
 ip address 222.22.2.1 255.255.255.0
interface Loopback3
 description Addresses for VoIP
 ip address 205.90.31.4 255.255.255.0 secondary
 ip address 205.90.31.1 255.255.255.0
interface Loopback51515151
 ip address 51.51.51.51 255.255.255.255
interface Ethernet0/0
 ip address 192.10.1.254 255.255.255.0
interface Serial0/0
 encapsulation frame-relay IETF
 frame-relay lmi-type cisco
interface Serial0/1
router bgp 254
 no synchronization
 bgp log-neighbor-changes
 redistribute connected route-map VOIP
 neighbor RACKS peer-group
 neighbor RACKS remote-as 200
neighbor RACKS route-map BGP_OUT out
 neighbor RACKS password CISCO
 neighbor 192.10.1.1 peer-group RACKS
 neighbor 192.10.1.2 peer-group RACKS
 neighbor 192.10.1.3 peer-group RACKS
 neighbor 192.10.1.4 peer-group RACKS
 neighbor 192.10.1.5 peer-group RACKS
 neighbor 192.10.1.6 peer-group RACKS
 neighbor 192.10.1.7 peer-group RACKS
 neighbor 192.10.1.8 peer-group RACKS
 no auto-summary
ip local policy route-map LOCAL
ip route 0.0.0.0 0.0.0.0 Null0
ip as-path access-list 1 permit ^$
ip prefix-list VOIP seq 5 permit 205.90.31.0/24
ip prefix-list VOIP seq 10 permit 220.20.3.0/24
ip prefix-list VOIP seq 15 permit 222.22.2.0/24
route-map VOIP permit 10
 match ip address prefix-list VOIP
route-map LO51515151 permit 10
 match interface Loopback51515151
route-map BGP_OUT permit 10000
 match as-path 1
route-map LOCAL permit 10
 set ip precedence critical
call rsvp-sync
voice-port 1/0/0
voice-port 1/0/1
dial-peer cor custom
dial-peer voice 1 pots
 destination-pattern 5281011
 port 1/0/0
dial-peer voice 2 pots
 destination-pattern 5281022
 port 1/0/0
dial-peer voice 3 pots
 destination-pattern 5283001
 port 1/0/0
dial-peer voice 4 pots
 destination-pattern 5284001
 port 1/0/0
dial-peer voice 5 pots
 destination-pattern 4085285001
 port 1/0/0
dial-peer voice 6 pots
 destination-pattern 4085286001
port 1/0/1
dial-peer voice 7 pots
 destination-pattern 5287007
 port 1/0/1
dial-peer voice 8 pots
 destination-pattern 5288888
 port 1/0/1
dial-peer voice 9 pots
 destination-pattern 5289999
 port 1/0/1
dial-peer voice 10 pots
 destination-pattern 100.
 port 1/0/1
dial-peer voice 11 pots
 destination-pattern 5281101
 port 1/0/1
dial-peer voice 12 pots
 destination-pattern 5281111
 port 1/0/1
dial-peer voice 13 pots
 destination-pattern 5282222
 port 1/0/1

hostname bb3
logging queue-limit 100
no logging console
ip subnet-zero
ip tcp synwait-time 5
no ip domain lookup
ip multicast-routing
ip cef
mpls ldp logging neighbor-changes
no voice hpi capture buffer
no voice hpi capture destination
mta receive maximum-recipients 0
interface Loopback0
 ip address 28.119.16.1 255.255.255.0
interface Loopback1
 ip address 28.119.17.1 255.255.255.0
interface Loopback10
ip address 30.0.0.1 255.255.0.0
interface Loopback11
 ip address 30.1.0.1 255.255.0.0
interface Loopback12
 ip address 30.2.0.1 255.255.0.0
interface Loopback13
 ip address 30.3.0.1 255.255.0.0
interface Loopback14
 ip address 31.0.0.1 255.255.0.0
interface Loopback15
 ip address 31.1.0.1 255.255.0.0
interface Loopback16
 ip address 31.2.0.1 255.255.0.0
interface Loopback17
 ip address 31.3.0.1 255.255.0.0
interface FastEthernet0/0
 ip address 204.12.1.254 255.255.255.0
interface Serial0/0
 ip address 172.16.4.3 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 172.16.4.1 907 broadcast
 frame-relay lmi-type cisco
router bgp 54
 no synchronization
 bgp log-neighbor-changes
 network 28.119.16.0 mask 255.255.255.0
 network 28.119.17.0 mask 255.255.255.0
 neighbor RACKS peer-group
 neighbor RACKS remote-as 100
 neighbor RACKS send-community
 neighbor RACKS route-map BGP_OUT out
 neighbor 172.16.4.1 remote-as 54
 neighbor 172.16.4.1 send-community
 neighbor 204.12.1.1 peer-group RACKS
 neighbor 204.12.1.2 peer-group RACKS
 neighbor 204.12.1.3 peer-group RACKS
 neighbor 204.12.1.4 peer-group RACKS
 neighbor 204.12.1.5 peer-group RACKS
 neighbor 204.12.1.6 peer-group RACKS
 neighbor 204.12.1.7 peer-group RACKS
 neighbor 204.12.1.8 peer-group RACKS
 no auto-summary
ip route 0.0.0.0 0.0.0.0 Null0
ip route 54.0.0.0 255.0.0.0 172.16.4.1
ip prefix-list BGP_PREPEND_1 seq 5 permit 112.0.0.0/8
ip prefix-list BGP_PREPEND_1 seq 10 permit 113.0.0.0/8
ip prefix-list RIP seq 5 permit 30.0.0.0/14 ge 16 le 16
ip prefix-list RIP seq 10 permit 31.0.0.0/14 ge 16 le 16
route-map BGP_OUT permit 10
 match ip address prefix-list BGP_PREPEND_1
 set as-path prepend 50 60
route-map BGP_OUT permit 10000
call rsvp-sync
dial-peer cor custom
 login
 transport preferred none



This archive was generated by hypermail 2.1.4 : Mon May 03 2004 - 19:48:43 GMT-3