OSPF route missing?

From: Mark Rushby (mark@tisolutions.biz)
Date: Fri Apr 02 2004 - 04:57:56 GMT-3


Hi All

I have the following topology:

R2 (Hub)-------------R6
|
| ospf 1
|
R5

The configs are below. The problem is that I cannot seem to get R2
loop0 address (area 2) into the routing tables of R5 and R6. I have
included the routing table and ospf data tables from R5. I have
reconfigured the ospf process twice with no success. Any help
suggestions would be appreciated.

TIA

Mark

R2#sh run
Building configuration...

Current configuration : 2547 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
!
key chain r4
 key 1
  key-string ipexpert
!
!
!

!
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
!
interface Ethernet0
 ip address 172.16.12.2 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no frame-relay inverse-arp
!
interface Serial0.24 point-to-point
 ip address 172.16.24.2 255.255.255.252
 ip authentication mode eigrp 40 md5
 ip authentication key-chain eigrp 40 r4
 frame-relay interface-dlci 104
!
interface Serial0.256 multipoint
 ip address 172.16.0.2 255.255.255.248
 frame-relay map ip 172.16.0.5 105 broadcast
 frame-relay map ip 172.16.0.6 106 broadcast
 frame-relay map ip 172.16.0.2 105
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router eigrp 40
 network 172.16.24.0 0.0.0.3
 no auto-summary
 eigrp log-neighbor-changes
!
router ospf 1
 log-adjacency-changes
 area 1 virtual-link 192.168.5.5 message-digest-key 1 md5 ipexpert
 area 1 virtual-link 192.168.6.6 message-digest-key 1 md5 ipexpert
 redistribute connected subnets route-map conet2ospf
 network 172.16.0.0 0.0.0.7 area 1
 network 192.168.2.2 0.0.0.0 area 2
 neighbor 172.16.0.5
 neighbor 172.16.0.6
!
ip classless
ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.2.2
access-list 1 permit 172.16.24.0 0.0.0.3
access-list 1 permit 172.16.25.0 0.0.0.255
access-list 1 permit 172.16.12.0 0.0.0.255
access-list 1 permit 172.16.0.0 0.0.0.7
route-map conet2ospf permit 10
 match ip address 1
 set tag 222
!
!
alias exec c conf t
alias exec crs copy run start
alias exec sir sh ip route
alias exec sib sh ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
end

********************************************

R5#sh run
Building configuration...

Current configuration : 1342 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 192.168.5.5 255.255.255.255
!
interface Ethernet0
 ip address 172.16.200.5 255.255.255.128
 ip ospf authentication message-digest
 ip ospf authentication-key ipexpert
 ip ospf hello-interval 15
!
interface Serial0
 ip address 172.16.0.5 255.255.255.248
 encapsulation frame-relay
 ip ospf priority 0
 frame-relay map ip 172.16.0.5 501
 frame-relay map ip 172.16.0.6 501 broadcast
 frame-relay map ip 172.16.0.2 501 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
!
router ospf 1
 log-adjacency-changes
 area 0 authentication message-digest
 area 1 virtual-link 192.168.2.2 message-digest-key 1 md5 ipexpert
 network 172.16.0.0 0.0.0.7 area 1
 network 172.16.200.0 0.0.0.127 area 0
 network 192.168.5.5 0.0.0.0 area 5
!
ip classless
ip http server
ip pim bidir-enable
!
!
alias exec c conf t
alias exec crs copy run start
alias exec sir sh ip route
alias exec sib sh ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
end

Gateway of last resort is not set

     192.168.9.0/32 is subnetted, 1 subnets
O E2 192.168.9.9 [110/20] via 172.16.200.6, 00:14:44, Ethernet0
     172.16.0.0/16 is variably subnetted, 6 subnets, 5 masks
O IA 172.16.90.128/28 [110/84] via 172.16.200.6, 00:14:44, Ethernet0
C 172.16.200.0/25 is directly connected, Ethernet0
O E2 172.16.24.0/30 [110/20] via 172.16.0.2, 00:14:44, Serial0
O E2 172.16.12.0/24 [110/20] via 172.16.0.2, 00:14:44, Serial0
C 172.16.0.0/29 is directly connected, Serial0
O IA 172.16.69.0/30 [110/74] via 172.16.200.6, 00:14:45, Ethernet0
     192.168.5.0/32 is subnetted, 1 subnets
C 192.168.5.5 is directly connected, Loopback0
     192.168.6.0/32 is subnetted, 1 subnets
O IA 192.168.6.6 [110/11] via 172.16.200.6, 00:14:45, Ethernet0
     192.168.7.0/32 is subnetted, 1 subnets
O 192.168.7.7 [110/11] via 172.16.200.7, 00:14:46, Ethernet0

R5#sh ip ospf dat

            OSPF Router with ID (192.168.5.5) (Process ID 1)

                Router Link States (Area 0)

Link ID ADV Router Age Seq# Checksum Link
count
192.168.5.5 192.168.5.5 938 0x80000004 0x56D1 1
192.168.6.6 192.168.6.6 925 0x80000002 0x46DE 1
192.168.7.7 192.168.7.7 478 0x80000006 0x583A 2

                Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
172.16.200.7 192.168.7.7 924 0x80000002 0x450B

                Summary Net Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
172.16.0.0 192.168.5.5 1224 0x80000002 0xDC5
172.16.0.0 192.168.6.6 929 0x80000001 0x2CF
172.16.69.0 192.168.6.6 929 0x80000001 0x2068
172.16.90.128 192.168.6.6 929 0x80000001 0x4FA5
192.168.5.5 192.168.5.5 1227 0x80000005 0x232E
192.168.6.6 192.168.6.6 929 0x80000001 0x948

                Summary ASB Link States (Area 0)

Link ID ADV Router Age Seq# Checksum
192.168.2.2 192.168.5.5 1229 0x80000002 0xD247
192.168.2.2 192.168.6.6 1374 0x80000001 0xC751
192.168.9.9 192.168.6.6 931 0x80000001 0x34D6

                Router Link States (Area 1)

Link ID ADV Router Age Seq# Checksum Link
count
192.168.2.2 192.168.2.2 1402 0x80000003 0xF69F 1
192.168.5.5 192.168.5.5 1226 0x80000006 0xAED7 1
192.168.6.6 192.168.6.6 928 0x80000007 0x98E7 1

                Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum
172.16.0.2 192.168.2.2 1387 0x80000002 0xCCEC

                Summary Net Link States (Area 1)

Link ID ADV Router Age Seq# Checksum
172.16.69.0 192.168.5.5 916 0x80000001 0x91EE
172.16.69.0 192.168.6.6 928 0x80000004 0x1A6B
172.16.90.128 192.168.5.5 918 0x80000001 0xC02C
172.16.90.128 192.168.6.6 928 0x80000004 0x49A8
172.16.200.0 192.168.5.5 933 0x8000000A 0x6B45
172.16.200.0 192.168.6.6 919 0x80000008 0x624E
192.168.2.2 192.168.2.2 1389 0x80000004 0x8BD2
192.168.5.5 192.168.5.5 1229 0x80000005 0x232E
192.168.5.5 192.168.6.6 924 0x80000001 0x82C6
192.168.6.6 192.168.5.5 918 0x80000001 0x7ACE
192.168.6.6 192.168.6.6 928 0x80000004 0x34B
192.168.7.7 192.168.5.5 1223 0x80000001 0x65E1
192.168.7.7 192.168.6.6 924 0x80000001 0x58EC

                Summary ASB Link States (Area 1)

Link ID ADV Router Age Seq# Checksum
192.168.7.7 192.168.5.5 1223 0x80000001 0x4DF9
192.168.7.7 192.168.6.6 925 0x80000001 0x4005
192.168.9.9 192.168.5.5 919 0x80000001 0xA55D
192.168.9.9 192.168.6.6 929 0x80000004 0x2ED9

                Router Link States (Area 5)

Link ID ADV Router Age Seq# Checksum Link
count
192.168.5.5 192.168.5.5 1244 0x80000001 0x7F57 1

                Summary Net Link States (Area 5)

Link ID ADV Router Age Seq# Checksum
172.16.0.0 192.168.5.5 1235 0x80000001 0xFC4
172.16.69.0 192.168.5.5 920 0x80000001 0x91EE
172.16.90.128 192.168.5.5 920 0x80000001 0xC02C
172.16.200.0 192.168.5.5 935 0x80000003 0x793E
192.168.6.6 192.168.5.5 920 0x80000001 0x7ACE
192.168.7.7 192.168.5.5 1225 0x80000001 0x65E1

                Summary ASB Link States (Area 5)

Link ID ADV Router Age Seq# Checksum
192.168.2.2 192.168.5.5 1235 0x80000001 0xD446
192.168.7.7 192.168.5.5 1225 0x80000001 0x4DF9
192.168.9.9 192.168.5.5 920 0x80000001 0xA55D

                Type-5 AS External Link States

Link ID ADV Router Age Seq# Checksum Tag
172.16.12.0 192.168.2.2 1534 0x80000001 0x6328 222
172.16.24.0 192.168.2.2 1536 0x80000001 0xCCB5 222
192.168.9.9 192.168.9.9 579 0x80000004 0x7249 999
R5#

************************************************

R6#sh run
Building configuration...

Current configuration : 1398 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
enable password cisco
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 192.168.6.6 255.255.255.255
!
interface Ethernet0
 ip address 172.16.200.6 255.255.255.128
 ip ospf authentication message-digest
 ip ospf authentication-key ipexpert
 ip ospf hello-interval 15
!
interface Ethernet1
 no ip address
 shutdown
!
interface Serial0
 ip address 172.16.0.6 255.255.255.248
 encapsulation frame-relay
 ip ospf priority 0
 frame-relay map ip 172.16.0.5 601 broadcast
 frame-relay map ip 172.16.0.6 601
 frame-relay map ip 172.16.0.2 601 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 ip address 172.16.69.1 255.255.255.252
!
router ospf 1
 log-adjacency-changes
 area 0 authentication message-digest
 area 1 virtual-link 192.168.2.2 message-digest-key 1 md5 ipexpert
 network 172.16.0.0 0.0.0.7 area 1
 network 172.16.69.0 0.0.0.3 area 9
 network 172.16.200.0 0.0.0.127 area 0
 network 192.168.6.6 0.0.0.0 area 6
!
ip classless
ip http server
ip pim bidir-enable
!
!
alias exec c conf t
alias exec crs copy run start
alias exec sir sh ip route
alias exec sib sh ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 exec-timeout 0 0
 password cisco
 logging synchronous
 login
!
end

R6#



This archive was generated by hypermail 2.1.4 : Mon May 03 2004 - 19:48:41 GMT-3