RE: Multicast over NBMA again!

From: Michael Snyder (msnyder@revolutioncomputer.com)
Date: Thu Feb 05 2004 - 22:37:35 GMT-3


R2 is the hub, R5 and R6 are the spokes. The DR priority command sets
the dr to r2. Does this help me? I think it does. I mean R5 can't
speak to R6 directly so I'm sure I don't want it to be the dr for the
nbma network segment. See below. I'm just learning multicast myself.

R2#show run
Building configuration...
!
ip multicast-routing
!
!
!
interface Loopback0
 ip address 192.168.2.2 255.255.255.255
 ip pim sparse-mode

interface Serial0.56 multipoint
 ip address 172.16.56.2 255.255.255.248
 ip pim dr-priority 1000
 ip pim nbma-mode
 ip pim sparse-dense-mode
 ip ospf hello-interval 2
 ip ospf priority 255
 frame-relay map ip 172.16.56.2 105
 frame-relay map ip 172.16.56.5 105 broadcast
 frame-relay map ip 172.16.56.6 106 broadcast

ip pim send-rp-announce Loopback0 scope 10 group-list 77
ip pim send-rp-discovery Loopback0 scope 10
!
access-list 77 permit 227.1.1.1
access-list 77 permit 239.1.1.1

R2#show ip pim int

Address Interface Ver/ Nbr Query DR DR
                                          Mode Count Intvl Prior
192.168.2.2 Loopback0 v2/S 0 30 1
192.168.2.2
172.16.56.2 Serial0.56 v2/SD 2 30 1000
172.16.56.2

IP Multicast Routing Table

(*, 224.0.1.39), 00:03:22/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:03:03/00:02:58
    Serial0.56, Forward/Sparse-Dense, 00:03:22/00:00:00

(192.168.2.2, 224.0.1.39), 00:03:22/00:02:37, flags: CLT
  Incoming interface: Loopback0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0.56, Forward/Sparse-Dense, 00:03:03/00:00:00

(*, 224.0.1.40), 00:07:21/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Loopback0, Forward/Sparse, 00:03:05/00:02:57
    Serial0.56, Forward/Sparse-Dense, 00:07:21/00:00:00

(192.168.2.2, 224.0.1.40), 00:02:24/00:02:34, flags: CLT
  Incoming interface: Loopback0, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0.56, Forward/Sparse-Dense, 00:02:24/00:00:00

R2#

R5#st s0
Building configuration...

Current configuration : 374 bytes
!
interface Serial0
 ip address 172.16.56.5 255.255.255.248
 ip pim nbma-mode
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf hello-interval 2
 ip ospf priority 0
 frame-relay map ip 172.16.56.2 501 broadcast
 frame-relay map ip 172.16.56.5 501
 frame-relay map ip 172.16.56.6 501
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
end

R5#show ip pim int

Address Interface Ver/ Nbr Query DR DR
                                          Mode Count Intvl Prior
172.16.56.5 Serial0 v2/SD 1 30 1
172.16.56.2

R5#show ip pim rp-hash 227.1.1.1
  RP 192.168.2.2 (?), v2v1
    Info source: 192.168.2.2 (?), via Auto-RP
         Uptime: 00:01:24, expires: 00:02:33

R5#show ip mroute

IP Multicast Routing Table
 (*, 224.0.1.39), 00:03:09/00:02:50, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0, Forward/Sparse-Dense, 00:03:09/00:00:00

(*, 224.0.1.40), 00:06:03/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0, Forward/Sparse-Dense, 00:06:03/00:00:00

(192.168.2.2, 224.0.1.40), 00:02:10/00:02:48, flags: PCLTA
  Incoming interface: Serial0, RPF nbr 172.16.56.2
  Outgoing interface list: Null

R5#

R6#st s0
Building configuration...

Current configuration : 416 bytes
!
interface Serial0
 ip address 172.16.56.6 255.255.255.248
 ip pim nbma-mode
 ip pim sparse-dense-mode
 encapsulation frame-relay
 ip ospf message-digest-key 1 md5 michael
 ip ospf hello-interval 2
 ip ospf priority 0
 frame-relay map ip 172.16.56.2 601 broadcast
 frame-relay map ip 172.16.56.5 601
 frame-relay map ip 172.16.56.6 601
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
end

R6#show ip pim rp-hash 227.1.1.1
  RP 192.168.2.2 (?), v2v1
    Info source: 192.168.2.2 (?), via Auto-RP
         Uptime: 00:01:49, expires: 00:02:04

R6#show ip mroute

(*, 224.0.1.39), 00:02:58/00:02:59, RP 0.0.0.0, flags: DJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0, Forward/Sparse-Dense, 00:02:58/00:00:00

(192.168.2.2, 224.0.1.39), 00:02:58/00:00:01, flags: PCTA
  Incoming interface: Serial0, RPF nbr 172.16.56.2
  Outgoing interface list: Null

(*, 224.0.1.40), 00:05:32/00:00:00, RP 0.0.0.0, flags: DJCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Serial0, Forward/Sparse-Dense, 00:05:34/00:00:00

(192.168.2.2, 224.0.1.40), 00:02:00/00:02:58, flags: PCLTA
  Incoming interface: Serial0, RPF nbr 172.16.56.2
  Outgoing interface list: Null

R6#
R6#show ip pim int

Address Interface Ver/ Nbr Query DR DR
                                          Mode Count Intvl Prior
172.16.56.6 Serial0 v2/SD 1 30 1
172.16.56.2

-----Original Message-----
From: alsontra@hotmail.com [mailto:alsontra@hotmail.com]
Sent: Thursday, February 05, 2004 9:08 PM
To: Michael Snyder; ccielab@groupstudy.com
Cc: 'Hossam'
Subject: Re: Multicast over NBMA again!

Although, I can't recall why or find any supporting information at the
moment. I remember reading somewhere that if your going to use pim
sparse
you should use pim spare-dense mode to avoid the chicken or the egg
problem.
I also recall that on NBMA interface you should use sparse mode, don't
remember why. (scary thought)

In any event, I'm using only sparse mode on NBMA interfaces and in most
possible permutations (Auto-RP, c-BSR, RP's located behind spokes) and
all
configurations have worked. Also, thanks for the information regarding
ip
pim DR. I thought the DR process only applied to multi-access networks.
Or
At least that's what I think I read in, Cisco Press's Developing IP
Multicast Networks.

Thanks,
Alsontra

----- Original Message -----
From: "Michael Snyder" <msnyder@revolutioncomputer.com>
To: <ccielab@groupstudy.com>
Cc: "'Hossam'" <sam6626@yahoo.com>; <alsontra@hotmail.com>
Sent: Thursday, February 05, 2004 4:33 PM
Subject: RE: Multicast over NBMA again!

> I could be wrong, but I remember that auto-rp doesn't work without
> sparse-dense mode. How could it, it uses multicast to advertise the
rp
> groups? Chicken and egg problem.
>
> So, if you use sparse mode, you have to use a static rp.
>
> Auto-rp has to have sparse-dense mode to function.
>
> Sparse-mode will work fine with static rp.
>
> One more thing, on the multipoint frame-relay (or even multipoint
isdn)
>
> Run ip pim nbma-mode on the interfaces
>
> And on the hub interface run the following command,
>
> ip pim dr-priority 1000
>
> Why? Same reason you make the ospf process the highest priority on
the
> hub interface, it can speak to all the spokes.
>
> interface Serial0.56 multipoint
> ip address 172.16.56.2 255.255.255.248
> ip pim dr-priority 1000
> ip pim nbma-mode
> ip ospf hello-interval 2
> ip ospf priority 255
> frame-relay map ip 172.16.56.2 105
> frame-relay map ip 172.16.56.5 105 broadcast
> frame-relay map ip 172.16.56.6 106 broadcast
>
>
> I could be wrong on some this, your mileage may vary, but the above
> config(s) have worked well for me in practice labs.
>
>
> -----Original Message-----
> From: alsontra@hotmail.com [mailto:alsontra@hotmail.com]
> Sent: Thursday, February 05, 2004 7:49 PM
> To: Hossam
> Cc: ccielab@groupstudy.com
> Subject: Re: Multicast over NBMA again!
>
> Sorry about that. I was running a similar configuration yesterday, and
> there
> are a few things I notice right off about yours. Sparse-dense mode is
> not
> recommended for NBMA interfaces, I think sparse should be used. Also
you
> need
> to issue the ip pim nbma-mode command on the serial interfaces( I used
> this
> command on all NBMA attached interfaces)
>
> ip pim nbma-mode <------This allows multipule mappings on your serial
> ip pim sparse-mode
>
> After you've add those, I would verify that the RP address is
> registering with
> the spoke clients.
>
> (sh ip pim rp )
>
> Should look like this: Group: 228.1.1.1, RP: 223.1.1.2, v1, uptime
> 04:01:38,
> expires 00:03:18
>
> There are some exellent post regarding this topic, do a search for
Brian
> McGahan's last post regarding multicast.
>
> Hope this helps,
> Alsontra
>
>



This archive was generated by hypermail 2.1.4 : Fri Mar 05 2004 - 07:13:47 GMT-3