Redistribution with distances

From: Charles T. Alexander (charles.t.alexander@verizon.net)
Date: Thu Jan 29 2004 - 16:05:49 GMT-3


Having trouble with redistribution using distance. Doing IPExpert #37

r2- - r6 ------- r9
    - - |
   FR(ISIS) | EIGRP
    - - |
  - - |
r5 r4--- r7 ----r8

The frame is ISIS. r6,r4,r7 ethernet, r6 to r9 serial, r7 to r8 token ring

Prior to redistribution the isis routers were internally pingable as were the EIGRP routers.
After redistribution at r6 only, the ISIS routes were redistributed to EIGRP but the EIGRP routes were not redistributed to

ISIS.

Attached first is r6 (the only router that redistributed).

r6#r
Building configuration...

Current configuration : 2836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname r6
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
!
ip cef
ip audit notify log
ip audit po max-events 100
!
!
key chain cta_vlanc
 key 1
  key-string cta_vlanc
key chain cta_r69
 key 1
  key-string cta_r69
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 137.10.6.6 255.255.255.0
 ip router isis
!
interface Ethernet0/0
 ip address 137.10.74.6 255.255.255.192
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_vlanc
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 ip address 137.10.100.6 255.255.255.224
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map clns 604 broadcast
 frame-relay map ip 137.10.100.2 604 broadcast
 frame-relay map ip 137.10.100.4 604 broadcast
 frame-relay map ip 137.10.100.6 604
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/1
 bandwidth 1544
 ip address 137.10.69.6 255.255.255.240
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_r69
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface ATM2/0
 description 2 24 12 2
 bandwidth 149760
 no ip address
 shutdown
 atm ilmi-keepalive
 pvc 0/5 qsaal
 !
 pvc 0/16 ilmi
 !
!
interface ATM2/0.1 multipoint
 ip address 137.11.69.6 255.255.255.240
 atm esi-address 666666666666.00
 !
 svc nsap 10.000000000000000000000000.999999999999.00
  protocol ip 137.11.69.9 broadcast
  encapsulation aal5snap
  idle-timeout 10
 !
 !
 svc 100000000000000
  protocol ip 137.11.69.6
  encapsulation aal5snap
  idle-timeout 10
 !
!
router eigrp 100
 redistribute connected metric 1544 2000 255 1 1500 route-map c2e
 redistribute isis level-2 metric 1544 2000 255 1 1500
 network 137.10.69.0 0.0.0.15
 network 137.10.74.0 0.0.0.63
 no auto-summary
!
router isis
 net 49.0426.6666.6666.6666.00
 redistribute eigrp 100 metric 10
 distance 171 ip
 distance 169 137.10.4.4 0.0.0.2
!
ip classless
no ip http server
!
access-list 1 permit 137.10.6.0 0.0.0.255
access-list 1 permit 137.10.100.0 0.0.0.31
route-map c2e permit 10
 match ip address 1
!
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r6#
--------------------------------------------------
r4#r
Building configuration...

Current configuration : 2255 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
logging buffered 10000 debugging
logging rate-limit console 10 except errors
enable password radnor
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
key chain cta_vlanc
 key 1
  key-string cta_vlanc
!
!
!
!
interface Loopback0
 ip address 137.10.4.4 255.255.255.0
 ip router isis
!
interface Ethernet0
 ip address 137.10.74.4 255.255.255.192
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_vlanc
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 frame-relay lmi-type ansi
!
interface Serial0.5 multipoint
 ip address 137.10.45.4 255.255.255.240
 ip router isis 45
 no ip mroute-cache
 frame-relay map clns 405 broadcast
 frame-relay map ip 137.10.45.4 405 IETF payload-compression FRF9 stac
 frame-relay map ip 137.10.45.5 405 broadcast IETF payload-compression FRF9 stac
 isis hello-multiplier 20
!
interface Serial0.26 multipoint
 ip address 137.10.100.4 255.255.255.224
 ip router isis
 no ip mroute-cache
 frame-relay map clns 401 broadcast
 frame-relay map clns 406 broadcast
 frame-relay map ip 137.10.100.2 401 broadcast
 frame-relay map ip 137.10.100.4 401
 frame-relay map ip 137.10.100.6 406 broadcast
 no frame-relay inverse-arp
 isis priority 127
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 100
 network 137.10.74.0 0.0.0.63
 no auto-summary
 no eigrp log-neighbor-changes
!
router isis
 redistribute isis ip level-2 into level-1 distribute-list 103
 net 49.0426.4444.4444.4444.00
 max-lsp-lifetime 1800
!
router isis 45
 net 49.0045.4444.4444.4444.00
 is-type level-1
!
ip kerberos source-interface any
ip classless
ip http server
!
access-list 103 permit ip host 137.10.2.0 any
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line 1 8
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r4#
--------------------------------------------------
r2#r
Building configuration...

Current configuration : 2151 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
boot system tftp r2-ios-image 137.10.74.62
logging buffered 10000 debugging
enable password radnor
!
username r5 password 0 ctasta
ip subnet-zero
no ip domain-lookup
ip host r1 137.10.125.1
!
isdn switch-type basic-ni
!
!
!
interface Loopback0
 ip address 137.10.2.2 255.255.255.0
 ip router isis
!
interface Ethernet0
 backup delay 5 60
 backup interface BRI0
 ip address 137.10.125.2 255.255.255.0
 ip ospf hello-interval 1
 ip ospf priority 0
!
interface Serial0
 ip address 137.10.100.2 255.255.255.224
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 104 broadcast
 frame-relay map ip 137.10.100.2 104
 frame-relay map ip 137.10.100.4 104 broadcast
 frame-relay map ip 137.10.100.6 104 broadcast
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 137.10.25.2 255.255.255.252
 encapsulation ppp
 dialer map ip 137.10.25.1 name r5 broadcast 4082222222
 dialer load-threshold 99 either
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 40811111111
 isdn spid2 40811111112
 no peer neighbor-route
 no cdp enable
 ppp authentication chap callin
 ppp multilink
 hold-queue 25 in
!
router ospf 1
 router-id 137.10.2.2
 log-adjacency-changes
 timers lsa-group-pacing 600
 network 137.10.25.0 0.0.0.3 area 1
 network 137.10.125.0 0.0.0.255 area 0
!
router isis
 net 49.0102.2222.2222.2222.00
 is-type level-2-only
!
ip classless
ip http server
ip ospf name-lookup
ip pim bidir-enable
!
access-list 101 permit icmp any any
access-list 101 permit ip any host 137.10.125.10
access-list 101 permit tcp any any eq bgp
access-list 101 permit ospf any any
dialer-list 1 protocol ip list 101
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r2#
-------------------------------------------------------------
r5#r
Building configuration...

Current configuration : 2623 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r5
!
logging buffered 10000 debugging
enable password radnor
!
username r2 password 0 ctasta
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
isdn switch-type basic-ni
!
key chain chucko50
 key 1
  key-string ctasta50
!
!
!
!
!
interface Loopback0
 ip address 137.10.5.5 255.255.255.0
 ip router isis
!
interface Loopback1
 ip address 205.1.1.1 255.255.255.224
!
interface Loopback2
 ip address 205.1.1.33 255.255.255.224
!
interface Loopback3
 ip address 205.1.1.65 255.255.255.224
!
interface BRI0/0
 ip address 137.10.25.1 255.255.255.0
 encapsulation ppp
 dialer idle-timeout 0
 dialer map ip 137.10.25.2 name r2 broadcast
 dialer-group 1
 isdn switch-type basic-ni
 isdn spid1 40822222221
 isdn spid2 40822222222
 no peer neighbor-route
 no cdp enable
 ppp authentication chap pap
!
interface Ethernet0/0
 ip address 137.10.50.5 255.255.255.0
 ip rip authentication mode md5
 ip rip authentication key-chain chucko50
!
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Serial1/0
 ip address 137.10.45.5 255.255.255.240
 ip router isis
 encapsulation frame-relay
 no ip mroute-cache
 random-detect
 serial restart-delay 0
 isis hello-multiplier 20
 frame-relay map clns 504 broadcast
 frame-relay map ip 137.10.45.4 504 broadcast IETF payload-compression FRF9 stac
 frame-relay map ip 137.10.45.5 504 IETF payload-compression FRF9 stac
 frame-relay lmi-type ansi
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 137.10.5.5
 log-adjacency-changes
 network 137.10.25.0 0.0.0.3 area 1
!
router isis
 redistribute connected metric 10 route-map c2i level-1
 net 49.0045.5555.5555.5555.00
!
router rip
 version 2
 timers basic 40 120 180 240
 passive-interface default
 no passive-interface Ethernet0/0
 output-delay 50
 network 137.10.0.0
 no auto-summary
!
ip classless
ip http server
!
access-list 1 permit 205.1.1.0 0.0.0.127
dialer-list 1 protocol ip permit
route-map c2i permit 10
 match ip address 1
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r5#
--------------------------------------------------
r7#r
Building configuration...

Current configuration : 1579 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
logging buffered 10000 debugging
enable password radnor
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
key chain cta_vlanc
 key 1
  key-string cta_vlanc
key chain cta_r78
 key 1
  key-string cta_r78
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
!
!
interface Loopback0
 ip address 137.10.7.7 255.255.255.0
!
interface BRI0/0
 no ip address
 shutdown
!
interface Ethernet0/0
 ip address 137.10.74.7 255.255.255.192
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_vlanc
!
interface TokenRing0/0
 ip address 137.10.78.7 255.255.255.128
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_r78
 ring-speed 16
!
router eigrp 100
 variance 5
 redistribute connected metric 16000 20 254 1 1500 route-map c2e
 offset-list 1 in 1923328 TokenRing0/0
 network 137.10.74.0 0.0.0.63
 network 137.10.78.0 0.0.0.127
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
access-list 1 permit 137.10.98.0 0.0.0.255
access-list 2 permit 137.10.7.0 0.0.0.255
route-map c2e permit 10
 match ip address 2
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r7#
--------------------------------------------------------
r8#r
Building configuration...

Current configuration : 1706 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r8
!
logging buffered 10000 debugging
logging rate-limit console 10 except errors
enable password radnor
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip host bb2 137.10.98.100
!
no ip dhcp-client network-discovery
!
key chain cta_r78
 key 1
  key-string cta_r78
!
!
!
!
interface Loopback0
 ip address 137.10.8.8 255.255.255.0
!
interface Ethernet0
 ip address 137.10.98.8 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 ip address 137.10.78.8 255.255.255.128
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_r78
 ring-speed 16
!
router eigrp 100
 variance 5
 timers active-time disabled
 redistribute connected metric 16000 40 254 1 1500 route-map c2e
 offset-list 1 in 1923328 TokenRing0
 network 137.10.78.0 0.0.0.127
 network 137.10.98.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
ip http server
!
access-list 1 deny 137.10.9.0
access-list 1 deny 192.177.0.0 0.0.3.0
access-list 1 permit any
access-list 2 permit 137.10.8.0 0.0.0.255
route-map c2e permit 10
 match ip address 2
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r8#
r8#
-------------------------------------------------------

r9#r
Building configuration...

Current configuration : 1708 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r9
!
logging buffered 10000 debugging
logging rate-limit console 10 except errors
enable password radnor
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
key chain cta_r69
 key 1
  key-string cta_r69
!
!
!
!
interface Loopback0
 ip address 137.10.9.9 255.255.255.0
!
interface Ethernet0
 ip address 137.10.98.9 255.255.255.0
!
interface Serial0
 bandwidth 1544
 ip address 137.10.69.9 255.255.255.240
 ip authentication mode eigrp 100 md5
 ip authentication key-chain eigrp 100 cta_r69
 no fair-queue
 clockrate 2000000
!
interface Serial1
 ip address 137.10.90.10 255.255.255.0
 no ip split-horizon eigrp 900
 no keepalive
!
router eigrp 100
 timers active-time disabled
 redistribute connected metric 1544 40 254 1 1500 route-map c2e
 redistribute eigrp 900
 network 137.10.69.0 0.0.0.15
 network 137.10.98.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
router eigrp 900
 redistribute eigrp 100
 network 137.10.90.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
ip http server
!
access-list 1 permit 137.10.9.0 0.0.0.255
route-map c2e permit 10
 match ip address 1
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end
          
r9#



This archive was generated by hypermail 2.1.4 : Mon Feb 02 2004 - 09:07:52 GMT-3