EIGRP Dual Paths

From: Charles T. Alexander (charles.t.alexander@verizon.net)
Date: Tue Jan 06 2004 - 23:21:20 GMT-3


I have an EIGRP domain.

r6 ---serial-------- r9
 | |
ethernet ethernet
 | |
r7 ---token ring ---r8

I can ping all around. The route table showes r7 to r9 through token
ring. If I shut the token ring I can ping r9 the other
way.

However the route table doesn't show two paths from r7 to r9. I don't
understand why not.

r7#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     137.10.0.0/16 is variably subnetted, 5 subnets, 4 masks
C 137.10.7.0/24 is directly connected, Loopback0
D 137.10.69.0/28 [90/2195456] via 137.10.74.6, 00:34:38,
Ethernet0/0
C 137.10.74.0/26 is directly connected, Ethernet0/0
C 137.10.78.0/25 is directly connected, TokenRing0/0
D 137.10.98.0/24 [90/297728] via 137.10.78.8, 00:34:38,
TokenRing0/0
D EX 192.177.0.0/24 [170/425728] via 137.10.78.8, 00:29:24, TokenRing0/0

D EX 192.177.1.0/24 [170/425728] via 137.10.78.8, 00:29:25, TokenRing0/0

D EX 192.177.2.0/24 [170/425728] via 137.10.78.8, 00:29:25, TokenRing0/0

D EX 192.177.3.0/24 [170/425728] via 137.10.78.8, 00:29:25, TokenRing0/0

r7#

--------------------
r6#r
Building configuration...

Current configuration : 2328 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service single-slot-reload-enable
!
hostname r6
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
!
ip cef
ip audit notify log
ip audit po max-events 100
!
!
key chain cta_vlanc
 key 1
  key-string cta_vlanc
key chain cta_r69
 key 1
  key-string cta_r69
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 137.10.6.6 255.255.255.0
 ip router isis
!
interface Ethernet0/0
 ip address 137.10.74.6 255.255.255.192
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Serial1/0
 ip address 137.10.100.6 255.255.255.224
 ip router isis
 encapsulation frame-relay
 serial restart-delay 0
 frame-relay map clns 604 broadcast
 frame-relay map ip 137.10.100.2 604 broadcast
 frame-relay map ip 137.10.100.4 604 broadcast
 frame-relay map ip 137.10.100.6 604
 no frame-relay inverse-arp
 frame-relay lmi-type ansi
!
interface Serial1/1
 bandwidth 1544
 ip address 137.10.69.6 255.255.255.240
 serial restart-delay 0
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface ATM2/0
 description 2 24 12 2
 bandwidth 149760
 no ip address
 shutdown
 atm ilmi-keepalive
 pvc 0/5 qsaal
 !
 pvc 0/16 ilmi
 !
!
interface ATM2/0.1 multipoint
 ip address 137.11.69.6 255.255.255.240
 atm esi-address 666666666666.00
 !
 svc 100000000000000
  protocol ip 137.11.69.6
  encapsulation aal5snap
  idle-timeout 10
 !
 !
 svc nsap 10.000000000000000000000000.999999999999.00
  protocol ip 137.11.69.9 broadcast
  encapsulation aal5snap
  idle-timeout 10
 !
!
router eigrp 100
 network 137.10.69.0 0.0.0.15
 network 137.10.74.0 0.0.0.63
 no auto-summary
!
router isis
 net 49.0426.6666.6666.6666.00
!
ip classless
no ip http server
!
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r6#

----------------------

r7#r
Building configuration...

Current configuration : 1160 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r7
!
logging buffered 10000 debugging
enable password radnor
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
!
key chain cta_vlanc
 key 1
  key-string cta_vlanc
key chain cta_r78
 key 1
  key-string cta_r78
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
!
!
interface Loopback0
 ip address 137.10.7.7 255.255.255.0
!
interface BRI0/0
 no ip address
 shutdown
!
interface Ethernet0/0
 ip address 137.10.74.7 255.255.255.192
!
interface TokenRing0/0
 ip address 137.10.78.7 255.255.255.128
 ring-speed 16
!
router eigrp 100
 network 137.10.74.0 0.0.0.63
 network 137.10.78.0 0.0.0.127
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip http server
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r7#

--------------------

r8#r
Building configuration...

Current configuration : 1292 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r8
!
logging buffered 10000 debugging
logging rate-limit console 10 except errors
enable password radnor
!
ip subnet-zero
no ip finger
no ip domain-lookup
ip host bb2 137.10.98.100
!
no ip dhcp-client network-discovery
!
key chain cta_r78
 key 1
  key-string cta_r78
!
!
!
!
interface Loopback0
 ip address 137.10.8.8 255.255.255.0
!
interface Ethernet0
 ip address 137.10.98.8 255.255.255.0
!
interface Serial0
 no ip address
 shutdown
 no fair-queue
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 ip address 137.10.78.8 255.255.255.128
 ring-speed 16
!
router eigrp 100
 network 137.10.78.0 0.0.0.127
 network 137.10.98.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
ip http server
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r8#

------------------

r9#r
Building configuration...

Current configuration : 1237 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r9
!
logging buffered 10000 debugging
logging rate-limit console 10 except errors
enable password radnor
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
key chain cta_r69
 key 1
  key-string cta_r69
!
!
!
!
interface Loopback0
 ip address 137.10.9.9 255.255.255.0
!
interface Ethernet0
 ip address 137.10.98.9 255.255.255.0
!
interface Serial0
 bandwidth 1544
 ip address 137.10.69.9 255.255.255.240
 no fair-queue
 clockrate 2000000
!
interface Serial1
 no ip address
 shutdown
!
router eigrp 100
 network 137.10.69.0 0.0.0.15
 network 137.10.98.0 0.0.0.255
 no auto-summary
 no eigrp log-neighbor-changes
!
ip kerberos source-interface any
ip classless
ip http server
!
!
alias exec i show ip route
alias exec r show run
alias exec c config t
alias exec u undebug all
alias exec b show ip bgp
alias exec bs show ip bgp sum
alias exec s show ip int brief
alias exec w write
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
 escape-character 27
line aux 0
line vty 0 4
 exec-timeout 0 0
 password bp
 login
!
end

r9#



This archive was generated by hypermail 2.1.4 : Mon Feb 02 2004 - 09:07:37 GMT-3