RE: Redistributing statics into ospf

From: R&S Groupstudy (rsg@synergy-networking.co.uk)
Date: Mon Jan 05 2004 - 08:31:14 GMT-3


Hi - consider using route tagging OR prefix lists OR "match inerface" here.
the problem with using access-lists, is that they match smaller subnets as
well.

your solution will be something like:

!
ip route 15.15.1.0 255.255.255.0 null0 tag 1000
!
router ospf 111
redistribute static subnets route-map match_tag_1000
!
route-map match_tag_1000 permit 10
match tag 1000
!

OR

ip route 15.15.1.0 255.255.255.0 null0
!
ip prefix-list my_prefixlist seq 10 permit 15.15.1.0/24
!
router ospf 111
redistribute static subnets route-map match_my_route
!
route-map match_my_route permit 10
match ip address prefix-list my_prefixlist
!

OR

int Looopback 40
ip address 15.15.1.1 255.255.255.0
!
router ospf 111
redistribute connected subnets route-map match_my_loopback
!
route-map match_my_loopback permit 10
match interface Loopback 40

either solution will do, and you can choose to fit your network.

cheers

Adam

-----Original Message-----
From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
Stephen Skinner
Sent: 05 January 2004 10:48
To: dmitry.volkov@rogers.com; ccielab@groupstudy.com
Subject: RE: Redistributing statics into ospf

chaps ,

many thanks

i tried the subnets add-in but it didn`t work ...i will try both subnets
command again and changing the access-list

cheers

steve

>From: "Dmitry Volkov" <dmitry.volkov@rogers.com>
>Reply-To: <dmitry.volkov@rogers.com>
>To: "'Stephen Skinner'" <stephen_ski@hotmail.com>
>Subject: RE: Redistributing statics into ospf Date: Sun, 4 Jan 2004
>13:50:58 -0500
>
>Stephen,
>You should put
>redistribute connected reoute lo10 subnets <---- !!!
>and instead of "access-list 1 permit host 15.15.1.1"
>use "access-list 1 permit host 15.15.1.0" or use "match interface"
>instead of "match address"
>
> > -----Original Message-----
> > From: nobody@groupstudy.com [mailto:nobody@groupstudy.com]On Behalf Of
> > Stephen Skinner
> > Sent: Sunday, January 04, 2004 1:29 PM
> > To: ccielab@groupstudy.com; cisco@groupstudy.com
> > Subject: Redistributing statics into ospf
> >
> >
> > Chaps
> >
> > i have been working on some re-distribution problems and have
> > a quiery..
> >
> > i know i have to classfully re-distribute networks with this command
> >
> > i know i can re-dist a host using a route map ..
> >
> > i know i can re-dist a static network using a route map
> > i.e
> > ip route 198.121.1.0 255..255.255.0 null0
> >
> > than use
> >
> > access-list 3 permit 198.121.1.0 0.0.0.255
> > i just tryed it
> >
> > i know i CANT re-dist a non-classfull host using a route map
> > (it doesnt put
> > this host in the ospf dbase)
> >
> > i know i CANT re-dist a non clasffull network usign a route map...
> >
> > Question is ...is there any way of doing it ...????
> >
> >
> > here`s what i got
> >
> > int lo40
> > ip address 15.15.1.1 255.255.255.0
> >
> > router ospf 111
> > redistribute connected reoute lo10
> >
> > access-list 1 permit host 15.15.1.1
> >
> > route-map lo10
> > match address 1
> > set metric 200
> >
> > iany clue`s
> >
> > cheers
> > steve
> >
> > _________________________________________________________________
> > Find a cheaper internet access deal - choose one to suit you.
> > http://www.msn.co.uk/internetaccess
> >
> > ______________________________________________________________
> > _________
> > Please help support GroupStudy by purchasing your study
> > materials from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html



This archive was generated by hypermail 2.1.4 : Mon Feb 02 2004 - 09:07:36 GMT-3