From: Pun, Alec CL (Alec.CL.Pun@pccw.com)
Date: Sun Dec 28 2003 - 13:32:28 GMT-3
Adel,
wow! that's cool!
many thanks
alec
-----Original Message-----
From: Adel Abushaev [mailto:adel@netmasterclass.net]
Sent: Monday, December 29, 2003 12:15 AM
To: ccielab@groupstudy.com
Subject: Re: igmp profile
If the action is "permit" then there is an explicit deny everything at the
end. If the action is "deny" then there is an explicit permit everything at
the end.
The following illustrates the concept:
Initial configuration:
Receiver: (r2)
interface Ethernet0
ip address 1.1.1.2 255.255.255.0
ip igmp join-group 229.1.1.1
ip igmp join-group 229.1.1.2
ip igmp join-group 229.1.1.3
ip igmp join-group 229.1.1.4
ip igmp join-group 229.1.1.5
ip igmp join-group 229.1.1.6
ip igmp join-group 229.1.1.7
end
Mrouter: (r1)
ip multicast-routing
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
ip pim dense-mode
duplex auto
speed auto
end
Test number 1: Permit only 229.1.1.4, 229.1.1.5 and 229.1.1.6:
ip igmp profile 10
permit
range 229.1.1.4 229.1.1.6
After applying igmp filter 10 to Receiver's port of Cat 3550:
CAT1#sh run inte fa0/2
Building configuration...
Current configuration : 103 bytes
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
ip igmp filter 10
end
R1#
R1#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
224.0.1.40 FastEthernet0/0 00:09:15 00:02:30 1.1.1.1
229.1.1.5 FastEthernet0/0 00:01:31 00:02:27 1.1.1.2
229.1.1.4 FastEthernet0/0 00:01:31 00:02:30 1.1.1.2
229.1.1.6 FastEthernet0/0 00:01:28 00:02:31 1.1.1.2
R1#
R1 only received groups 4, 5 and 6.
Test number 2: Permit everything, except 229.1.1.4, 229.1.1.5, 229.1.1.6
ip igmp profile 20
range 229.1.1.4 229.1.1.6
You will not see "deny" keyword, because it's the default.
After applying filter 20 to receiver's port:
CAT1#sh run inte fa0/2
Building configuration...
Current configuration : 103 bytes
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
ip igmp filter 20
end
R1#sh ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
224.0.1.40 FastEthernet0/0 00:12:11 00:02:57 1.1.1.1
229.1.1.7 FastEthernet0/0 00:01:03 00:02:51 1.1.1.2
229.1.1.1 FastEthernet0/0 00:01:01 00:01:58 1.1.1.2
229.1.1.3 FastEthernet0/0 00:01:06 00:02:57 1.1.1.2
229.1.1.2 FastEthernet0/0 00:01:03 00:01:56 1.1.1.2
R1#
Adel Abouchaev
CCIE# 12037, MCSE
http://www.netmasterclass.net
----- Original Message -----
From: "Pun, Alec CL" <Alec.CL.Pun@pccw.com>
To: <ccielab@groupstudy.com>
Sent: Sunday, December 28, 2003 6:44 AM
Subject: igmp profile
> Hi group,
>
> The following example is taken from the 3550 command reference. My
question
> is what's the default action for the other "not mentioned" multicast
groups
> ?
>
> ip igmp profile 40
> permit
> range 233.1.1.1 233.255.255.255
>
> rgds,
> alec
>
> _______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html
This archive was generated by hypermail 2.1.4 : Sat Jan 03 2004 - 08:25:45 GMT-3